Jump to content

Saves Searches Involving Date References ("Today," for example)


Recommended Posts

I am running Evernote Windows Version 10+ on my computers and the legacy app on my Android phone.

I have a saved search that returns notes created today (created:day) and another that returns notes updated today (updated:day-0). (I also have similar ones that return that info for the last 2 days, 3 days, and week, but let's just use these 2 ). I've used these two saved searches for years and they return correct results.

The results I get on my the Windows search and the Android search are different from each other. Last night, I was seeing Windows miss notes that the Andoird app returned.

This morning, I started by creating a junk note (so that that was the one and only thing either created or updated today)and ran the following test:

1)  I ran this search: updated:day and expected it to find 1 note. Windows returned the correct note along with 5 notes updated yesterday. The Android legacy app retturned the 1 note created this morning. 

2) I ran this search: created:day and expected to find 1 note. Windows and Android both returned the same one note.

3) I ran this search: created:day-1 and expected to find 2 notes...the test note I created for this experiment and the one and only note I created yesterday. The Android legacy returned those two notes. Windows returned those 2 AND 1 from the evening of Dec. 13. (Today is December 15.) I also ran this search as follows: created:20201214 and got the same result with Widnows... the note created today (Dec. 15) and note created yesterday (Dec. 14) and a note created at 6:40PM on Dec. 13.

Obviously, the same saved search should be returning the same results regardless of the platform or version.  I am wondering if the search is somehow looking at not only the DATE but the TIME as it returns hits. In other words, a search performed on the morning of Dec. 15 for "day-1" should be searching for notes results from Dec. 14 or later. I wonder if it's searching for notes from the past 48 HOURS (or some other number of hours). I also wonder if there is a time zone error.

I also wonder (lots of wondering going on this morning) if there has been a change in the syntax language used in Version 10.

Has anyone worked enough with saved searches involving day references to shed some light?

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...