Jump to content

Syncing on iPadOS is unreliable (slow?)

Recommended Posts

Since about a month, the syncing of notes on specifically Evernote on my iPad is quite often unreliable. In the sense that updates I make on the iPad are not synced at all, or properly (maybe very slowly updated?). This leads to quite a lot of conflicted notes that I have to fix.

Additional info:

  • I use Evernote on my iMac, Android phone, and in Chrome (on Windows), and it all works fine there. The problems only occur on the iPad;
  • I am running iPadOS 13.7 and Evernote 10.1;
  • At the moment, I only use the iPad at home, where the Wifi is very reliable. Other devices in my home have no problems using this Wifi, and other apps on the iPad also do not have any connection problems;
  • I always press the green check mark to indicate that my changes should be updated;
  • I leave more than enough time between committing the changes on the iPad, and working on the same note(s) on other devices;
  • Syncing from other devices to the iPad seems to work a lot more reliable/better, so it looks like the outgoing updates are the problem; 
Link to comment

I also have a problem syncing between my iPhone and my husband's device. Both on iOS 14.2 and Evernote 10.1. It's a one-way problem for us. If I edit the note, he doesn't see it. If he edits the note, I can see it. I submitted a support ticket today (11/10/20).

Link to comment
  • Level 5

Do you use the same account, or do you share notes or notebooks between accounts ?

This is the wrong sub-forum (there is one for EN 10 iOS), but when you updated to EN 10, my experience is that you need to renew the sharing. If the message about the share is still in your work Chat, you can click on it there. Else quit the share, and create a new one.

With my wife this settled the sharing problem.

Link to comment
  • Level 5

Sorry, my post was an answer to the following one by @KimberlyinMN

Regarding your post: I am not sure whether pressing on the green sync symbol does anything - for me it just shows that it IS syncing in that moment.

If I want to force a sync, I pull the left panel down with a finger a little, and let it go. The Syncing wheel will show in the top part of the left column. Another way is to go to the app settings, position sync where you find the option „sync now“. Just a lot more clicks to achieve the same.

iPad Pro 10.5, iOS 14.2, EN v10.1. If you are still on iOS 13.7, I can give a green light for iOS 14.2. No problems, nice new features like the Scribble handwriting input by Apple pencil into nearly every field where you usually needed to type.

Link to comment

@PinkElephantWe've tried everything. New shared note, etc. The problem is only syncing from my device to his. I submitted a support ticket. We share a notebook between two separate accounts. Hopefully EN will have an update soon. (I hadn't noticed that I was in the wrong sub-forum. :) I had just searched for "Sync". (I've deleted/reinstalled the app, turned off my offline notebooks, created a new shared note, etc.) Sometimes the husband opening the note on his device erases all the adds that I've made to the note on my device. I'll hang out in the other sub-forum to hopefully see a "fix" message. Thanks!

Link to comment
  • 1 month later...
  • 1 month later...


One thing that helped with our syncing issues (between my iPhone SE 2020 and my husbands iPhone X) is to turn off iCloud sync. This had been turned on for my phone and off for my husband's. This helped for awhile but it's still super buggy for our syncing. Sometimes when I add something (and force a sync), he might see it... or he won't. After he opens our shared note, all of my stuff is wiped out. It's just weird. (Now it's just easier to text him to add this or that to our shopping list.) 

Link to comment
  • Level 5

@bhermans @KimberlyinMN Hi there, I think the guy who posted right on top of you is not for real, or is following a commercial interest by posting here. He posted on several old threads with iOS issues, always promoting this „problem solving“ software for iOS, that you need to buy and install on a Windows PC for using it.

This is BS - iOS is much too closed than to allow a Windows PC a deep access into the OS to fix anything there.

So I think this person should be ignored.

Regarding syncing issues with EN iOS, mine are solved since EN iOS v10.4, running iOS 14.3 on all of our devices.

Link to comment
  • 5 months later...

The present problem is that notes ARE being synced quickly but then not showing in the Notes list until the client is relaunched OR the note is searched ... then it's added to the Notes list.

Clicking Notes makes no difference.

They should show up automatically (right?)


Link to comment
  • Level 5

Hmmm - from where are these notes synced ?

If they are synced, but don’t show, how do you know they were synced at all ?

A like more details would make it easier to understand what happens.

Are we talking about EN iOS v8 (This thread is in that subforum) or v10 ?

Link to comment
  • 1 year later...

This is so frustrating, I crated a calendar event note and went in to edit and it just sits there trying to sync.

I am on the latest version of Evernote for ipad, and I will have to say I am experiencing a lot of performance issues, where the app is slow and buggy.


I have attached a video clip of the issue. Funny thing is the main reason I was recording the video is to record how each time I copy and image into Evernote it creates 2 duplicates! Instead I captured the note just syncing and taking forever to load and allow me to copy and paste my image.

Link to comment
  • Level 5

A 16 second clip says nothing. A lot of hype, no content.

The green triangle does not tell „Oh, I am trying to sync, and it is soooo hard“. It only means „This note still needs to sync“, nothing more.

When syncing a little turning wheel would appear top right. And when it has synced, the green triangle disappears.

From my experience it can take a minute until it syncs. Most of the time it is faster, but not always. If you want to force it, you can pull down the note list a little, and let go. Or go to settings, synchronization, sync now.

In case of a calendar note it probably needs to wait for an answer of the Google calendar through the API before it can sync at all.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...