Jump to content

Evernote not automatically recognized as app to open classic note link and then doesn't open it in a new separate window


Recommended Posts

Classic note links are a crucial part of my workflow. I paste classic internal links to notes into tasks in my task manager and in other apps that I use for my personal knowledge management, but when I click on the link in one of these apps, Evernote is not recognized anymore by my Mac as the app that can open the evernote:/// link. I get this message box (see attachment).  

It is in Dutch but it says: 
There is no app selected to open the URL evernote:///....
Find an app in the App Store that can open this document or choose an exisiting app on your computer. 
Cancel - Choose app.. - App Store.

When I click on Choose app, Evernote is not in the list of suggested apps, so I have to click on Options and then on All apps and then I can finally select Evernote as the app to open the link with. 

Then, when it finally opens in Evernote, the note is not opened in a new window. Evernote just shows the note in the main Evernote screen, and it also doesn't show the note in the notes list, so I can't double click it to open it myself in a new window. 

This has been a problem since the new version 10 was released and it still happens every time in the latest version 10.2. Could it be that this problem (not automatically recognizing Evernote for opening evernote:/// links) can be fixed with some setting in my Mac settings?

Mac cant find app to open classic Evernote link with.png

  • Like 4
Link to post
  • mvdweer changed the title to Evernote not automatically recognized as app to open classic note link and then doesn't open it in a new separate window

+1 on this being an important part of my workflow. Seems like an unfortunate oversight or a bad call to launch v10 that breaks this. Worse, the format of the app links makes it impossible to otherwise glean what note you were linking to, as the note title is not partially exposed in the link like web links.

Please fix 🙏🏻

  • Like 2
Link to post

Thank you @gazumped. I'll consider this option because this issue really slows down my workflow. I'm not fond at using two versions at the same time though. I'm ok with some missing functions at the moment but I hoped that this issue (not automatically recognizing Evernote for opening evernote:/// links) could be fixed with some setting in my Mac settings. That's why I also reported it here and not just via the Feedback-button in Evernote.

  • Like 1
Link to post

Internal links are central to my workflow. When I discovered that I could put Evernote internal links into my to-do app (Things 3), my Kanban Board (Kanbanier), and into my calendar, and documents, etc, ... my workflow/productivity system was on steroids!  I suspect that Evernote knows that only a small percent of users use internal links and have decided to deprecate them. The situation may be similar to tags (not on the chopping block, but de-emphasized). According to Ian Small's interview on The Paperless Movement (YouTube), only 2% of users use tags, so they are not important enough to receive any serious attention. My guess is that the same applies to internal links. 

I'm sure I speak for other 2-percenters when I say that we need to know Evernote's plan for internal links. Are they on the list of items to bring back to Evernote, or forever gone? I'll add that one App internal links do not work in is Notion, which is also an electron app. I'm wondering if this is an electron limitation.

Link to post

I'll add that internal links even work on my iPhone! I use this feature all day long, as my job is on the go. I set up the internal links on my computer the night before (to-do's in Things that link to Evernote), and then get work done using my iPhone throughout the day -- the links open directly into Evernote in iOS (no web interface). Such an awesome productivity enhancement!

Link to post

I don't believe that Evernote decided to depricate the internal links. In 10.2 they even added a separate menu-item so we can choose between the web link and the app link. I hope that the issue with the links that I reported, is due to a small bug or a setting on my Mac.

On my iPhone the results are varying, depending on which app I open the link from. It works fine when I open a link from Todoist, Trello or Roam. It also works fine when I click on a link to a note from Notion or Apple Notes while Evernote is closed. But when I do this while the Evernote-app is already opened, it just shows the notes list or the note that was already opened in the app. It doesn't open the right note. 

Link to post

This honestly seems like an accident. 

If when you click an app link you choose "Choose Application..." in the modal that pops up, you can then click "Options", then in the "Enable" dropdown choose "All Applications", the choose "Evernote". And the link works.

So the code that accepts, parses, and sends you to a note based on the link is all there and working.

The issue seems to be they forgot/overlooked/didn't get to registering the URI scheme with macOS so the OS knows to shoot those links automatically to Evernote.

If true, this is a very simple fix. Hopefully they'll get on it soon.

  • Like 5
Link to post
  • 4 weeks later...

Yeah, I think you're right. I tried to modify info.plist myself to register the URI (it's not included) but it made evernote keep crashing. Which, is apparently a known issue that you can't modify the plist yourself (see: https://discussion.evernote.com/forums/topic/40722-infoplist-modification-crashes-evernote-for-mac-vs-521-401574/). But looks like it was previously registered based on the screenshot they post. 

Link to post
  • 4 weeks later...

Does anyone know if this has been resolved yet? This is a critical part of my workflow with various notes held in evernote and accessed from external apps. To deprecate this deliberately is another nail in the coffin for evernote for me.... I was already considering moving to something like Devonthink before this.... 

If anyone can update or provide a fix, that would be most gratefully received.

Link to post

For me, this is still not working (version 10.5.7). Together with the many loading issues that keep occurring, this becomes really annoying. 😕

  • Like 1
Link to post
  • 2 weeks later...
5 hours ago, brian_t_grant said:

What task manager are you using? I use App Links with Things 3 every day of the week and it has been working just fine for me for quite a while.

I don't think this is about the task manager that I'm using; which is Todoist. On iOS everything works great. But when I click on an evernote:/// link on my Mac, either the situation that I described above happens (Todoist), or nothing happens (when I click on a note-link in my Chrome browser (within Roam or within Trello). 

It is that Evernote is just not recognized automatically anymore as the app that the link should be opened in.

Link to post

You're right, I would hope that which application it is wouldn't really matter. On a different thread, I shared some troubleshooting that I did with a number of apps on my computer. With the exception of Microsoft Teams which wouldn't allow a evernote:/// URL to be assigned to the selected text, everywhere I tested App Links they worked.

I see in your original post that you were on 10.2; have you upgraded to 10.6?

If you haven't already done so, you might try deleting the Evernote app and downloading a new copy. I have a vague memory from my days of doing Mac desktop support that, when an application is copied from a disk image or similar, that was a time when the OS would check for any file/URL handlers that the app wanted to own. There may be other ways to go about this process, but deleting & downloading another copy seems like it would be the most simple.

Sorry you're having this issue.

Link to post

Hi @brian_t_grant. Thank you for your suggestion to reinstall the Evernote app. I had not thought about that yet. Unfortunately it didn't work. 🙄

Before I reinstalled, I already had the most recent version (10.6.9), because each time a new one comes out I'm very eager to see if this issue has been solved, so I'm updating it asap each time. But I tried reinstalling anyway, because you made me remember that this sometimes solves strange problems. I even shut down my laptop for a few minutes before reinstalling the app. 
Since my first post, I also upgraded my system to Big Sur (now on 11.1), but that didn't make a difference either.

So still no solution. I hope someone from Evernote will soon read this. I pointed it out to them on Twitter this week (after praising them about the new HOME-page, which I really think is great).  

  • Like 1
Link to post

+1 for this issue.   App links stopped working since v10 release.  I mostly use them from Things 3 as part of my regular task workflow.  Within Evernote they're OK.

I can use the dialogue box to "open with..." Evernote, but have to change the application filter from "Supported" to "All" for this to work, and the setting does not persist.

 I'm on 10.6.9 now

  • Like 1
Link to post

@Menno Borst Since the issue still wasn't fixed with Evernote 10.8, I finally tried installing SwiftDefaultApps and I'm happy to say that it works now. So thank you for this 'solution'. Though I still hope that the Evernote team will fix this issue. 

Link to post

+1

N.B.: Linking to Evernote notes from my calendar is absolutely crucial to my workflow. That such basic features have been fumbled (drawing on iPad is another one: it's absolutely horrible) whilst Evernote is releasing new ones (e.g. Home) signals that they haven't shaken off their previous habit of bloating the app before the basics are done right - the whole reason they fell behind to the competition.

To underscore the point: on MacOS, if I click "Send Feedback", I get the message "We are listening." And, you guessed it, the feedback link doesn't open correctly. It goes to Safari and says it can't find the page. What a mess. If Evernote were listening, they'd have delivered the basics and the features people have been asking for for years, like encrypted notes (available on Notejoy, Apple Notes, Bear...).

I have very little hope that Evernote will listen to this about the x-callback-url problem. No doubt they're busy cooking up some new feature nobody needs. 

Come on Evernote! Start actually listening and sort out the basics!

 

Link to post
  • Level 5*
50 minutes ago, Jorma said:

I have very little hope that Evernote will listen to this about the x-callback-url problem. No doubt they're busy cooking up some new feature nobody needs.

Being a subscriber,  and rather than complain about issues in a -mainly- user-supported Forum,  you (and everyone else here who had this happen) could complete a support ticket direct with Evernote.  That brings it to their attention in a timely manner, gives them some accurate idea of how many are affected, and the opportunity to collect some logs,  if needed,  from individual machines to check what's going wrong.

As to encrypted notes and the like - Evernote have only just finished a root-and-branch rewrite of their whole package to bring the code up to the standard which would allow them -maybe- to add new features.  There's a long list of thousands to get through,  and I hope they'll do that soon - after bug fixes (like the links) and restoring all the old features you know and love,  which is still ongoing.

  • Like 3
Link to post
  • 1 month later...
  • 2 weeks later...

Found the answer on a YouTube video comments section - delete your Evernote and re-install from the Evernote website - NOT the App Store. (Apparently the App Store can be slow to update with the newest versions.) This fixes the internal link issue. Here's the how to link: https://help.evernote.com/hc/en-us/articles/208314248-Reinstall-Evernote

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...