Jump to content

Premium: Can't login, can't password reset, can't reach support


Recommended Posts

I recently just purchased premium on another account where I had been using across two devices since 2013.  When I finally decided to go premium, apparently, I can't login via the web because it wants me to change my password.  But I can't change my password, because a reset email link is never sent to me.  What's even better, I submitted a ticket 4 days ago (because chat doesn't work) and I have not heard from anyone.  Does this company still exist (I hope so, cause Apple took my money for them)?  Or has anyone had a similar experience who can help me before I'm completely just done with evernote?

Link to post

I have been a premium user for years and recently wanted to reach out via chat during the posted available hours. Has always said “you’ve reached us outside regular hours, etc”. I’m starting to wonder if we’re getting what we’re paying for. They keep going up in price, yet the service seems to be lacking.

Link to post

Unbelievably poor, well non existent, service. I've been trying to renew my subscription and can't get hold of anyone in support - tried email but that link just kicks you out of being logged in, chat not available, twitter got half an answer then silence. Just tried messenger. Bad bad bad

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...