Jump to content

Unable to clip on Firefox, while chrome one works

Recommended Posts

The clipper stays "クリップを保存中...(Saving clip...)" state until the timeout error occurs, and never start to sync on Firefox.
Webclipper for Chrome works for the same page, so it's the problem on Firefox Clipper.





Message did timeout

Evernote Web Clipper Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0
Clipper core: 1.5.0-98592b5
Locale: ja
3978984 experiments status:
 "SaveButtonPos_CLIPPER-1768": null,
 "ClipTypeOrder_CLIPPER-1992": null


  • Like 1
Link to comment

I'd like to agree with this post : I think you might have a problem in Firefox with web clipper extension.

I've been using both FF and Evernote for 3+ years together and this is the first time that 50%++ of my clips fail with 'Saving clip' timeouts.

I've tried the normal reboot, etc but, this problem seems to be occurring consistenly across multiple computers.


Link to comment
  • Level 5*

Hi.  As you probably know Firefox and Chrome effectively represent separate operating systems from Mac or Windows,  and in the browsers case are updated on a more or less daily basis.  It's entirely possible that Evernote was caught by surprise by a change somewhere.  Since these two are pretty popular browsers,  you can bet that if the staff didn't pick up on this themselves,  quite a few people have now alerted them.  Short term -  use alternative ways to clip a page.  Hopefully it'll get fixed soon.  

Link to comment

Yes - this is an issue still. It is not universal however - some pages clip fine while others never clip at all

I noticed the problem on ebay trying to clip shopping items but I've seen it go both ways on other sites

If you turn on logging in the extension, you can see the errors: 'ERR Channel: Message 'fetchUrl' failed with error: ' & so forth

I tried turning off other extensions while troubleshooting w/no impact

Link to comment
  • Level 5

From my experience if Web Clipper has a problem to clip a page, it has more to do with the page and the browser than with Web Clipper.

If I look at browsers, and on a desktop (mobile runs under different rules), there are currently 3 „engines“ on which browsers run: Chrome / Chromium, sponsored by Google, Safari based on Apples Web kit and Firefox based on the Mozilla Engine. Chrome based browsers have by far the largest market share.

Because each „engine“ interprets web sites differently, web clipper does not work the same in each browser. If you run into a problem using one browser, switch to another, and try again. It should be a browser based on a different engine, because if the underlying engine is the same, the problem will probably not go away.

Link to comment
  • 3 weeks later...

It is not a page problem. Web Clipper on Chrome (over macOS) doesn't clip anything anymore. At all.

The clipper popup appears, I can select the content, assign tags, etc. But the Syncing will never start the progress-% bar, nor it will ever succeed at storing anything. "Syncing" will go on forever, till the tab is closed.


Checking the `background.html` page of the browser extension I can see that the Javascript failure is:

> Message did timeout


commons.js:25 Uncaught (in promise) Error: Message did timeout
    at commons.js:25
    at Array.forEach (<anonymous>)
    at Channel._removeTimedOutMessages (commons.js:25)
    at commons.js:25
(anonymous) @ commons.js:25
_removeTimedOutMessages @ commons.js:25
(anonymous) @ commons.js:25
setTimeout (async)
_updateTimeOutCheck @ commons.js:25
_removeTimedOutMessages @ commons.js:25
(anonymous) @ commons.js:25
setTimeout (async)
_updateTimeOutCheck @ commons.js:25
_handleResponsePromise @ commons.js:25
_handleDispatchResponse @ commons.js:25
_handleMessage @ commons.js:25
_listener @ commons.js:25

In the Network tab of the DevTools over the background.html page I cannot see any request failing (404 or others). Everything has HTTP status 200, but the syncing reports timeout anyway.

This is occurring since at least one month, and is making Evernot a lot harder to use.

Link to comment
  • Level 5

Browsers update all the time, WebClipper needs to follow, and sometimes does not make it. This is when users notice.

IMHO it is wise to use a number of browser (with different engines) to have at least one of them usable at any time. WebClipper will update, but sometimes it takes a while to adapt to the latest browser releases. And then we do the Uninstall - Reinstall - Test -cycle again.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...