Jump to content

Impossible to download Web Clipper from the Mac App Store

Recommended Posts

When I try to update to version 7.12.4 of the Clipper the Update button fades and I just get a perpetual spinning wheel in the MAS app's title bar. I see that several other people are having this issue. If you look on the MAS web preview page the failure to update was already reported on Feb. 27. What is going on here, Evernote team? It's just bad quality control.

And meanwhile v.7.12.3 is periodically crashing Safari 13.1. – after all the long-time issues were supposed to have been fixed.

Very disappointing.

Nonetheless, stay safe everyone.

Link to comment
  • Ex Employees

Hi there, it sounds like you're encountering some difficulties with the Safari Web Clipper. It is strange to hear of these specific issues you're seeing and I feel you on the frustration. Let's investigate this in more detail together.

First, in your Safari Clipper > Settings screen, if you're seeing version - 1.0.5 (30) listed, this is currently the newest version. The 7.12.4 version you see in the App Store is actually the 7.12.3 version in the Clipper itself. Definitely confusing and is due to a mismatch between the build we post and the build Apple displays. This is something we're working on resolving in future releases as yes, both should be consistent. That being said, if you're seeing - 1.0.5 (30) in Clipper's Settings, you shouldn't also be seeing the ability to update in the App Store as you should already be on the latest version. Does an uninstall and reinstall possibly help resolve this so you see - 1.0.5 (30) in Clipper's Settings / 7.12.4 in MAS (but with no ability to "Update" only the ability to "Open" in MAS)?

Second, for the crashes you're seeing in Safari 13.1, some more information may be helpful to try to pinpoint the possible causes. A list of the websites (if you're comfortable sharing them and if there's any consistency about where/when/how you notice the crashes) would enable us to try to recreate this on our end. Additionally, and other details of how you isolated the crashes to the Web Clipper could also be helpful at your convenience.

Link to comment

Thanks for responding Jay-Bob.

1. Yes, I have been using v. -1.0.5 (30). It was this version that was repeatedly crashing, and when I found a reference to v.7.12.4 I tried to update unsuccessfully.

2. The crashes have seemed to happen randomly, and most often when Safari is running in the background. I have now tried opening the identical set of 9 tabs which I usually have running in Safari, this time in Firefox with its own Web Clipper extension. So far, after 24 hours, Firefox has not crashed. (If it does soon I will get back to you.)

The Safari crashes happen, by the way, whether or not the Evernote app itself is open. The crashes have also occurred whether or not I have other Safari extensions enabled. I've tried testing a lot of variables for some months now, to attempt to pin it down before finally reporting the problem to you.

Below are slices of the crash report which seem most relevant:

Process:               Safari [10159]
Path:                  /Applications/Safari.app/Contents/MacOS/Safari
Identifier:            Safari
Version:               13.1 (13609.
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Safari [10159]
User ID:               501
Date/Time:             2020-05-11 16:06:28.908 +0300
OS Version:            Mac OS X 10.13.6 (17G12034)
Report Version:        12
Anonymous UUID:        08DF0677-C54C-6427-9C13-2536FF74B0F9
Time Awake Since Boot: 460000 seconds
System Integrity Protection: enabled
Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00007521de7bbec8
Exception Note:        EXC_CORPSE_NOTIFY
Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]
VM Regions Near 0x7521de7bbec8:
    Stack                  000070000919f000-0000700009221000 [  520K] rw-/rwx SM=COW  thread 25
    MALLOC_TINY            00007fc080400000-00007fc080500000 [ 1024K] rw-/rwx SM=PRV  
0   libobjc.A.dylib                   0x00007fff548cb174 objc_release + 36
1   libxpc.dylib                      0x00007fff5584737f _xpc_connection_dispose + 57
2   libxpc.dylib                      0x00007fff55840be9 _xpc_dispose + 51
3   libxpc.dylib                      0x00007fff55847309 -[OS_xpc_connection _xref_dispose] + 47
4   com.apple.Foundation              0x00007fff2f672122 -[NSXPCConnection dealloc] + 327
5   libsystem_blocks.dylib            0x00007fff5553f99d _Block_release + 111
6   libdispatch.dylib                 0x00007fff554b7db8 _dispatch_client_callout + 8
7   libdispatch.dylib                 0x00007fff554cc217 _dispatch_queue_serial_drain + 635
8   libdispatch.dylib                 0x00007fff554bf166 _dispatch_queue_invoke + 373
9   libdispatch.dylib                 0x00007fff554ccf0d _dispatch_root_queue_drain_deferred_wlh + 332
10  libdispatch.dylib                 0x00007fff554d0d21 _dispatch_workloop_worker_thread + 880
11  libsystem_pthread.dylib           0x00007fff55808fd2 _pthread_wqthread + 980
12  libsystem_pthread.dylib           0x00007fff55808be9 start_wqthread + 13
Here's hoping you can identify the problem – and remedy it!
All the best to all the team. And STAY SAFE!
Link to comment
  • Ex Employees

Thanks @cornetg. In those 9 tabs do you ever have Clipper open and running (e.g. you click the Elephant icon and leave it open in a tab but don't complete the clip and close clipper) in any of them? Or do you have a Business and Personal account signed in at the same time? After the crash happens, would you mind sending your Evernote Clipper activity log? Any other details on steps to reproduce these random crashes would be helpful so I can then get this relayed to the development team. Thank you - you stay safe as well!

Link to comment
  • 4 weeks later...

Ssup everyone!

Where can I get previous Web Clipper for Safari? Mac App Store requires OS X 10.12 to download but I'm using 10.11 El Capitan on Macbook Air 2009

Please help! I will be thankful if you mail me on bashlykkazan@gmail.com


Link to comment
  • 2 weeks later...
On 6/7/2020 at 10:56 AM, WiggaFoeLie said:

Ssup everyone!

Where can I get previous Web Clipper for Safari? Mac App Store requires OS X 10.12 to download but I'm using 10.11 El Capitan on Macbook Air 2009

Please help! I will be thankful if you mail me on bashlykkazan@gmail.com


You should still be able to download the clipper directly from the website.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...