Jump to content

I can't log into evernote even though the internet is good

Recommended Posts

Hi Evernote team,

I encountered the exact same problem.

After I clicked sign in the page keeps saying "Loading...", both on Google Chrome and Safari,. I tried clearing cookie and browser data, logging in anonymously but to no avail.

When I tried to create a new account it gets HTTP ERROR 418, also I could not sign in to Desktop version as well, it tells me to upgrade the version all the time although I've already grabbed the latest one.

I asked my friend and he said he could log in normally with his account so I have no clue why mine wasn't working.

Could someone please address these issues? Thank you so much!

Screen Shot 2020-05-06 at 08.45.56.png

Link to comment

Hi all,

I have installed Windows 10 on my PC, then I installed Evernote with the latest version.

Once done, I tried to open Evernote but I encountered an issue like below:


I tried disabling SSL 3.0 and enabled TLS then restarted the PC but it didn't work.

I tried installing Evernote with the older version but the error still occurred.


Does anyone resolve this problem?




Link to comment
  • 5 months later...
  • 1 month later...
  • 3 weeks later...
  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...