Jump to content

iOS clipper not working for NYT pages


Recommended Posts

The iOS Evernote clipper option never actually saves the page even though is says it does when I'm trying to save a page from the New York Times (seems to still work on other sites). This is a real pain as I can no longer "trust" Evernote to have done what it said it had done. Here are links to 2 pages that did not save:

https://www.nytimes.com/article/disinfectant-coronavirus.html?referringSource=articleShare

https://www.nytimes.com/2020/05/06/well/live/coronavirus-cleaning-cleaners-disinfectants-home.html?referringSource=articleShare
 

Link to post
  • Level 5

Just tried 3 methods on the first link you provided, iPad Pro, iOS 13.4.1. The NYT web site was open, Cookies confirmed, then I clicked on share:

  1. Simply clicking on the EN icon, confirming to save
  2. Choosing a shortcut (shortcuts app) to „share article with EN“
  3. Choosing print, then create a pdf in the print window, share to EN

You can see the result: All 3 methods resulted in a new note, containing the article. Because I use different methods, the look & feel is different. But the content was clipped in all three runs.

Conclusion: EN seems to work fine. Maybe there was something that went wrong when you tried to clip. One possibility is embedded advertisements - they sometimes use weird code. I am using a pi-hole Ad blocker that eliminates most ads from my internet traffic.

So it may be that if you run into problems like this, the „print to pdf, share to EN“ method will work around it. You end up with a Pdf, which is fine if you want the content. Just keep in mind that all Hyperlinks will not be working in the pdf.

 

image.thumb.jpeg.bb459720c0975605876d20cbcbd9d05b.jpeg

 

image.thumb.jpeg.b0fc80dbe4f697ee89b5bd2a308d6655.jpeg

Link to post

Thank you so much for your detailed response PinkElephant. As soon as I saw your interface screenshot I realized I had misspoken – this was not happening in Safari on iOS but from within the NYT app itself (I forgot that when I clicked on links in emails it's the app that opens not Safari). So my question now is - can the Evernote link be fixed to work properly from within the NYT app (accessed via the usual square box with up arrow icon)?

Link to post
  • Level 5

Each app is a closed biotop, ruled by the apps maker (and some general rules from the OS). So it depends on the App maker what he will allow and support - and what not. From my experience with news apps most will try to lock the reader in - no or reduced sharing options, no carry over of content to other apps etc.

A receiving app like EN can’t do anything about this, because the sequence is like this: source app to (i)OS, iOS to receiving app. Information that is not allowed to reach the OS-Level (like the clipboard) is not available to any other app.

So you have to do what I did: Use the browser if you want to reach out for content.

Link to post
  • 5 months later...

The Clipper is useless in iPad. It does not clip most of my used sites like the-Ken.com, stratechery.com, Bloomberg Businessweek, Economist and so on.

Evernote support is useless. Asked for videos, etc but then no response.

Link to post
  • Level 5

Probably it depends on the web site. I experience the same with the new iOS client, many web sites don’t clip well.

That iOS shortcut I used for better clipping does not work with v10 any more.

The only option that still produces good results is the „print to pdf“ version. It does not grab the URL, so in my workflow I copy the URL from Safari manually and Paste it manually into the EN note with the pdf. Takes some clicks and time, but makes the note complete. Furthermore the pdf does not support Hyperlinks. So it is a workaround, not a replacement for a web clipper.

Link to post
  • Level 5

I agree clipping in iOS sucks.

But in fact on iOS there is no real web clipper, like on desktop. The desktop clipper installs as an extension to the browser. This is not possible in iOS. So the clipper uses the iOS share function instead. The clipped content then must be „nested“ into the note, which works better with some, but not so good with many other web sites.

If it does not work, AFAIK the only solutions are through the pdf workaround, or to clip the site from a desktop with the real web clipper installed. The 3rd option through the „clip“ shortcut got axed by EN v10, which does not support shortcuts.

Link to post
  • 4 weeks later...

Another (needless) workaround that works correctly. Save the NYTimes article from within the iOS NYT app to your Pocket account. Then export to Evernote from Pocket and it works like a charm. URL, formatting, ad-free. Still seems this is a permissions problem between NYT and EN apps. I granted Pocket my NYT login info and it works fine. 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...