Jump to content

Installation/update issue

Recommended Posts

(.\Bootstrapper.cpp:984) 0x643:Fatal error during installation.

Windows 10 Pro

Version: 1909

OS build 18363.657


First time I got this problem when tried to update my current version of Evernote (308859) Public (CE Build ce-62.6.10954) to

I also tried to install Evernote from .exe file downloaded from official web-site and got same error.


Link to comment
  • Level 5*

Hi.  Always best to post in the update thread where the developers are watching for issues,  but this one has come  up before - the error seems to mean the existing MSI file which allows the updater to uninstall the older version of Evernote has been corrupted somehow.  The 'easy' fix is just to reinstall the old version of Evernote,  then uninstall it and try the new one again.


Link to comment

I have been attempting to install 6.24 now for a week.  I wanted to try the solution above but I no longer have the EXE for version 6.23 to attempt to re-install.  Uninstall of 6.23 is not an option since the evernote.msi is apparently corrupted.  Any other ideas?

Link to comment

The 'easy' fix implies I can get a copy of the MSI for a previous version of Evernote.  The problem is the download page only provides the latest version.  I can't find previous versions anywhere on the site.  I also can't uninstall Evernote because that results in the same error.

2020-03-12 13_23_44-Evernote Upgrade Error.png

Link to comment

Never mind.  I was able to solve this the hard way.  On the download page, I copied the hyperlink from "If your download didn’t start, click here."  Then I pasted it into the browser and manually changed the numbers to the version I needed from information contained in the "Add or remove programs" system setting in Windows.  In my case:

Version 6.24.2:


Changed to version 6.23.2:


I then ran the installers in order, version 6.23.2 followed by version 6.24.2.  This successfully upgraded my computer to the latest version of Evernote.

Hope this helps everyone else.

  • Like 2
Link to comment

Sadly boiler95's method doesn't work for me. If I attempt to uninstall the current version I get an "install server not responding" message. Reinstalling the current version on top of the current installation doesn't help. Do I need to uninstall manually or something?


Where is the update thread that Gazumped refers to?



Link to comment

Today I rebooted my PC to install Windows updates and received update in Evernote. It is not clear what solved the issue, but update was successfully finished w/o any additional steps from my side.

Link to comment
  • Level 5*
2 hours ago, TXC said:

Today I rebooted my PC to install Windows updates and received update in Evernote. It is not clear what solved the issue, but update was successfully finished w/o any additional steps from my side.

Maybe you had a Windows issue that the updates fixed - glad you got it sorted out,  anyway...

Link to comment
  • 3 months later...

I could not auto-upgrade or manually upgrade to Getting same error:

(.\Bootstrapper.cpp:984) 0x643:Fatal error during installation. 

I was able to uninstall the previous version ( I think?) using Windows, but the new version would still not install.
Now getting an error about being unable to access this file:


Tried running that msi file in situ as recommended by Mike P above, but got the same (ironic) error message.

I found installers for many previous Windows versions here: https://evernote.en.uptodown.com/windows/versions 

 but the one I tried gave the same file access error.

Solution: move said installer file <Evernote.msi> from that temp folder into the Downloads folder, and ran it there.

(Did the older version of the msi file first, and then the newer version by the same method. Not sure that the reinstallation of the older version was necessary though.)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...