Jump to content

Blank screen on login to web client on Windows


Recommended Posts

I signed up for the web client beta, and now get a blank screen when I log in through Windows. I use both Mac and Windows platform frequently, so wonder if it's related to having used it on a Mac more recently?

Thanks for any help - need access here at work on my Windows machine!!!!


Link to comment

In case this happens again or someone else has a problem, this happened to me on one of my computers and I had to do some digging in the chrome developer console. It turned out that my chrome hadn't been updating and I was still on version 68 or something. Updating chrome to newest solved this. This was on a computer running linux, so our problems might not have been the same 😕



Link to comment
  • 7 months later...
  • Level 5
On 10/7/2020 at 5:07 AM, GameManiac101 said:

Help, same thing happened to me... It's not the problem with the Google Chrome mine is the latest version, care to help? my exam is literally tommorow

This has happened to me quite a few times. I find that clearing cookies, even just the last hour's worth, will fix it.

Link to comment

Hello everyone!

I had been facing the same issue for a week. It would one time just appear and other times it would just be blank. I tried clearing the cookies, using the Incognito version, multiple browsers. Everywhere, it would work sometime and again be blank for the most of the time.

I use Linux but I believe the following simple solution will work for all.

Just revert to the older version of Evernote. How to do it? Just go to https://www.evernote.com/Settings.action In Account Summary, find out Evernote Web and click on "Go to previous version". Then go to "Go to Notes" on the top right of the page. It worked on mine and also a few others who were facing this.

I think the new Web Client version is facing some issues loading in some browsers and Operating systems. Whereas Web client runs fine on my friend's laptop, it does not run on mine. Hope Evernote team is working to fix it.

Thanks a lot! And thank you Evernote for being an important part of my life!

Link to comment
  • 3 months later...

I use Linux and Firefox as the web browser. Evernote was working fine earlier and suddenly it was stopped working. Then I switched back to Evernote older version and it fixed my issue(Thanks to @Arunabh). But later I considered to update my web browser. Now new version is also working fine.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...