Jump to content

Why can I no longer use the Web Clipper in Safari?

Go to solution Solved by Ana P.,

Recommended Posts

Safari 12.0.3. It worked perfectly until a few days ago. it continues to work fine with Chrome. I use Web Clipper extensively for research and may have to switch browsers just to be able to continue to use it.

Link to comment
  • Level 5

Has nothing to do with premium or not. WC is a (by all means) a basic function of EN. Maybe try another Browser as a workaround. Not very practical, I know, but the standard procedure would be to un-/reinstall. And you are past it ...

Link to comment

I had already uninstalled and reinstalled twice. The difference was that now at least I get the message that Web Clipper is "loading." Unfortunately that's as far as it goes.  I've been using Web Clipper heavily for years and never had a problem. I didn't upgrade or anything and no other app has started to misbehave. It does work fine with another browser. Curious.

Link to comment

Mojave 10.14.3, Safari 12.0.3, Web Clipper updated yesterday.

In those instances when Web Clipper does load in Safari, instead of getting the usual box asking if I want to clip "article," "simplified article" etc, and offering "organization" by notebook, it simply creates a large green box around the entire page with + - at the top and the  bottom. I have no idea what that's all about and it doesn't seem to do anything.

Link to comment
On 2/5/2020 at 9:47 PM, BMoose said:

Safari 12.0.3. It worked perfectly until a few days ago. it continues to work fine with Chrome. I use Web Clipper extensively for research and may have to switch browsers just to be able to continue to use it.

I did the auto-update of the Mac OS and now the Evernote Web Clipper is not working. The extensions says that version 12.3 is in use and the new Web Clipper version is 12.4.  The screen said to go to the Mac App Store and when the installer Web Clipper started, nothing happens. The Safari preferences window appears but I cannot delete the old version. The screen message is that a component of the Web Clipper is in use. 

I think we have a loop problem in the software and it cannot update.  HELP!!

1-Web Clipper appears.png

2-Safari extension.png

3-Installer directions.png

4-Error message.png

5-Web Clipper not in use.png

Link to comment

I had the problem that I would log into the Evernote Webclipper, it would ask me to sign in. Then it would bring up a box that it uses cookies, but never let me clip anything. I checked that I have cookies allowed for Evernote. Still only this dialog box came up, without actually clipping anything.  (Webclipper 6.13.2, Safari 12.1.2, macOS 10.14.6)

I went to the webclipper page on the Evernote website. https://evernote.com/features/webclipper

Clicked that I would like  to "Get Webclipper". It took me to the Mac APP store to download. I installed from the app store. App Name: Evernote Web Clipper

After installation, the Safari  Preferences > Extensions -  Box Came up. I deselected the old webclipper 6.13.2. And I selected the new webclipper extenstion 7.12.3

It works now. I suppose I could uninstall the old webclipper now. 

Hope this helps. 

Link to comment
  • Level 5

Information: Since WebClipper is a Safari extension, it is ONLY available from the AppStore. Thus the link from the EN website takes you there.

For the app itself, one can install from the AppStore or directly from the website (if enabled in the Mac settings). In my experience one should always use the direct version.


Link to comment
  • Solution


As a first step to isolate the issue, please make sure you are on the latest Safari version (Safari 13). If the issue continues, it is probably because the old Clipper version is still installed and causing conflict on updating to the new version. 

If this is the case, please try these steps to uninstall the old Clipper version:

1. Open Safari and select Safari > Preferences from the menu bar.
2. Choose Extensions > Evernote Web Clipper > Uninstall.
3. Quit and reopen Safari.
4. Once Clipper is uninstalled, please go ahead and reinstall it from the App Store.
  • Thanks 1
Link to comment

Ana P., I'm also having problems with web clipper. I'm in Safari 13.0.4, Catalina 10.15.2. Web clipper doesn't appear in my browser bar anymore. Nor does it appear in my extensions list. When I try to download the app, it just spins and spins. I've tried many times over several weeks. Any ideas for me? Thanks!

Link to comment
  • 7 months later...
  • Level 5

You are posting on an old thread.

Please create a new one - your problem is most likely not related to what was discussed here.

Safari is now on ver. 14, and the recent web clipper extension that is working with it is Version: - 1.0.7 (40). Whether this version of WC works with Safari 12, I don't know.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...