Jump to content

Chrome web clipper doesn't offer "selection" for clip format

Recommended Posts


I'm trying to clip part of an article from Lifehacker, and Firefox seems to be challenged by the content that I'm trying to clip. I thought I'd try with Chrome, but there doesn't appear to be an option to clip a selection. Is my Web Clipper broken (I have the latest version), or does Evernote not support clipping by selection on Chome? If not, why not? ...thanks!


Link to comment
  • Ex Employees

Hi @emkay, the Selection option should still work in the latest version of Chrome with the latest Clipper version 7.12.4.

You first need to highlight your selection on the webpage itself and then invoke the Clipper, then the actual "Selection" clip option should appear.

Here's what I see in Chrome:


However, these are the same steps as they are for Firefox which you're showing works as expected - and worked for me too there, so it is strange you're seeing different behavior in each browser.

  • Like 1
Link to comment
  • 2 months later...

Hi, Jay-Bob ... sorry I didn't get back here to see this response before!

Indeed, I was selecting the part of the web page that I wanted to clip, but still the clipper wasn't offering selection. When I tried again a few days later, all was well. I forgot to follow-up here.

Thanks for the help! ...cheers! -mk

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...