Jump to content

Template replaces spaces with nbsp;

Recommended Posts

I saved a note as a template (it is a table) and it is full of nbsp; code where there should be spaces.

It looks like this before I save it as a template:


And it looks like this in My templates, and like this when I create a new note using the template.

image.png.e9a796c1f0b68468635d6910a63c1097.png image.png.c827dd363619bff512aef33974746e44.png


Link to comment

I just tested it/had a go for you, on my EN-Windows v6.18.4, and I did not experience this issue. I saved a note with text and table, text separated by spaces, then saved as template, then applied template...but again nothing.  Annoying when these bugs come up...maybe you used copy and paste from another doc!?  If yay try creating from scratch in EN.


  • Like 1
Link to comment

Thanks for the test RavBoy.  I just spent some time chatting with Evernote, and it seems that the issue might be when the first thing in the note (or perhaps the first thing in the first row of a table where the note is just a table) is an internal link to another Evernote note.  I say this because when I viewed the note I was using in the new Evernote Web, the first thing I got was "HTML Content". I'm troubleshooting that now, by creating a note in Win10 and another in new Web where I just have a table and the first thing in it is an evernote link. Then I'm going to create a template from each note on both platforms, then I'm going to create a new note using the template with both platforms. We shall see.  



Link to comment

Ok, that's it. I'll be telling the evernote folks.

Some things trigger Evernote web to include a "HTML Content" notice in the notes on the web. If you were to save that note as a template and then use it, you would get html code (so far just the spaces ( )) everywhere in the note. Your best bet is to re-create the note from scratch, avoiding the things that cause that notice to appear.

What causes it? The one thing I know is that if you have text in one cell where you are using two different formats (maybe a different colour, a different font size) in the same cell you will get the notice (when you look at the note on the web). That's what triggered it for me.  Once it got triggered, even deleting the row of the table in which the cell appears will not fix it; the space codes appear elsewhere in the table the minute you have a space in a cell (or perhaps only a formatted cell?).

My guess is that other things might trigger this, but I don't have time to spend another 5 + hours troubleshooting.


  • Like 2
Link to comment

I reported this "nbsp" and template issue about 30 minbutes after the template feature came out years ago. I wasn't even using a table but I was  using different fonts with different attributes. One line was a label (eg: 10pt, blue, bold, underlined) and the next I wanted to have indented with a larger font. The only way to get Evernote to "remember" that the line was to be a larger font was to have something on the line, I chose a space to be invisible but keep the font selection alive for that line.

Every "place-holding" space character  in my template was translated into the 5 characters "&nbsp". when I tried to use the template.

I stopped trying to use templates then and never tried since. Duplicate worked just as well as templates so I gave up on them.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...