Jump to content
We apologize for the inconvenience, but chat support is currently unavailable. Please feel free to submit an email ticket or reach out at discussion.evernote.com. Thank you for understanding. ×

Search PDF Problem

Go to solution Solved by PinkElephant,

Recommended Posts

I am a Plus user.

I use NAPS to scan my documents and save many as PDFs. NAPS will OCR the document when saved as PDF. There are two documents, one is a PDF with the keyword in it. The other has the keyword in the title.

When I search on the Windows desktop, it will find both documents using the keyword. But when search in the Android version, it only finds the document with the keyword in the title, not in the PDF. Both are updated. I cleared all data from the Android app, then logged in and downloaded it all. But same result. Is this behavior by design? Or a new problem?

Link to post
  • Level 5*
7 minutes ago, charlieedstrom said:

But when search in the Android version, it only finds the document with the keyword in the title, not in the PDF.

For the Android search, are you online?

Do you have offline notebooks?

On my iPad, if online the search uses the web indexes

Link to post
  • Level 5

In the Android app, a peculiarity of search is that it will only find results in titles as you type the search term; only after you hit the search button (on my keyboard, a magnifying glass) will it proceed to search all content, including OCR'd material in PDFs. I just tested this again a couple of times, and found it to work consistently.

Link to post
  • Level 5
  • Solution

Probably the similarity results from using the same search engine. The mobile clients perform a lot of functions on the EN server, whereas the desktop clients for Windows and Mac hold a local copy of the database, with a local search index.

Link to post
  • Level 5
14 hours ago, charlieedstrom said:

I know what you mean, and I do find the active search as you type usefull, but this is after hitting the magnifying glass. I'm just surprised also to find this happening in the web client.

That is surprising. It seems as if the OCRed layer provided by NAPS is not being indexed in the process used by the Web and Android clients. My experience is with PDFs indexed by Evernote itself, and on these it seems to work. Would it be possible to test that in your setup--attach a non-OCRed PDF to a note, give EN time to OCR and index it, and then search?

Link to post

Good suggestion Dave. I created a PDF document without the OCR function and brought it into my desktop app. Then synced it. 

What I noticed was the desktop app could already find the document by using keywords inside the PDF before it synced. It was my understanding PLUS account can't search for PDF documents contents, only PREMIUM accounts. This seems more like a built in function of the desktop app, which I was not aware of. A nice bonus.

After waiting a while, the android and web versions do not find the document by its content so the account features for PLUS versus PREMIUM are working as designed. Its just the desktop app that functions differently.

Link to post
  • Level 5

OK, my bad--I failed to note the difference in types of accounts. And that does seem to be it: if you want this to work on Android, you're going to have to upgrade. If you're using Evernote a lot for this purpose in a professional context, it might be worth it.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...