Jump to content

Screen Snap--> Capture not working

Recommended Posts

This wasn't happening before I upgraded my computer. Is skitch compatible with the new mac system? 

Anytime I try to take a screenshot, the image does not capture what's on my screen - it takes a screenshot of my desktop background instead. I've tested this on my computer and my colleagues' and can confirm it's only happening to Macs that upgraded to the new Catalina system. 

Please advise as Skitch is rendering useless right now. 

  • Like 2
  • Thanks 1
Link to comment

When I got to my settings and look at the screen recording section, I only have 2 apps listed I can give permission to and Skitch is not one of them, even though I have skitch downloaded on my mac. Please help! I need skitch! 

Link to comment
  • 4 weeks later...

Skitch was working so far without any issues. I recently updated the OS and its now macOS Catalina (mac airbook 2017 model).  When i tried to take a screenshot, only the underlying desktop/wallpaper image was captured.

Skitch version - 2.8.4

I even uninstalled and reinstalled the app. I still could not capture what i wanted. 

Link to comment
  • 1 month later...
  • Level 5

If it does not show, the installation has not taken place, out of whatever reason.

Make sure you have the necessary admin rights with the User you use, and try again. Make a complete uninstall of all Skitch-related stuff before by using the app AppCleaner, to start this with a blank sheet.

Link to comment
  • 3 months later...

I removed Skitch with AppCleaner, reinstalled from the App Store, but Skitch did not request screen recording capability, nor can I find a way to add it. Skitch is currently not usable for me on a freshly installed load of Catalina.

Link to comment
  • 4 weeks later...
On 3/30/2020 at 9:49 PM, Mikerj said:

I removed Skitch with AppCleaner, reinstalled from the App Store, but Skitch did not request screen recording capability, nor can I find a way to add it. Skitch is currently not usable for me on a freshly installed load of Catalina.

I had the same issue after recently swapping computers for work. It's likely that you downloaded Skitch and it's operating from the default download directory instead of Applications.

  1. Close Skitch
  2. Open your finder and locate where the Skitch app is
  3. Drag the icon into Applications
  4. Relaunch the Skitch program from Applications

After this I was able to take screenshots again, even without setting permissions.

Link to comment
  • 5 months later...
  • 3 months later...

Skitch needs to be screen recording permission, but it's not showing up in Screen Recording apps for your Mac user.

I fixed like this:

  1. Log in as another admin user on your Mac. You might need to make one. 
  2. Launch Skitch and take a screenshot.
  3. Now you should be able to give screen recording permission.
  4. This permission will automatically show for your primary user, too.

Hope that helps!



  • Thanks 1
Link to comment
  • 8 months later...

This was working for me, and I use skitch a lot to take screenshots and annotate them.


Today I have to restart my MBP M1 and skitch is only screenshotting the desktop not the real window.  I tried restarting the mac, I tried removing the permission to screen recording and then allowing again but nope.


Any clue or help what is going on?



Link to comment
1 hour ago, PinkElephant said:

No idea - works for me without any problems (BigSur 11.6, Skitch Mac 2.9).

The Screen Recording permission is the key, and Skitch must be restarted once after allowing it.

I did restarted skitch when I try to remove the permission, and did it again when I allowed the permission so I guess is not that.

Only difference is that I have scheduled 11.6 for tonight update.  But doesn't make sense (IMHO) that I have to update Mac OS, unless skitch has been updated recently.

With very few hope I will try updating the OS.


Thanks anyway

Link to comment
1 minute ago, PinkElephant said:

It worked for me before 11.6, and after.

Only difference in setup is that I am running on an Intel MacBook Pro 15“ - but usually this should work. I think Skitch is still running through Rosetta, since it was last updated in 2020.

It doesn't make sense at all.  This early morning I did an screenshot without problems.  Then it started to make captures only of the screen background.  I restarted twice.  I tried to remove and then give back the security permission (record screen).  I have updated OS o version 11.6 and restarted again.


Nothing works.  I am going to try reinstalling.

Link to comment
  • 3 weeks later...

My skitch app is not only recording the background.  I'm on a mac desktop with Catalina 10.15.7.

My skitch is version 2.9.

My privacy screen recording box is selected for skitch.

any tips or suggestions?






Link to comment
  • Level 5

No ideas beside the usual, you already mentioned the correct setting in the Macs preferences. It worked for me back when I was on Catalina, and it continues to work on BigSur (currently on 11.6).

Quit Skitch and EN, restart the Mac.
Try again

Uninstall Skitch, restart the Mac, reinstall.
Try again

Link to comment
  • 1 month later...

Starting a week ago, Skitch will not take any screenshots anymore.  Screen Recording permission is on.  I suspect that the recent Catalina Security Update may be the culprit, but I'm not sure?

Intel MBP w/ Catalina.  10.15.7 (19H1519)

Skitch Version 2.9 (265153)


When I press "Screen Snap" *nothing happens*.  Funny enough, I can take a screenshot with Mac's built in shortcut (Cmd+Shift+4) and drag that into Skitch, then Edit it...but thats a rather cumbersome workaround.  

Screen Shot 2021-12-10 at 9.29.14 AM.png


Link to comment
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...