Jump to content

Why my web clipper can't use on Safari 13?

Go to solution Solved by SYu,

Recommended Posts

  • Level 5

You have to give it a go by checking it off in the settings. There is one Box to check before it can do its job.

There are other threads here that show screenshots, if you do not know what to do.

And maybe you should update, Catalina is at 10.15.1 already.

Link to comment
  • Level 5*
1 hour ago, SYu said:

I use safari 13 on MacOS 10.15.
After install the new web clipper, it  still can't use on my Mac.

What's wrong?

Please show us your extensions page.  Here's mine38471085_ScreenShot2019-11-01at14_39_40.png.1f1f2f1ad6e8033e247dcd6426fd5773.png

Link to comment
  • Level 5

The influence of traditional Chinese is hard to test for me, sorry. Maybe you could issue a support ticket for yourself and the other users in Taiwan.

Yesterday I had another problem: I had updated to 10.15.1, tried to get the WebClipper update as well, and it got stuck in the AppStore. The blue ring stayed at „1 before 12“, and would not close, neither could I stop and reset.

Then I decided to do a complete uninstall, first through the trash, then cleaning out with AppCleaner. I made a reinstall, which worked just fine, authorized the access and my WebClipper is back to business.


Link to comment

Believed that there is a bug inside Web Clipper.

After Catalina upgrade, I can't click Web Clipper, and now I have installed the latest version of Web Clipper, it still doesn't work.

Surely I do enable the extension on Safari. 

This issue has existed for a long time after Catalina, but seems Evernote is not aware of this issue in TW, I am very disappointed as a premium user... 


Link to comment
  • Level 5

If there would be a bug in general, there would be NO working installation. Mine does work ...

There may be a problem together with another app or configuration - to find this a support ticket would be the appropriate next step. They can view analytical data, which the forum users can’t.

Link to comment
  • 2 years later...

Got in touch with Evernote support and they confirm there is a problem with web clipper in Safari 13. They advised to upgrade the OS to get newer version of Safari. Which I can't on my iMac 2011 stuck in High Sierra.

Work around: use Chrome or Firefox. Firefox does it for me, and web clipper works well in it.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...