Jump to content

Can I search notes or only attachments?

Recommended Posts

I tried a search (for the very first time on android) and got a pop-up telling me that since I was "Premium" I could search attachments and PDFs too. This is wonderful but the search I tried had the text in the body of the notes (Windows finds 5 notes) rather than in an attachment. Nothing was found. It just says "Try another search."

As I mentioned, Windows reports 5 matches and what's even funnier is that the very first note in "All notes" had the text in it. Actually it was the very first word of the very first note (sorted by title) that I was searching for so I expected it would be found there at least. I already knew exactly which notes had the text, I just wanted to see how long it would take Evernote to find it.

Is there something beyond "Premium" that I have to subscribe to in order to search the body of notes?

btw - This was on a Samsung S6 tablet so CPU power/memory speed isn't an issue.

Link to comment
  • Level 5

Certainly search should find text in the bodies of notes. (You can also search specifically for words in titles, as @DTLow says.) I just tested a search and succeeded, on a Samsung phone. If you've truly just installed Evernote on your tablet, I wonder whether it takes a moment to create the necessary index. (I really don't know, just guessing.) If it continues to fail, you might try reinstalling Evernote (after first making any offline notebooks online temporarily, and doing a sync). That could perhaps recreate an index that's being searched. If the failure persists, I'd open a support ticket.

Link to comment

OK. Who's doing the magic? The search did not work on Thursday. I tried it on two tablets (S4 and S6) and tried it on my phone (S10+) and it did not find the text/word I entered. I read your replies this morning and was going to grab some screenshots to show the non-result and presto - it worked.

I haven't done anything different in the last few days. Just routine PlayStore updates and the occasional Evernote sync on the tablets but now it works.

Maybe I was searching too soon after adding the records to Evernote. I've been running EN on Android for years but never tried a search before, so perhaps it was just timing that foiled me. But, it's working so I'm happy.

Thanks for the assistance.

  • Like 1
Link to comment
  • Level 5*
2 minutes ago, OrbWeaver said:

Who's doing the magic?

The Evernote servers?

Notes are uploaded to the Evernote servers and undergo processing, for example OCR for search indexing

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...