Jump to content

Core Spotlight uses high CPU when running Evernote


Recommended Posts

For several months now, whenever I have Evernote running on my Mac I've noticed the corespotlightd process takes a higher than expected CPU percentage.  It could be anywhere from 25% - 45%.  It's significant enough that it drains my battery more quickly than it used to (I've been using Evernote for a couple years).  It got to the point where I stopped using Evernote and switched to OneNote.  But after using OneNote for a while, I think I like Evernote a lot better.

So, I'm back to trying to figure out why corespotlightd keeps running with a high CPU percent when Evernote is running.  I uninstalled Evernote and reinstalled and still get the same behaviour.  I've let it run for a long time so if it's indexing, it's really taking a long time.

Any suggestions for how I can resolve this?

Paul

Link to post
  • Level 5

No idea. On my MacBook Pro EN is completely silent, only taking up a small fraction of available CPU. It only spikes when I put load on it, like searching or other jobs.

Could you be more specific on MacOS, EN version, if it was installed directly or from the AppStore, and the Mac you’re using (model, year, CPU, RAM).

Link to post
  • 3 months later...

I'm having the same problem with a new Macbook Air, Evernote 7.14 update has been installed.

When I have used the search function within Evernote at times the fan kicks in. Otherwise it never kicks in. 

I then check the Activity Monitor and find that 'corespotlightd' is using more of my CPU than Evernote, enough such that the Macbook begins to overheat thus prompting the fun to run.. 

 

Link to post
  • 8 months later...

I'm having this problem as well on my 2019 Macbook Pro, with a fresh install of macOS 10.15.6 and Evernote 7.14. While Evernote is running, corespotlightd uses 100% CPU, and stops a few seconds after I (completely) quit Evernote. The bug is also causing corespotlightd to write absurd amounts of data to disk (over and over again): over a few days before I realized what was happening, the process wrote almost 6 TB of data! I'm hoping it was all buffered and didn't hurt the life of my SSD :(

Is there any hope of getting a response from Evernote about this 1 year old problem? Apparently I can't submit a ticket since I don't have Premium, but this bug makes Evernote very difficult for me to use, since I can't leave it running.

Link to post

For anyone else who comes across this: Anibal kindly made a ticket for me, and the Technical Support folks said this is a known bug: it has been fixed in the new client for Mac, but we'll just have to wait until that is released. They said some people have worked around the problem by completely uninstalling Evernote using AppCleaner (checking all boxes for items to be removed; this will delete your local notes!) and reinstalling, but the problem came back for me as soon as I re-imported my notes.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...