Jump to content

macOS 10.14.6 - Just updated Evernote to v7.12 - Evernote process using up to 98% just to scroll through a note after the update.

Recommended Posts

Hi all, 

TL;DR - I'm new to the forum, an Enterprise technical support engineer (this means I'm not a noob noob) using Evernote Premium daily for work without issue. That is until I updated yesterday to v7.12 for macOS. Now scrolling through a note fullscreen or windowed mode causes Evernote to spike it's CPU usage to 90-100%. This is making Evernote unusable and I'm trying to study for an AWS certification exam...please help! 



I'm new to the forum as I've never had a need to post here. However, I'm having an issue today that I didn't have yesterday and the only difference is the Evernote update 7.12. 

Before I go into the issue further, I'd like to mention a couple things in the hopes I won't get replies with comments like "have you tried rebooting?" or some variation of that. So..

  • I am an IT professional working for an Enterprise storage company as a technical support engineer. Essentially, I'm not a noob noob and before ever posting to a forum or calling a support line I troubleshoot the issue as far as I can, then I google every possible work combination to find someone with similar issues. However, I've not found one post about v7.12 for macOS with similar behaviour. 

A few things noteworthy...

1. The particular note I'm using was being used yesterday without issue, only now after the update is it showing this faulty behaviour. (Yes I've rebooted, at which point OSX installed is own update but this didn't fix anything nor did I expect it to). 

2. Yes I've tried both full screen and windowed mode, behaviour is the same. 

3. No I have not tried to roll back to the previous version yet. Before doing this, I wanted to confirm if others have experienced this issue or not. 

4. The particular note I am scrolling through does have screenshots but they are not even close to being large enough to require 98% CPU. I don't think for a second the screenshots are to blame, but admit it's definitely a possibility. 

  • In fact after writing the above paragraph I've tested it with a large text only note and I managed to hit 100.7% CPU usage by scrolling up and down quickly. I've never had issues like this with Evernote. 

5. Lastly, I use Evernote premium everyday of my life at work to document my investigations. With 4 screens (1x 4k, 2x 1080p, and laptop display) plus 5-6 or more applications open at all times, I've never seen my laptop lagging the way Evernote is when trying to scroll right now. 


Image 1 - MBP specs and macOS version confirmation (Just to clarify I have enough computing power to scroll through a single note with a few screenshots embedded in it)



Image 2 - Screenshot of Activity Monitor and realtime matching CPU usage per core (in a simplified view - gee thanks Apple) 



Ok so after all that, my simple questions are...

1. Is this a known issue? (can't find any reference to this type of issue for v7.12) 

2. Have others experienced or are others experiencing this? 

3. If so, have you tried to fix it and if you have, did you have to roll back version?

4. Has anyone tried using 'nice/renice' to lower the priority of Evernote? If so, does it work or just make Evernote less usable? 



I'm currently trying to study for an AWS certification and this issue is making my core note taking app unusable. I've just wasted an hour or more trying to troubleshoot this issue and I could really use some help please. If rolling back is the answer, I'll do that but don't want to unless it's necessary.


  • Like 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...