Jump to content

Unresponsive after intitle:something search

Recommended Posts

After a search: intitle:SometingHere

When I leave evernote to use some other application then come back to Evernote, it becomes totally unresponsive (especially after trying to change the search term). Removing Evernote from memory and restarting it always works. This problem has persisted for several versions. I just recently realized that it happens after an intitle:xxx search. 

  • Sad 1
Link to comment

Search: “This is a string” also left evernote locked up after leaving and coming back. Fortunately, I’ve never had data loss because of this.

System: iPad Pro running the latest iOS version & latest evernote.

Link to comment
3 hours ago, PinkElephant said:

Do you get the Data Sync wheel turning (Screen top right) while the App does not react ?

Thanks for the question. I watch for it the next time it locks up. (Just now I tried several times to get it to lock up and it would not fail.)

Link to comment
  • Level 5

With me, it is like that:

The locking up when switching the app was a bug. It was reproducable and depended on a text string in the search field. But it was resolved with one of the last releases. I am now on 8.20.

When currently the app is locking up, it happens when the little data transfer wheel is spinning. It sometimes spins a long time ...

If I then close the app, and reopen it, it is usually back to normal. Hard to reproduce though. Actually, it just happened to me, when I wanted to look up my current app version (see screen shot). Placed a support ticket on it right now. When I get an answer, I will post it.


Link to comment
  • Level 5

My app is back to normal.

My observation: I had set some of my notebooks to „offline“ before. This caused some heavy syncing from the servers to my iPad. Probably this caused the app to be unresponsive - it had not failed, it just did not react as long as the data transfer wheel was spinning.

The offline notebooks now show that the sync is through, and the app is back to normal again.

I am still in contact with support, maybe they can confirm the issue. 

Link to comment

Offline Notebooks: Interesting - it doesn't matter whether the notebooks are offline or not.  I had a premium account (and had all my personal notebooks set for offline) until a month ago, and it behaved the same back then with a premium as it does now with the basic account.

Link to comment
  • Level 5

With me still no problem since the download of all that stuff went through. Updated to 8.21 in the meantime, still everything is working just fine. Except of trash and a notebook I use for archiving, all other notebooks are now offline on my iPad.

On my iPhone I depend much more on the server notes, because I have not made much offline available there. But it is working as well, now on 8.21, no issues. Even when on mobile and with 3G, the app is fully responsive, except for the short breaks when it is actively downloading something after opening a note.

Link to comment

This is a problem for me with intitle:  searches as well as bringing a note up via Siri voice cuts, leaving evernote to another app, then coming back to Evernote frozen. All my offline notebooks have been fully downloaded.

Evernote’s iOS app was getting much better for me, but this latest update has multiple problems.

Link to comment

Yeah, I have three support requests in. Also, Evernote on iOS almost instantly times out for me on a fast iPad. Reloads a note even if I swipe away from it for less than 10 seconds. Also, formatting a block of text one color, going to another note, then coming back to it the formatting is gone. 

This iOS update has been a hot mess for me. @PinkElephant did downloading the offline files go quick on your iPad? I might do a full reinstall, but last time I did this it took a week to get from Evernote servers and fully downloaded. Was something to do with their servers not my broadband speeds..

Link to comment

 Well, some of these problems aren’t happing on the phone like they are on the iPad. Doing the full reinstall.

update: and a fair warning if you do a full reinstall and also use a lot of voice shortcuts to notes.  ⚠️  

Deleted app and reinstalled to resolve problems. Now hundreds of Siri voice shortcut are gone. Not only that, but I can’t use the same voice shortcuts I used before since “phrase is already in use.”

I’ve become accustomed to the voice shortcuts I set, now they are registering as already in use. How can these be tied to the device and also unavailable?


Link to comment
  • Level 5

Offline download: I have a pretty fast Internet at home, so if there was something slowing things down it was not that. I think the problem was that every time the app was not at the front, or the iPad went to sleep, the downloading stopped. In total I have 10GB of downloaded data for the EN app, and it took appr. 2 days to get it done.

On the iPhone I just have very few notebooks offline, those that I will really need on the fly (travel, inbox, stuff like that). Actually I do not use the app often on the iPhone, because it is just quick retrieval, not working on the notes as on the iPad.


Link to comment
  • Level 5

On their last official EN video with Ian Small they have posted some interesting information about how they changed their database to make it more performant and responsive.

In short they had one central read/write structure before that had to serve all traffic. On finding that the main traffic is read only, they created several read-only copies of the central hub, that spread the read traffic among them, with a regional twitch. So all write Traffic still goes to the hub, but read requests will be handled by a distributed base of cloud servers closer to the users.

Maybe I was just lucky to download after this was done ...

But still given that the iOS devices are much more similar to each other than the Androids, I am amazed that some experience heavy problems when others report solid performance. I would expect a more coherent behavior of the iOS user base.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...