Jump to content

Skitch drag and drop still doesn't work on Mojave or Skitch 2.8.4


Recommended Posts

Dark mode update today YAY.

3 years of users reporting drag and drop no longer works without a fix. NAY.  

Thousands of screenshots later - I've been using Skitch and Evernote for 12 years since 2007, so close to moving....

Are there any Evernote/Skitch developers on here?

Link to comment
  • Evernote Staff*

Hi!
Sorry you're still running into problems. Can you clarify or give me steps to reproduce the drag and drop problem you're seeing? We fixed a few of them but not all. 

Link to comment
  • 2 months later...

I'm having a similar issue. I'd like to drag a Skitch image, which has been saved in Evernote, into an Outlook email. I can grab the image, I can seemingly move it to an Outlook email, but when I "drop" the image nothing appears.

Details:

MacOS Mojave, 10.4.6

Evernote 7.12

Skitch 2.8.4

 

Link to comment
  • 3 weeks later...

Just wanted to add to this while looking for an answer on this myself. I was previously on Mac 10.12.6 Sierra which was working flawless, but when upgrading to 10.14.6 Mojave this issue started occurring where dragging a screenshot from Skitch to anything else would often provide a blank screenshot. On testing further however I noted that if I change the name of the screenshot in the bottom-left corner of Skitch before dragging this, the dragging feature would work 100% of the time. This is at least a workaround for now, though it would be nice to see this resolved.

If you need any more info from me, let me know and I'll check back a few days a week in case there's any update.

Link to comment

What do you mean by "change the name of the screenshot on the bottom-left corner of Skitch?" 

I don't see a filename on the bottom left corner of the image or of the Skitch app.

Maybe you could use Skitch to show me a screenshot illustrating what you mean. 😉

Link to comment
  • 1 month later...

Having this same issue now (dragging/drop OR copy/paste image into iMessage) since upgraded to Catalina. Never had issues before wad was up to date. 

Mac OS Catalina

Skitch 2.8.4.

I have already toggled the Screen Recording (fixed the desktop capture) but doesn't fix that I can't drag/drop OR copy/paste my screenshot into iMessage 

  • Like 1
Link to comment
  • 5 weeks later...

So here's what I have noticed since my previous post:

If you screen cap your selection, you need to go to the EDIT button at the top-left of your screen. In the drop-down menu, select COPY IMAGE. You can then paste in MAIL and in iMessage.

However, what I have noticed is if you screen cap and attempt to DRAG into MAIL/iMessage, this will not work. Further, if you attempt to COPY IMAGE from drop-down menu, after having attempted to DRAG, it will also not work. You will need to capture again followed by the EDIT / COPY IMAGE / PASTE (into Mail or iMessage).

Hope this helps some of you!

Mac Catalina 10.15

Skitch 2.8.4.

  • Like 1
  • Thanks 1
Link to comment
  • 4 months later...
On 6/11/2019 at 6:02 AM, Nick L. said:

Hi!
Sorry you're still running into problems. Can you clarify or give me steps to reproduce the drag and drop problem you're seeing? We fixed a few of them but not all. 

Dear Nick - thanks for the response and apologies for not providing more detail. 
The drag and drop feature of Skitch is still not working.  Drag to any app or desktop on Catalina (same issue in Mojave) and the Green Plus UI icon to show add shows but does not drop the file.  See the video of an attempted drag to a desktop or to an email. 
Copy and paste is only option as per above.  The drag was such an innovative UI option.  It just seems like there is one line of code unresolved to restore this functionality.
Kind regards
Paul

Link to comment
  • 2 weeks later...

Skitch responds beautifully on High Sierra. It's a permanent feature in my reports and documents... And emails. Love it.

Doesn't work on my new MacBook Pro. Same problem as above.

Glitch in skitch Version 2.8.4 (265025) for operating systems Mac10.14 and Mac10.15 using MAIL.

It works in the browser... 

 

G

Skitch_drag_and_drop_still_doesn_t_work_on_Mojave_or_Skitch_2_8_4_-_Evernote_for_Mac_-_Evernote_User_Forum.jpg

Link to comment
  • 4 months later...

I too am looking for a solution to this drag and drop issue.... BUT heres a work around no one has mentioned. If you have a screen shot THAT IS NOT ANNOTATED <--- important, you can Command A (SELECT) and Command C (COPY) from skitch and then Command V (PASTE) in iMessage. If the screen shot is annotated, only the annotations get copied, not the whole screenshot with annotations.

UPDATE. For a screen shot that has annotations...switch to the crop tool and just do a Command C (COPY) from skitch and then Command V (PASTE) in iMessage.. No Command A (SELECT) is needed.

Note the key command to select the crop tool  OPTION + COMMAND K

 

-Cheers - Tommy

Link to comment
  • 1 month later...

Hi, i have/had similar issues... i had v2.9 which failed to launch after a recent macOS update, i'm on macOS 10.14.6. So i completely uninstalled Skitch (using an app cleaner app) and downloaded a fresh copy... i now have version 2.8.1 (which seems to be working ok but no 'dark mode') and checking for updates says i'm on the latest... so, where are versions 2.8.4 and 2.9 coming from/gone? Thanks, John

Edited by johnvlang
Wanted to word it better and include OS version.
Link to comment
  • 2 months later...

hi team - I can't drag thumbnails from the thumbnail overview screen anymore using Catalina. I can only drag one image at a time from the full screen view.

It renders Skitch pretty much unusable. Is there any solve for this or plans to update?

Link to comment
  • 4 weeks later...

Hey Evernote, any updates or plans to fix this bug? I can't drag thumbnails into anything, they don't drag at all anymore. This is rendering my favorite app I use every day unusable. Please please help!!

Link to comment
On 9/7/2020 at 7:30 AM, Tommytrc said:

I too am looking for a solution to this drag and drop issue.... BUT heres a work around no one has mentioned. If you have a screen shot THAT IS NOT ANNOTATED <--- important, you can Command A (SELECT) and Command C (COPY) from skitch and then Command V (PASTE) in iMessage. If the screen shot is annotated, only the annotations get copied, not the whole screenshot with annotations.

UPDATE. For a screen shot that has annotations...switch to the crop tool and just do a Command C (COPY) from skitch and then Command V (PASTE) in iMessage.. No Command A (SELECT) is needed.

Note the key command to select the crop tool  OPTION + COMMAND K

 

-Cheers - Tommy

the issue is that I can't do more than one screen at a time - which is the point of skitch! :( 

Link to comment
  • Level 5

Personally I am on Skitch 2.9 and MacOS 11.1. My Skitch works as I am used to - and I do not understand what you want to do, and where the malfunction happens. Can you describe it a little better, maybe with a screenshot or two ?

Link to comment
  • 2 months later...
  • 1 month later...

This is something that worked years ago, but broke at some point. I used to be able to snap something and drag it directly into Apple Messages. My laptop at work is a MacBook Pro 2013 running macOS Catalina. If I try to drag a snap into a Message I get the green plus sign but the snap does not get inserted into the message. I have to drag the snap to the desktop and then drag that file into Messages.

However, it DOES work on my home laptop, a MacBook Pro 2019 running Big Sur. I can drag a snap directly into a Message. Usually Big Sur is the reason something doesn't work, but in this case it's the opposite.

I was a tester for Skitch when it was first released a long time ago. I still use it all the time, but it feels like it's just not getting a lot of attention anymore since Evernote took it over.

Glenn

Link to comment
  • Level 5

With the Catalina Mac I would check if all authorizations are granted to Skitch in settings, security, privacy. When I tried it first, Skitch didn’t even appear to be selected. This changed however when I uninstalled and reinstalled it. Since it is working fine for me, and made the upgrade to BigSur without a blink.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...