Jump to content
AronsLaw

Incredible lag while typing and using notes - Mac

Recommended Posts

I have a new mac book air, and recently I've been experiencing a crazy lag while typing and using the evernote app on my mac. I can barely use it. Very frustrating. Anybody else have this same issue, or know what can be done to rectify it. Thanks.

 

Jeff 

Share this post


Link to post

How new is new ?

And have you activated file vault ?

My experience is from a MBPro, new and shiny. A little more horsepower than the air, but it was not working well for the first days.

With support from the apple hotline, we found out that there was a LOT of background activity related to syncing hundreds of GB with iCloud plus files moved from my Win-PC and building the encrypted structure on the SSD. Because EN in itself is a database, there are many transactions going on while you are typing. It is not a simple editor, grabbing letters from the keyboard as you go hacking away.

If there is this background stuff (check for a process called „mds“ in the activity monitor, another is „windowserver“), it takes away a lot of CPU power. The Apple support has the chance to run a diagnosis through the web, so use it.

It was not an EN issue, I had „beach balls of death“ in pages, safari and other apps as well, when EN was not even opened.

After the initial stuff was though, everything started to work fine, as expected.

Share this post


Link to post

I have the same problem now on a 2016 maxed out 13" MacBook Pro. I'm getting > 60% CPU utilization from Evernote and also Apple spell processes. I tried clearing the keyboard and spelling caches in macOS with no improvement. I can type for about 3-4 words followed by a 2s delay, CPU spike, and return of normal typing speed for a few seconds. Then the process repeats. I'm not having slow downs anywhere else. I tried to give up and use the web interface, but it destroys the formatting of my notes (fun). 

 

It doesn't appear to be related to syncing, as turning off wifi doesn't fix the problem like it did when I had this behavior in version 6. 

Share this post


Link to post

See my post above.

What OS ?

Updated recently ? OS and/or EN-app ?

File Vault running ?

etc.

When I look up EN in the activity monitor, it usually just takes appr. 1% of CPU. No lag at all when typing into a EN note.

Share this post


Link to post
6 hours ago, PinkElephant said:

When I look up EN in the activity monitor, it usually just takes appr. 1% of CPU. No lag at all when typing into a EN note.

I'm glad it's working for you. It was working for me until the most recent update so maybe that corrupted my database. 

 

It's affected every note I've tested so far including a blank new note. 

 

I do have File Vault active and I'm on High Sierra, but I haven't had this problem since early version 7. 

 

I'm currently on Evernote 7.10.  

 

I filed a ticket, but based on my recent experience with Evernote support that is unlikely to be revealing. The support experiences I've had thus far have been tantamount to "can't reproduce said issue / can't be happening / etc".

 

I'll have to nuke my database and download from the server when I have access to a faster connection speed. 

Share this post


Link to post

Updating can create the most stupid situations, I agree.

Have you updated through the App Store, or by direct install ? Both say they are 7.10, but the direct version seems to be more sound.

Did you try to fix your database ? Hold the option key when opening the Help-menu. Down the menu, in a submenu you will find options to rebuild aspects of the database. Sometimes this will fix things.

Share this post


Link to post

I'll try rebuilding the indexes, thanks for the tip. I'm using the direct Evernote website download version (always have). 

 

I wonder if there's some problem with either syncing (or attempt to sync even if wifi is off), or with spell check as the apple spell process seems to go up in CPU use at the same time. 

Share this post


Link to post

Interesting observation about the spell checking. I have it running as well, with no observable effect on resources usage.

Hope you can solve the problem by rebuilding the database.

Share this post


Link to post

Unfortunately no luck. I force re-synced using shift + option + sync and also Recreate Full Text Search Index and Recreate Spotlight Search Index and I'm still getting a typing delay. I get about 1 - 2 words written followed by the blue upper right hand side indicator for the note needing to sync illuminating. At the same time the Evernote CPU process jumps to > 60%, as does AppleSpell. Then the fans kick on. Eventually the note syncs and the process repeats. 


This is only happening on a MacBook Pro. My 2018 iMac is fine, so it suggests some local issue to that machine maybe. 

Share this post


Link to post

Evernote support suggested I fix this problem by “rebooting my phone”

I sent a log and screenshot. I don’t think they are even reading the emails anymore.

🤦‍♂️

Share this post


Link to post

Crossing my fingers... A clean reinstall of Evernote and downloading all notes from the server seems to have fixed the problem. I'm still getting ~40% CPU with typing fast, but I also see this occur with other apps at times and it's not heating up the machine anymore or causing delayed typing. Also the AppleSpell process isn't spooling up anymore. 

  • Like 1

Share this post


Link to post

I doubt you can type fast enough to create 40% CPU (not even 1% CPU with plain text). If you want to monitor it more closely, you can install something like System Toolkit on your Mac.

Probably File Vault is working on the new GBs that came in from the EN server. If this is happening, it should stop soon.

Share this post


Link to post

I"m still having this issue. It is incredibly annoying and ruining my productivity at work. Anyone have any solutions? 

Share this post


Link to post

Since I still have no problem, I still have no solution.

Tried Support on this (however mixed the experience seems to be ...) ?

Share this post


Link to post
On 5/8/2019 at 2:17 PM, PinkElephant said:

How new is new ?

And have you activated file vault ?

My experience is from a MBPro, new and shiny. A little more horsepower than the air, but it was not working well for the first days.

With support from the apple hotline, we found out that there was a LOT of background activity related to syncing hundreds of GB with iCloud plus files moved from my Win-PC and building the encrypted structure on the SSD. Because EN in itself is a database, there are many transactions going on while you are typing. It is not a simple editor, grabbing letters from the keyboard as you go hacking away.

If there is this background stuff (check for a process called „mds“ in the activity monitor, another is „windowserver“), it takes away a lot of CPU power. The Apple support has the chance to run a diagnosis through the web, so use it.

It was not an EN issue, I had „beach balls of death“ in pages, safari and other apps as well, when EN was not even opened.

After the initial stuff was though, everything started to work fine, as expected.

Can you please tell me what you actually did that worked? Reading over this it sounds like you diagnosed the issue but I don't see any solution here. How did it actually end up working? Evernote is SO SLOW ITS RIDICULOUS

Share this post


Link to post
45 minutes ago, RingMyBellyButton said:

Can you please tell me what you actually did that worked? Reading over this it sounds like you diagnosed the issue but I don't see any solution here. How did it actually end up working? Evernote is SO SLOW ITS RIDICULOUS

Have you run the Activity Monitor app to get some details on your device activity?178138211_ScreenShot2020-02-02at12_19_28PM.png.77d0b3f84a1c76db6e4453bf97784068.png

Share this post


Link to post
Just now, DTLow said:

Have you run the Activity Monitor app to get some details on your device activity?

Yeah Evernote takes up 2-5GB of memory, it's crazy

Share this post


Link to post
8 minutes ago, RingMyBellyButton said:

Yeah Evernote takes up 2-5GB of memory, it's crazy

That's high - restart your device

Share this post


Link to post
3 minutes ago, DTLow said:

That's high - restart your device

Yeah it's high... is there anything I can do to stop it from taking up so much space? Restarting won't solve this problem it's been happening for years. 

Share this post


Link to post

Because on my Mac performance is still o.k. (No, looking at the data volume, syncing activities and that I have installed everything, from the main app over Helper, Skitch and WebClipper, it is excellent), I can’t really help on this. I am running a MacBook Pro 15, 2018, i7, 32GB RAM, latest Catalina and EN apps, no betas. In fact I do NOT want to find out what could change this comfortable situation.

Maybe you should give a try to involve support, they have better means to Analyse what is going on on your system.

Share this post


Link to post

I've got this problem again. Now on a fresh install i9 2019 16" MacBook. This was a totally fresh disk image, not restored from any backup. Evernote had never been on the machine before. It worked well for a few days. Now, after typing 1-2 words the sync button spools up and text entry crashes to a halt and note freezes up. CPU use goes to > 80% and AppleSpell process goes > 40%. Temps > 80c if typing for any duration of time. 

 

I'm going to have to wipe the Evernote installation and hope de-corrupts itself. 

 

Not sure this means my database is corrupted on the server side, but its weird as it only affects one machine at a time and has improved in the past with reinstalling the database. 

 

The slow down in typing definitely seems related to the sync process as though the sync event is too resource intensive for the machine. I have many other software programs with continuous save functions that don't do this and it seems a new i9 MacBook should be able to handle Evernote. 

Share this post


Link to post

Not having such a fancy Mac, just a MBP15“/i7.

Normally EN is doing fine, fast and no issues. I recently had one note where the beachball started and kept spinning.

This note contained a high number of URLs, it was a copy of a blocklist for my pi-hole ad blocker. So it contained thousands of suspicious web sites. I think EN tried to connect to all these URLs in the background when I clicked on the note. Once I deleted all the URLs and just kept the master URL where the list can be downloaded, the note immediately turned to a normal behavior.

Maybe this could be a lead for you. If you need a high number of URLs, it is better to put them into a document (like a spread sheet or text document) and attach this to the note itself. Thus the URLs will be inactive until the attachment is opened. Or put the document onto your disk, and put a link into the note.

Share this post


Link to post

That makes sense. This note had maybe 500 words, no links, just lots of indented bullet points. The note is fine on other machines like a super slow 12" MacBook from 2015. I think something is happening that corrupts the notes leading to some sync error that eats up cpu time, but I don't know. I'll see if re-downloading the data from the server fixes this hopefully for longer than a week. 

 

Update: it seems to have resolved with a new download from the server and typing is fast now even though my CPU is working hard to download all the other notes. I think this points to some corruption process occurring. I just wish I figure out how to keep if from happening. 

 

It would be great if there was an option to re-sync problematic notes rather than re-sync the entire database. 

  • Thanks 1

Share this post


Link to post

Yes, it is all or nothing when forcing a new sync. I would be happy to help, but said the one note with a lot of URLs EN is continuing just fine on my Mac. No problems,  no analysis, no fix. I hope you find out what helps in your case, and maybe you can post it here, for others that are looking for advise.

Share this post


Link to post

OK so whatever the bug is, it has happened again. So seems like I have to do a fresh download of the database every two weeks. I'm able to get the CPU up to 90C by just typing into Evernote and can't type more than three word without a lock up and sync event. No errors in the log that I can see. 

 

Very sad. At least my other machine is still usable. I may have to start using the web version (shudder). 

Share this post


Link to post

Sorry, but still everything working fine with my Mac.

So just a few more ideas, but nothing solid:

Have you tried what happens if you (for a test) you set the computer offline, to avoid syncing operations while using EN ?

What does the Mac‘s Activity Monitor show ? Any security software running ? Changes between Off- and Online ?

Did you try the options to reorganize the data base ? Hold **Option** before opening the Help-Menu. The last item (which only shows with **Opt** pressed) has subtitles to check the database.

Instead of installing fresh, you could try to force-sync the data base: Hold the **Shift** and **Option** keys on your keyboard and click the sync wheel.

Share this post


Link to post

Thanks for the suggestions. 

I tried without WIFi on and although the application isn't syncing, text still freezes about every 3 seconds or so for about 1 second leading to a block of text that suddenly appears after a delay. Activity monitor only shows high CPU use of the Evernote process > 150% and no other processes above 5%. Previously AppleSpell would be high as well, but not this time. 

I don't have a database check option when option clicking. It gives me re-indexing options or "Troubleshoot note list", which only opens the activity log. 

Shift Option Sync fixes the issue only while other syncing is happening. Typing returns to fast while the wheel is spinning and then goes back to freeing up when the wheel stops. 

My current guess is that if I make the app busy syncing notes other than the one in which I'm writing, it doesn't try to sync the note in focus and text input can be smooth. I can reproduce this with a new note, so it doesn't appear to be related to any particular corrupted note. 

I explained this to support last year and they told me to "reboot my phone"

Share this post


Link to post

I will try to get some help to you from EN. Don’t know how long it takes, due to holidays and office hours.

  • Like 1

Share this post


Link to post

@Tcellguy Thank you for reaching out!

I'm going to DM you directly to get some more information.

  • Like 1

Share this post


Link to post

Thank you both. For unclear reasons the issue resolved itself today with no reboots or other changes. I'm still on Evernote 7.14. Now typing is very fast without the constantly spinning sync wheel while typing. 

I'll keep monitoring and see if if comes back  or is associated with any clear precipitants. 

Share this post


Link to post

Glad it now works for you. The only other thing I could think about was an ongoing indexing (like Spotlight), but this should influence all applications.

If it just vanishes, fine. Maybe we get hold on it in another case.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...