Jump to content

Indent lost when copying code


Recommended Posts

Hello all,

I'm a Java developer, I'm used to copy code snippets on Evernote, and everything was working fine for my (basic) needs until one week ago: pasted code retained format and indenting. Then I had to change my laptop (I switched from an HP to a Dell) and since then, code copied from IntelliJ loses indentation on Evernote while formatting is retained. What I have tried so far without solving:

  • Downgrading Evernote up to version 6.8.7 (oldest working version)
  • Downgrading IntelliJ
  • Changing indents from spaces to tabs (and vice versa)

If I copy as plain text, formatting of course is lost but indents are present. If I copy as rich text, formatting is taken but indents are gone. Using Evernote code blocks also removes formatting. If I copy the same code text to Word, both indents and formatting are retained. What is driving me crazy is that everything was working perfectly up to one week ago on my old laptop, I was able to paste code with correct font, formatting and indents. Now indents are lost.

Do you have any idea how can I solve this?

Thank you in advance

Fab

Link to comment

IIRC Evernote uses an Android component, WebView, for some or most of the editor. I suppose you could roll back Android to an earlier version, but I'd want to do some research first. Maybe you have access to an Android device that hasn't updated in a while? Maybe you could use an Android emulator...which I've never done. I hear https://www.bluestacks.com/ is good, there are a lot of others.

In connection with another forum post, I made this table showing recent version numbers of Evernote for Android and two other components (WebView and Uno) that appear in the Activity Log. It might give you some clues as to what's changed. The table is truncated on the right in my browser (Chrome on Win 7) for some reason but you shouldn't need the info that is truncated :-)

Link to comment

I have Evernote installed on my Android device but in fact I almost never use it. The issue I have is on the Windows client. I don't use Evernote web too, almost all my notes come from the laptop version. I'm pretty sure there is a setting somewhere to solve this indent issue, I tried everything but I really cannot find the right clue.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...