Jump to content

Web Clipper stops in Firefox and on NY Times


Recommended Posts

I have been trying to deal with this problem but have not yet found a solution to this. The Evernote Web Clipper add-on on Firefox refuses to clip anything from NY Times. When I write a comment, I clip it or used to clip it to Evernote but I keep getting a small window telling me that this page has to be reloaded ... Even after reloading it, the clipper never cooperates. The odd thing is that it works in Chrome and it also works in Firefox on my desktop computer. They are configured the same, Firefox synchronizes all the settings and add-ons on both computers, I have the same Internet security, Norton on both computers. They are both Windows 10, 64-bit OS platforms. My laptop is a Microsoft Surface Book 2.

I have tried the following:

  1. Removed and added again Evernote Web Clipper
  2. Cleared all the cookies and data in Firefox
  3. Uninstalled Firefox, cleaned all the folders, reinstalled Firefox
  4. Disabled all add-ons except Evernote Web Clipper
  5. None of the above solved the problem, although, as I mentioned above, along with the very same Firefox and add-ons the Web Clipper works find on my desktop

Is there a way to resolve this issue so that I can continue using Firefox and Evernote or should I be wiser if I searched for alternatives for both?


Link to comment

Well, you are right. As I indicated in my post it works on my desktop (most of the time) but it totally refuses to clip from NYT on my laptop. Firefox configurations are identical as they are synced. This has been going on for quite a while and I reported it more than once but there is no solution. I am looking into Notebook by ZOHO although it has some features missing.

Link to comment

I have exactly the same issue. I just keep getting a notice that the page needs to be reloaded, yet when I do that, the same notice appears. It seems like the Web Clipper for Firefox has been abandoned. The version for Chrome is a different story. It shows solid advancement in terms of how I think the clipper should function. But I'm not a fan of Chrome, alas.

Screen Shot 2019-04-24 at 2.34.17 PM.png

Link to comment

Oh, I am glad I am not the only crazy one! Thank you for confirming the problem @samdale67. As they fix some of the shortcomings of ZOHO Notebook, it will be a contender. Part of the problem is with Firefox too, as Grammarly also misbehaves in Firefox especially when visiting NY Times.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...