Jump to content

Evernote for Windows 6.18 beta 3


Iriska

Recommended Posts

  • Evernote Staff

Today we released Windows 6.18 beta 3. It's available here!

Update: We reverted to the previous version of Chromium. Please find a new version of beta 3 in the above link

What’s in 6.18 beta 3?
New:
  • Security update
Fixed:
  • German: Transitional HTML entities display in the warning box when moving unshared note to a shared notebook
  • Expanded Notebooks or Stacks in Notebook Kingdom view does not keep after expanding them and returning back
  • Incorrect notebook name is shown on notification message in Japanese
  • Source url field is blank if it is set to https:// in Note info
  • Tooltip is missing from the "Save as Template" icon
Link to comment
  • Iriska pinned this topic
  • Level 5*
3 hours ago, fchandler said:

Updated to Beta 3 this morning. There is a Blank Area above Note Lists that will not go away.

Is that in all note views? I use Snippet view almost exclusively.

Link to comment
5 hours ago, fchandler said:

Updated to Beta 3 this morning. There is a Blank Area above Note Lists that will not go away.

Blank Area.png

I got the same blank area after closing a pop-up about a new Evernote add-on for Gmail.  Restarting Evernote solved in my case. By restarting  I mean choosing File --> Exit and then starting Evernote again. Have you tried to do the same?

Link to comment

1) Seeing a lot of crashes - just closes with no warning/no info.  This is largely occurring when I drag an image from Evernote into an Outlook email - doesn't happen every time, but 'frequently' - which is 100% more than the prior version of EN. 

2) in the note window, I get the text input mouse icon (upper case "I" with serifs looking pointer - sorry, the name of it eludes me) - This seems normal - except over links - I can still click a link and it goes to the link, but this mouse cursor stood out to me - prior version was the hand and pointed finger icon.

In full disclosure, I probably need to reboot this laptop anyway - maybe the problems will go away. 

Link to comment
20 hours ago, keisoko said:

I got the same blank area after closing a pop-up about a new Evernote add-on for Gmail.  Restarting Evernote solved in my case. By restarting  I mean choosing File --> Exit and then starting Evernote again. Have you tried to do the same?

Thank You. Worked for me, but have experienced other issues in the drag and drop between apps. Have gone back to 6.17.

Link to comment
  • Evernote Employee

There are multiple DnD issues (honestly? Don't DnD). The "blank space" issue has been identified.

Updating CEF (Chromium Embedded Framework - the browser) is always a dreadful process. We updated between this beta and the last. 

  • Thanks 1
Link to comment
1 hour ago, dconnet said:

There are multiple DnD issues (honestly? Don't DnD). The "blank space" issue has been identified.

Updating CEF (Chromium Embedded Framework - the browser) is always a dreadful process. We updated between this beta and the last. 

I still wonder why Evernote's  DnD implementation is so fragile in this framework?  Is CEF not intended for this kind of applications?

Link to comment
  • Evernote Employee

We had to modify the CEF source to get DnD to do what we needed. (But the problem is deeper - rolling back all our changes still doesn't get things that should work working)

Link to comment

I am observing the return of a previously fixed bug: opening a link from a secondary window doesn't follow the link on the same window, instead it opens it on the main window.  This disrupts my weekly two windows note update.

Anyone else seeing this?

Link to comment
31 minutes ago, Don Dz said:

I am observing the return of a previously fixed bug: opening a link from a secondary window doesn't follow the link on the same window, instead it opens it on the main window.  This disrupts my weekly two windows note update.

Anyone else seeing this?

Seeing this too - although, using links in a secondary window isn't a part of my normal work flow at all so I'd likely have never noticed this.
This being said... I just tested the prior version for this quirk and found the results "spotty" - sometimes links would follow in the secondary window, sometimes they'd only open in the main window.  I found a some notes that stayed consistent - wonder if it has something to do with the link being generated when one creates a note link?

  • Like 1
Link to comment
On 4/13/2019 at 9:40 PM, ej8899 said:

Seeing this too - although, using links in a secondary window isn't a part of my normal work flow at all so I'd likely have never noticed this.

Well, I uninstalled beta 3 and reinstalled beta 2.  The behavior no longer occurs in my case. 

A couple of other things are no longer happening: 1-the mouse cursor was not turning into a hand on links at all, now it is doing it normally again.  2-The Reminders link on the Note list was not visible, now it is visible again.

Uncertain whether these were caused by beta 3.

EDIT: Reinstalled beta 3, all 3 problems mentioned above reappeared.  Back to beta 2, all is well again.

Link to comment
  • Level 5*
On 4/12/2019 at 4:33 PM, dconnet said:

We had to modify the CEF source to get DnD to do what we needed. (But the problem is deeper - rolling back all our changes still doesn't get things that should work working)

Ugh. Sounds horrible. Where do I send the sympathy card to?

  • Like 1
Link to comment
  • Iriska unpinned this topic
On 4/12/2019 at 10:33 PM, dconnet said:

We had to modify the CEF source to get DnD to do what we needed. (But the problem is deeper - rolling back all our changes still doesn't get things that should work working)

I hope you can confince the CEF team to integrate the required DnD functionality into their framework. Forking the code is a never ending story I'm afraid

  • Like 1
Link to comment
  • Level 5*
On 4/12/2019 at 1:33 PM, dconnet said:

We had to modify the CEF source to get DnD to do what we needed. (But the problem is deeper - rolling back all our changes still doesn't get things that should work working)

Sometimes you are the bug, and sometimes you are the windshield.  :wacko:

  • Like 2
  • Haha 1
Link to comment
  • Level 5*
4 hours ago, eric99 said:

I hope you can confince the CEF team to integrate the required DnD functionality into their framework. Forking the code is a never ending story I'm afraid

For fun, check out the CEF repository (I'm assuming that this is the one Evernote is based from, could be wrong, though): https://bitbucket.org/chromiumembedded/cef

343 forks, to date. Never-ending, indeed... :)

(and I know that that's not what you really meant)

Link to comment
On 4/11/2019 at 5:16 PM, ej8899 said:

1) Seeing a lot of crashes - just closes with no warning/no info.  This is largely occurring when I drag an image from Evernote into an Outlook email - doesn't happen every time, but 'frequently' - which is 100% more than the prior version of EN. 

I am seeing a lot of crashes, but I can't identify any consistent pattern to when or what I'm doing.

Link to comment

I think I had 4 crashes yesterday. So frequent I've had to reinstall the production version and will re-join the beta after the next update. I was watching a webinar and trying to take notes and it crashed at least 3 times so I couldn't get the notes -- had to use the web version.

Link to comment

ver 6.18.3.8456 (308456) Prerelease (CE Build ce-62.3.7750) running on Win10 Home.

Encountering frequent fatal errors crashes. Happening at a rate around 8+ times per day. Usually occurs when I try to click open a note from the Top List view. EN won't respond when clicking the Icon or Tray Icon. I either have to reboot or go into Win Task Manager kill the EN Tray App and for good measure, I haven't checked if it makes a difference, EN clipper App. Once all EN processes are shut down I can open EN again. At launch, the All Notes List View is blank, but a sync restores everything in view. Not seeing any data loss, whatever I'm working on seems intact when EN syncs.

Link to comment
  • Evernote Employee

Recommendation: Downgrade to Beta2. Seriously. (We're working on rolling back all the CEF changes that went into Beta3. I'll need a substance abuse program when this is done.)

  • Like 1
  • Haha 2
Link to comment
3 minutes ago, dconnet said:

Recommendation: Downgrade to Beta2. Seriously. (We're working on rolling back all the CEF changes that went into Beta3. I'll need a substance abuse program when this is done.)

Which version is that? And where can I get it at this point?

I have install files for 6.17.6.8292 (Production) and 6.18.3.8456 (Beta 3, I believe).

Link to comment
2 hours ago, dconnet said:

Recommendation: Downgrade to Beta2. Seriously. 

In that case, perhaps beta 3 should be taken off the automatic update channel.  Currently it is still showing up..

  • Like 1
Link to comment
  • Level 5*
4 hours ago, dconnet said:

Recommendation: Downgrade to Beta2. Seriously. (We're working on rolling back all the CEF changes that went into Beta3. I'll need a substance abuse program when this is done.)

Hopefully it's nothing worse that espresso overload. (I was smartlucky and hadn't updated to Beta 3 yet)

1 hour ago, dconnet said:

We do have the automatic update set at 0% - but if you manually check, you'll see it. A replacement for that beta is coming "real soon".

Good luck -- hope that the rollback goes better and everyone's heart rates can drop back. Working under pressure isn't fun, it's worse when it entails undoing something that didn't work. See the scars here? And here? Oh, and over there?

  • Haha 1
Link to comment
  • Evernote Employee
21 hours ago, dconnet said:

We do have the automatic update set at 0% - but if you manually check, you'll see it. A replacement for that beta is coming "real soon".

A "new" version is available. This is a hotfix for the 6.17 GA. Because of our update versioning, this is seen as an update to the beta (because it was released later - yeah, I know. The architecture for that was set down a decade ago. Thankfully we rarely run into cases like this.).

If you're running Beta2 (or 3), the hotfix issue is already fixed, so you probably want to ignore the 6.17.7 release. (And because of MSI versioning, the installer itself knows this is a downgrade and will complain. Loudly. double sigh.)

Link to comment
  • Evernote Employee
1 hour ago, jefito said:

The day I'm asked to do installer stuff will be the day I retire...

I did it for almost 3 years at another company. Driver installs too. (Funny thing, headhunter contacted me, my skills were a perfect match - for installers. Nope! Once was enough!)

  • Like 1
Link to comment
  • Level 5*

I have beta 6.18.3 but it is asking me to install the latest version, 6.17.7 Public (308474). I wasn't paying attention to versions so said OK, and obviously got this.

 

image.png.f964ac9953e48c9b6fb717d639b665b4.png

 

The update notification: 

image.thumb.png.836515bd9a3ac9c7ee0c332f34953d5e.png

 

My installed version:

image.png.f5df050f20d3a7821be903011b9abf44.png

 

Link to comment
  • Level 5*
1 hour ago, dconnet said:

That's expected. See my post (a couple) above.

Edit: Our upgrade path doesn't play nicely with MSI (Microsoft Installer).

Ok. I didn't check for the update. It just told me it was there. I only checked to get the screengrabs above.

I too have seen crashes in the past few days, but never when using. Only after suspending and whatnot, so haven't had an issue to lose data or work.

Link to comment

I just want to add I was also automatically informed of the upgrade this morning, I did NOT look for an upgrade manually. I, too, accepted the suggested upgrade because I didn't realize it was in fact a downgrade.

So now I'm in the process of reinstalling.

Link to comment
  • Iriska pinned this topic
  • Level 5*

Reboot requirement is a new thing.

l'll have to wait to try this. I don't recall ever seeing that. Normally it just uninstalls and installs fine, and might fuss if Outlook isn't closed first.

image.png.232410f2987818b0fa942c24077e4ce1.png

Link to comment
8 minutes ago, EdH said:

Reboot requirement is a new thing.

l'll have to wait to try this. I don't recall ever seeing that. Normally it just uninstalls and installs fine, and might fuss if Outlook isn't closed first.

 

No reboot required for me - although I did "prepare" for a reboot just in case. 

 

Link to comment
  • Evernote Employee
11 minutes ago, EdH said:

Reboot requirement is a new thing.

We try to avoid this style upgrade - as I noted, we re-release Beta3. So MSI sees this new version as the same version as the old Beta3 - this is the same-version upgrade path. It's not very user friendly, so we try to avoid ever doing this publicly. However, the old Beta3 has a newer version of CEF - so any upgrade from that would cause "very bad things" to happen (because we would be violating MSI component rules). We made a conscious decision to inflict that same-version upgrade so the CEF dll downgrade would properly install.

Probably as clear as mud now.

tl;dr: Installers are hard. Downgrading files during an upgrade is harder.

  • Like 2
Link to comment
2 hours ago, dconnet said:

There's a new Beta3 now available. It should be safe! 6.18.3.8477. (The link in the initial post at the top of this thread has been updated)

Hmm, somehow I think it should have been called beta 4,  to avoid confusion with the other beta 3 (and to discuss it separately), but ok.

Link to comment
  • Level 5*

.............................................................................that was..... interesting.  Please don't ever do that again..........................................  arrgh!!

  • Like 1
Link to comment
On 4/13/2019 at 10:24 PM, Don Dz said:

2-The Reminders link on the Note list was not visible, now it is visible again.

The problems I previously mentioned are apparently no longer present, except the Reminder link on the Note list is again not visible, not sure if this is a beta feature, I did check options just to be sure.

Link to comment
  • Evernote Employee
15 hours ago, Don Dz said:

Hmm, somehow I think it should have been called beta 4,  to avoid confusion with the other beta 3 (and to discuss it separately), but ok.

True. We probably should have - it would still be 6.18.3 tho! (because of the MSI update issues I talked about before)

Link to comment
  • Level 5*

Mitigating factor in this case is that this is a beta release, so fortunately the affected number of users should be relatively small. In my case, I had avoided the earlier beta 3, and the update to the new beta 3 from beta 2 went smoothly, which I think is expected, since there's no downgrade of the CEF componentry. .

Except: installs (or the updating step in the install) will halt if you just happen to be at a breakpoint in the Visual Studio debugger; probably not  in the test suite... :)  But no problem, just F5 to Continue, and it's all swell...

Link to comment
  • Level 5*
28 minutes ago, TdeV said:

Evernote is telling me I have to uninstall 6.18.2.8380 to proceed. I think an upgrade has never told me this before. Should I proceed?

It always uninstalls, but I do think this is the first time it stops to tell you that and press Ok. If you had watched the earlier "upgrades" closely, one of the progress bars is "removing old version" or something to that effect. 

Nothing is lost. It is just removing the app files, no data, no settings. You should be ok.

  • Thanks 1
Link to comment
  • Evernote Employee
17 hours ago, TdeV said:

Evernote is telling me I have to uninstall 6.18.2.8380 to proceed. I think an upgrade has never told me this before. Should I proceed?

It sounds like this is doing the 6.17.7 upgrade (which is really a downgrade). Since you're on beta2, skip this. A new Beta3 is now available and will upgrade in the way you expect.

  • Like 1
Link to comment

Updated to version 6.18.3.8477 (308477) Prerelease (CE Build ce-62.3.7750) but now my notes appearing blank in the Windows Desktop similar as in this thread https://discussion.evernote.com/topic/111758-notes-appearing-blank-in-windows-desktop-client/

 EvernoteActivityLogLagrange.txt

The log states that the BrowserEngine does not start - with or without hardware acceleration. Notes are OK  and visible in presentation mode but will not be rendered in the note window of the client...nor can they be edited.

Link to comment

Strange - I am able to access the thread and the attached log file from this very forum page. But to summarize quickly:

  • In the desktop client the note list displays  with snippets  correctly
  • Yet the note window is simply blank for all notes
  • If you open a note in a pop-out window the window is blank
  • if you open a note in a presentation window it shows correctly
  • The notes show correctly in a web version as well as in the mobile versions of the evernote client
  • This has happened to other users with previous versions of the client (not me) 

Does it make it more clear?

Link to comment
7 minutes ago, lagrange said:

Strange - I am able to access the thread and the attached log file from this very forum page.

Hmm. Interesting.

 

Yes, thank you.

So, you can't see the notes,( like this ) :

437301219_ScreenShot2019-05-01at11_03_18AM.png.38813f86d8284eaa6332fafe9fb9f242.png

But you can only see the Title? ( Sorry, I spelled Symbols wrong. lol )  :)

 

Link to comment

Yes, title of the note is correctly displayed including tags and the format ribbon but the actual content frame is simply empty - a white space that the curse can hover over but not interact. No typing possible - nothing to see.

Link to comment
  • Level 5*

Hi.  As a subscriber you should be able to raise this with Evernote support which might help to avoid this being an issue with the next release;  otherwise you might want to avoid the betas for a while and go back to the last public release by uninstalling the current version and downloading / reinstalling.  Keep a copy of your databases folder as a backup,  and don't forget to change the settings on Evernote > Tools > Options so you won't re-update to the beta thread again.

  • Like 1
Link to comment
  • Level 5*
9 hours ago, lagrange said:

The feedback from support was to disable Hardware Acceleration (in the client and/or the registry) but unfortunately, this did not change the situation

Hmmn.  In that case I'd suggest a step back to the current public version.  You could try a re-install of the beta,  but if you want to do that I think a comprehensive clean out with Revo Uninstaller Free and a system restart would be indicated to ensure that all traces of your existing setup (except for the database files) are removed.  For safety's sake a system backup or at the very least copying your Databases folder to another location would be a good idea...

Link to comment

Thanks for the advice!

Did roll back to 6.17.7.8474 (308474) Public (CE Build ce-62.1.7539)  - Notes are fully visible and edible,  including hardware acceleration. Seems the beta introduced a change in the rendering engine that did not went well with my system.

 

  • Like 1
Link to comment
  • Level 5*
6 hours ago, viveknz76 said:

When is the new editor coming to the Beta version of Windows? I am liking the minimalism on Web.

Evernote don't usually trail upcoming releases - when it's out,  we'll know. Probably. The betas releases can be a bit light on change detail even then.  Somethng like a new or upgraded editor should be a bit in-your-face though..

Link to comment

I skipped 6.17 completely because I had too many problems with it and just now tried 6.18 B3.

Is there a reason it inserts an extra carriage return on every paste operation? For instance, take the words

Testing one two three

I select the "two" (only those three letters) and copy. I then instantly paste and the result is

Testing one two

three

It always gives me that extra return. I've reverted to 6.16.4 again as I do lots of cut/paste and fixing them takes too much time. The older versions don't have this issue. I won't call it a problem or a bug because it may be on purpose. I just don't know why.

Link to comment
  • Level 5*
33 minutes ago, OrbWeaver said:

It always gives me that extra return. I've reverted to 6.16.4 again as I do lots of cut/paste and fixing them takes too much time. The older versions don't have this issue. I won't call it a problem or a bug because it may be on purpose. I just don't know why.

Not seeing this in 6.18.3.8477 (308477) Prerelease (CE Build ce-62.3.7750)

Link to comment

This has been going on for some time already. In the current beta, (CE Build ce-62.3.7750), a normal paste is okay. A "Paste and Match Style" will net you a line break/carriage return.

  • Like 1
Link to comment
21 minutes ago, JoseVS said:

normal paste is okay. A "Paste and Match Style" will net you a line break/carriage return.

I was just about to clarify my post to note this. I had the "switch Ctrl-V / Ctrl-Shift-V" option turned on. I'm not sure what "style" the extra CRLF is matching but it makes it unusable for me. Version 6.14.x works so that's where I'll be staying.

It may be a small thing but notes look really ugly with those extra line breaks and they sure mess up URLs.

 

  • Like 1
Link to comment
21 hours ago, OrbWeaver said:

I skipped 6.17 completely because I had too many problems with it and just now tried 6.18 B3.

Is there a reason it inserts an extra carriage return on every paste operation? For instance, take the words

Testing one two three

I select the "two" (only those three letters) and copy. I then instantly paste and the result is

Testing one two

three

It always gives me that extra return. I've reverted to 6.16.4 again as I do lots of cut/paste and fixing them takes too much time. The older versions don't have this issue. I won't call it a problem or a bug because it may be on purpose. I just don't know why.

Could you send a screenshot for clarification, or a small movie?

Link to comment
  • Level 5*
On 5/6/2019 at 2:30 PM, JoseVS said:

This has been going on for some time already. In the current beta, (CE Build ce-62.3.7750), a normal paste is okay. A "Paste and Match Style" will net you a line break/carriage return.

That helped, thanks.

Link to comment
  • Shane D. unpinned and locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...