Jump to content

Browser Based Web App is NOT saving changes to notes

Recommended Posts

I am currently working for a company where I need to use a corporate laptop to interact with my Evernote account and cannot install the native app.

I have lost a TON of notes over the last 2 weeks because the web app is completely hit or miss when it comes to actually saving my notes.

It's absolutely ridiculous. I've spent upwards of 20 minutes entering text into a note only to have all of my work vanish upon a page refresh or when opening up the native app on any of my devices.

I've spent enough time trying to determine if it is just a situation unique to myself, or if it is a systemic issue. Every web browser I interact with my evernote account with behaves this same way. The web app is therefore completely useless to me. If I cannot trust that my updates are being saved then it is not worth my time to use the app.

Considering that searches throughout this forum show that people have been complaining about this issue for 10+ years — I will just assume that once again, Evernote doesn't care at all about their users. I can add this new issue I am having to the list of HUNDREDS of bugs I find in the app which people have been complaining about for the last decade.

This is the reason I am trying out new software and as soon as I find a suitable replacement for my needs I am ditching Evernote as fast as I can.

In the meantime I would like to know if anyone has a solution for this problem but I am not going to hold my breath waiting for an acceptable answer.

Link to comment

I am being a lot more careful how I interact with this. I literally need to real-time interact in the same note between my personal mac and the corporate POS Dell they gave me.

I already have to be careful not to introduce note conflicts by hitting refresh on my mac when I switch — and I notice that MOST times if I hit refresh on my mac after making a change on the PC (browser) side the changes save AND sync properly. But not every time.

I can deal with note conflicts if I create them by being careful, but when the notes simply don't save it completely destroys my workflow.

The only problems I am having is if I spend a few minutes modifying the note on the windows machine (or creating a new note) I can work for a period of time and find that nothing I did was saved. The proper fix would either be to introduce a specific "SAVE" button in the web UI to CONFIRM that your stuff is saving — because in the current implementation I have absolutely no idea of knowing if what I did was saved or not.

I've lost notes at least 10 times in the last 2 weeks and there is nothing I can point to as "steps to reproduce" the bug other than "just use it for awhile and you'll see it happen to yourself."

If I could install the desktop app on this garbage corporate Dell I would be fine but for users who are in my situation you're pretty much screwed.

I am basically in a situation where I have to use a personal machine to do my work because the horrible IT department at this place won't give me any equipment, access, or tools I need to do the job — but they gave me some 10 year old piece of junk Dell so I can access certain things behind firewalls they will not allow me to access with my own device.

Plus I have to run a VPN on my personal mac to get around 90% of the internet being blocked by them — and I am using evernote to keep my notes AND to transfer things I need between machines.

Link to comment
  • 9 months later...
  • Level 5

@Gianni1337, you're responding to posts that are many months old, posting the same thing in multiple forums, and offering no information about the specifics of your problem. Assuming, despite all this, that you are not just trolling and would like a bit of assistance from your fellow Evernote users here, can you give some more details, please? Which version of the Web app are you using: Beta, Classic, or "Previous"? (There is an indicator in the bottom right of the screen for Beta and Classic; if there's no indicator there, you're on the "Previous" version.) If you switch to a different version, does your lost data appear there? (To switch between Beta and Classic, click the indicator at bottom right. To switch to or from the "Previous Version," click the large initial on the left side of the page and select the appropriate option.) What exactly happened when the information disappeared?

Link to comment

I've also hit the same problem last night (circa ~ 3:00 a.m. CET).

  1. Last evening and night I was working on a few notes with webclient.
  2. After 3:00 a.m. CET I've checked their content (for sure), then I close the browser, shutdown computer and I go to sleep.
  3. At the morning I copy and paste my most important note to other tool - to create the backup copy (I didn't checked the content of the note during this operation).
  4. A few minutes ago I've realized that there are missing parts in my notes  - there are no changes done with webclient between ~ 10:00p.m. - 03:00 a.m. (there are lacks also in my morning backup)
  5. There are no "conflicts" between the versions of the notes in Evernote.

It looks that I can lost >5h of my very important work.

  1. Didn't you have some problems with your storage or API/backend last night?
  2. Could you check, if there are (were?) newer versions of my notes before 3:00 a.m CET?
  3. Or any interaction/works on my account between (00:00 - 03:00 a.m) basis on the API/frontend/backend logs?
  4. Is there any chance to recover that "night" versions of my notes ? Is there any conflict? Eventually consistent problems in storage?

I'm the senior cloud architect, please contact me Ii I could help or you need some more details.

I hope that I can't "just silently lost the content of my notes", without any conflicts nor the information from your logs/systems.
For me, this is a CRITICAL problem.



Link to comment

This has happened to me to, I've lost important attachments and bits of text. Seems like a synchronization issue.  I'm quite desperate, it's class notes, so I can't even write them down again. I've used evernote for 4 years and this has never happened to me. I'm using classic editor, tried switching back between that and beta editor, tried opening the mobile app, to no avail 😕

Link to comment
  • Level 5

@sERo and @Ilana F, welcome to the forums. Ilana, it does sound like a sync issue, especially if the data are missing in the mobile app as well. sERo, please be aware that these are essentially user-to-user forums. Evernote staff may look in sometimes, but this is not an effective way to address Evernote directly, especially for technical server/sync questions. For support, check https://help.evernote.com/hc/requests/new. It's mainly for Premium subscribers, but for data loss questions like this, there may be options for Basic subscribers as well. You can also contact Evernote support on Twitter: https://twitter.com/evernotehelps. It is also possible to subscribe to Premium for one month and get access to both support and Note History, which could conceivably contain some of the missing data, depending on when the History snapshots were taken. Once you've got what you can get, you can then revert to Basic after the month is over.

Link to comment

Hi Dave, thanks for a fast response. I know that, this is not the best idea to contact with support via public forum, but I haven't any other option.

I tried to create a request via  https://help.evernote.com/hc/requests/new before I go to the forum. Yes, there is a message " Please submit a ticket and provide as much information as possible so we can diagnose the problem(...)", but I still don't see any button like "Submit ticket" / "Create ticket" / "New ticket" (screenshot attaced). Only working and enabled button is a link to this forum, so this is the main reason why I'm here - on the forum.

I also have a lot of experiences with support management and a support tiers created to block users from spamming the engineers. But for me it's a little exaggeration if user can't contact support when the user have such serious problem like a lost of the data. It looks serious, it could affect your premium users, but as user I have no way even to inform Evernote engineers about such serious problem. And as an engineer I know that this also bad idea, because without such technical feedback you are completely blind. Every cloud engineer is really afraid about "silent data corruption", just because - it's... silent.

And of course, I can subscribe to Premium for one month, but it seems a little crazy to pay for something that is not working. And evenwithout guaranty that my note/data is somewhere in your systems. Yes, maybe it's in the Note History, maybe not.

Is there any way to contact with IT support? I can help with technical description of my problem.
Thnx and best regards...





Link to comment
  • Level 5

Let me try not to be to harsh on this: You do not pay, so why do you expect somebody to be available for you on demand ?

Using the existing EN infrastructure is one thing, this is probably a trade off between marketing and work load on the server.

Giving support (which means a human needs to look after your problem) is something completely different, it is a 1:1 job. The people giving support go home at night, and they need to have something in their fridges as well. They do not come for free.

All serious stuff is probably brought to EN Engineers by the paying segment of the users. We use the same routines as the Basic accounts, plus some more available by upgrading the account. I do not see a need to open up personal support to the free users just because it might generate more information. My impression from my contacts with EN support is they have enough of it.

So for EN it boils down to a marketing decision.

And for you it comes down to the need to find out - which could probably be done as @Dave-in-Decatur told you: Sign up for a month, review the history of the relevant notes, issue a support ticket. Or skip it ...

If you take my nickel for it: I think that all of the posts in this thread are related to maybe short interruptions of the internet connection. Probably it helps to hit the „refresh“ button of the browser from time to time, or simply quit out of the edited note, and go back to it. Unless it was transported to the server, edits will be stuck in the local memory of the browser, and probably been lost when closing.

From a mobile app (I am using the iOS version on iPad , iPhone and Apple Watch) up to now I have never lost information.

Link to comment
  • 1 month later...

Same thing just happened to me. Haven't used Evenrnote in a while. Logged in this morning to the web interface to organise personal research into a topic. The website was sluggish and wouldn't hold changes to a new note I created, edited one note extensively which had the links I captured this morning. Clicked away and when I clicked all my notes were gone. 

This has never happened before. Time to look for alternatives to Evernote.

Link to comment
  • 2 months later...
  • 10 months later...

Update:  After clearing browser cache (Chrome) I am no longer experiencing this bug.


Happening for me now.  

I tried switching to Classic, but still happening.

Edited by BostonMatt
Found work-around for this bug.
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...