Jump to content

Screenshot via Web Clipper not working

Recommended Posts

When I take a screenshot using the evernote web clipper, Evernote only saves the top-left quarter of the image.

I've tried un-installing the Web Clipper, re-booting Chrome, and re-installing the Web Clipper. 

I'm using:

  • Google Chrome for Mac Version 71.0.3578.98 (Official Build) (64-bit)
  • Evernote Web Clipper (downloaded 01/07/2019)



  • Like 1
  • Sad 1
Link to comment

Me, too!

I love to do screen grabs of new words I look up - tagged with "new words" and the year. Makes for an interesting retrospective. But I don't need the rest of the irrelevant Google search - just the new word and its definition. This used to work fine. Now I get maybe the top left (? I'll pay attention next time). but certainly - not what I grabbed - just an erroneous chunk.

I uninstalled the EN GC extension, rebooted, downloaded the latest and greatest, reinstalled and - WHAM! Same dealio. No change. Very anticlimactic. And super frustrating cause that was a nice, EASY little daily edification that I won't do if I have to jerry rig a daisy chain of workarounds. I'll never find. sort, organize or revisit those clips again if not for the easy breezy EN ease.

NOTE: SOMETIMES I add a note as to why I looked the word up or its relevance to a tagged project but I only annotate about half the time - and it happens 100% of the time.

On macOS Mojave 10.14.2

Google Chrome is up to date: Version 71.0.3578.98 (Official Build) (64-bit)
  • Like 1
Link to comment
  • 2 months later...

I am having this problem too. The ability to screenshot the portion of the webpage I want to is vital to me when I am researching. I literally scan through hundreds of pages of Newspaper article archives and clip the articles relevant to my research. But now I can't when I attempt to highlight the portion of the page I want, Evernote web clipper kicks me back to the top of the webpage and I can't move down the page to what I'm trying to clip.  How can I get this ability back? I've tried uninstalling and reinstalling but it keeps reverting to the latest incarnation of the app. I'm super frustrated. I have quite a bit of research stored on my Evernote account and would like to keep using it but at this point, I feel like I am wasting my money. 

  • Like 1
Link to comment
  • 7 months later...
  • 1 month later...

I just tried it and it seems to be working again for me.

Not sure what changed or why it's working again (Evernote upgrade?). 

I'm on a MacBookPro (Mojave 10.14.6) using Chrome (79.0.3945.88) as a browser at the moment.

The screenshot, annotation, remarks - everything working. YAY! 

Link to comment
I sought the help of my son. He has explained why I am encountering the issue. Consequently, I no longer have a problem.
The solution (for me as least)  was as follows; when I used the clipper I was clipping only a portion of the visible screen. Therefore the clip only showed the portion I had clipped and the left the rest of the screen black. I was expecting to see the portion that I had clipped appear as a full screen clip and was flummoxed when it only showed a part of the visible screen . Once I went back to the clipper and expanded the section visible on the screen so that the portion that I was interested in occupied the entire screen the subsequent clip occupied the entire screen. Problem disappeared! Simple really.
Link to comment
22 hours ago, bawend said:

this is still a problem for me!! evernote support said they are aware no timeline for fix:(  

I found it's best to negate the crop and just do a full screen capture, then in evernote not you can right click the image, "annotate this image", and then crop it successfully.

Not ideal, but it's something.

  • Thanks 1
Link to comment
  • 1 month later...

Not working again... for a couple months. ;-/


Now I get the spinning wheel of death when I try to do ANYthing on my Evernote Desktop. No saving even normal clips! Or tagging or sorting - anything What gives?!

Really close to just giving up on the software and trying something else. AGAIN.

Link to comment

Yeah, thanks PinkElephant. ;-)

It's working. Again.

I did contact support. They are great. They are looking in the log for what's causing the prob.

I did everything: checked to make sure 3rd party cookies weren't blocked and that Evernote was whitelisted; disabled AdBlocker (don't use Ghostery); reset the cookies, then cleared and refreshed the cache; uninstalled and reinstalled Evernote web clipper's Chrome Extension.  But.. you know... it's a lot to go through! LOL! Over and over!

But yeah, I do use it all day, every day, so I'd love for it to keep functioning the way it's so often seamless and useful (or figure out what causes this prob - so I can just tweak it if/when it happens again).


  • Like 1
Link to comment
  • Ex Employees

Hi all, thanks for reporting this and keeping up with it. Apologies for the inconvenience.

The issue with the Clipper screenshot tool + annotation (only) where the right and bottom sides are blacked out after sending to Evernote should be fixed in the next clipper update (no eta on when to expect the release atm).

While not ideal, a possible workaround in the meantime could be to take the screenshot with Clipper (without annotation), sync it to Evernote, and then annotate the image in Evernote itself (granted, this will not work if you only use the web browser version; image annotation requires a desktop or mobile Evernote app).

  • Thanks 1
Link to comment
  • 4 months later...

I cannot save any screenshots to EN with the clipper using Safari - just a blank screen. Works with Edge though. As mentioned elsewhere, clipper cannot save pdf's either - error message. I wished I had tested EN more thoroughly before buying premium as it is of little use to me if it can't work with Safari. But I am within my 14 days grace, so will cancel soon if this issue cannot be resolved

MacOS Catalina 10.15.5, 4.2 GHz Quad-Core Intel Core i7, 48GB 2400 MHz DDR4, Radeon pro 580 8GB Safari 13.1.1



Link to comment
  • Ex Employees

Thanks for mentioning these issues @captianslocum. I too enjoy Safari and understand your concern with Clipper not behaving as you'd expect there when compared to other browsers. 

As it turns out, I haven't been able to reproduce the screenshot issue in Safari so far - do by chance you have any specific website links this happens on or steps to reproduce the unexpected behavior? Concerning the PDF issue specifically in Safari, we're aware of this and the developers will take a closer look, thank you!

Link to comment

Hi Jay-Bob, thanks for the prompt reply. I have just tried doing screenshots on several web pages and this is what I have discovered: that the problem is only when taking screenshots of paused video (which is what I was doing yesterday. I am a home educator at the moment so I'm using EN to compile teaching resources). Everything else around the video is captured, but not the video screen itself. I attach an example video. My work around at the moment is to use the mac screen capture (which does work on paused video) and then clip it to EN. As for the PDF problem, my work around is the same, save to the mac then clip to EN.

At the risk of going off topic, can you explain why it takes so long to save to EN from the clipper? Is it because it is synching to your servers? I was clipping about 30 pages yesterday and having to wait between each one was a pain. Is there a way to save it just to the computer and then sync later? It would greatly speed up workflow. I couldn't find anything in preferences.

All in all, I shall probably stay with EN now as it is so fully featured and does everything I want - I especially like the ability to have tags as well as folders; and the search is very impressive. But I hope you can get the above fixed soon. 

Best wishes from the UK

Link to comment
  • Level 5

To make clipping easier on the Mac, you could enable the EN Helper in the EN Mac clients settings. The helper installs in the menu bar and is permanently available (if you don’t hide the icon).

It has a crosshair screenshot function. It has a small note window as well, where you can type or insert clipped text. Not many options, but great to make a quick EN note.

Link to comment
  • 2 weeks later...
  • Ex Employees

@PinkElephant, that's a great workaround, thanks for suggesting it.

@captianslocumthanks for the video - after watching it there is an issue specifically with using Safari Clipper's Screenshot clip option on a YouTube video area. Screenshots of other places shouldn't be affected. The issue is known by the developers but I don't have an estimate on when to expect a fix so please do continue to use the Mac Evernote Helper crosshair screenshot function workaround for the time being.

Concerning the length of time when queuing up and clipping 30 web pages, that depends on a few different things like how big each page is and the internet connection as all clips do need to sync to Evernote and the 30 websites could also possibly be using and moving between computer RAM as well. So Clipper will have to work through both initially loading, then capturing, then syncing all that data for the 30 pages if numerous clip process are started before prior ones are finished. It's not a feature of Clipper at this time to save something locally and send it to Evernote at a later time, but it is a great suggestion!

Link to comment
  • 2 months later...

I have just installed the new ios version and realised that the screen clipper that I use several times a day is not there anymore. Not the webclipper, but the neat Evernote icon in macOS Mojave top bar that allowed me to clip small parts of the screen, keep it there in the icon drop box, and paste it where ever I wanted. I loved it.

The icon is still there, but instead of the screen clipper, it is just another way to open Evernote. Why would I need it there???

I want the screen clipper back the way it was, please!


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...