Jump to content

Annotate image not working in Android 7

Recommended Posts

Hi, hope someone can help with this.

I'm using Android 7 on a Galaxy S6. Evernote 8.5.1. 

I can no longer annotate an image in Evernote. I press the image; the menu comes up; I click annotate. The menu then vanishes, and the image is back but without the annotation options. They seem to have just vanished.

I've restarted the device and deleted/reinstalled Evernote. No effect.


Anyone else having this issue? Anyone have a solution?


Thanks for your help!


  • Like 1
Link to comment


I have the same exact problem, and it happened after the Evernote got updated 12h ago to version 8.5.1.


I have samsung Note 8 with android version 8.0.0.


I have cleared the app cache with no luck. I have set all permession for testing purposes but also with no luck. Of course I restarted my device with no luck.


I appreciate if devs can check it out.



Link to comment

The same problem on Oneplus 3 with OxygenOS 5.0.6 (Android 8.0.0). I do not know if the problem started with version 8.5.1 but I can confirm that the problem is present in

Evernote version: 8.5.1(1081823)

Evernote revision: 8.5.1_2408

I could send a log if necessary. 

Link to comment

I just noticed this exact problem today using Note8 Android 8.0.0.

I submitted a support ticket so hopefully this can be fixed. If not, this could be a deal breaker for me continuing to use Evernote as this feature (integrated with the Skitch app) is really important to me. 

Anyone else know of other apps that allow you to annotate images within your note? Just in case Evernote no longer supports this function...

Link to comment


I have just the same issue with my Samsung Galaxy S7 since a vew days. PDF can still be edited but not pictures. With the same account it works though on my Surface Pro device.

Anybody founded a solution so far ? Annotate pictures is quiet important for me; I'm a roofer and used to write my mesures straight on pictures.

Link to comment
On 11/10/2018 at 5:22 PM, Nickerz said:

I just noticed this exact problem today using Note8 Android 8.0.0.

I submitted a support ticket so hopefully this can be fixed. If not, this could be a deal breaker for me continuing to use Evernote as this feature (integrated with the Skitch app) is really important to me. 

Anyone else know of other apps that allow you to annotate images within your note? Just in case Evernote no longer supports this function...


For what it's worth, I'm still waiting for a response from Evernote's tech support. ARG! Poor support...

I tested something earlier today, so here is an update to what I found so far...

I have Evernote installed on my Android Note8 (Evernote version is 8.5.1 - see 1st screenshot) and Evernote is also installed on my tablet (Evernote version 8.5 - still the previous version - see 2nd screenshot).

I don't use my tablet as often, so when I opened it earlier today, I was prompted by Google Play Store to update a bunch of apps (one of them being Evernote). Of course I didn't update Evernote and instead I unchecked the box "Enable auto update" so it won't ever update until I manually do it. HA! Evernote!

So I open Evernote on my tablet try to use the annotate feature and viola it works!!!!  Works just like I remember with all of the features from the Skitch app. So I save the note, sync it, open the image on my Note8 and it saved all the things I did on my tablet!

This will be my work-around for now, hoping Evernote fixes this. However, if removing this feature was a planned update then I'll be looking for another app to replace Evernote.

So is it a coincidence that these changes have been happening to Evernote after their new CEO just took over? Probably not! This app is worse and I'm about to walk away after being a user of Evernote for over 5 years now.

Here's a thought...when you do updates to "improve" the app - stop removing useful features and instead add to it...don't take away from it! And stop using the same line in the description of the new update "fixed bugs" whn you know you're doing a lot more than just that. =(

Last, GIVE US THE OPTION TO REVERT BACK TO VERSION 8.5!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Or fix this bug! I have a feeling it's not a bug and the feature was removed deliberately. I hope not!



Link to comment

I think it's most likely to be a bug - if they'd taken out the feature I think we'd be seeing complaints about it with other devices and platforms. It wouldn't only affect Android.

Thanks for persisting with the tech support! 

Link to comment
23 horas atrás, gazumped disse:

I use Xodo Docs - it has a lot more bells and whistles.

Hi @gazumped! Did you can help me? I've tried to edit a image in a note using the Xodo. But, when I finished the edition and press back button, the app shows me two opposite messages: first ("Document saved"); then ("Resourse not changed"); result: the edititon isn't saved. Can you point me where I had a mistake? Thanks in advance.

Link to comment

I did receive a reply. They say they realize it is a bug and are working on it.

. . . . .

Actually a new version just showed up in the Play Store. Installed it and the problem is fixed for me ? .

Edited by easye
Link to comment

Hmm - I still have 8.5.1 appearing in Play store. Perhaps it's appearing territory by territory?

Quite amazed at tech support's refusal to get to other users here. It doesn't take much to say that you're aware of the problem and working on it, does it?

Link to comment

Version 8.5.2 seems to fix the problem for me. It would be better if the bug didn't happen at the first place but when it did it was at least not ignored neither it took an eternity to resolve it. 

Maybe more communication from the developers would help to ease the frustration of users. There is still some room for improvement in this regard. 

Anyway, thanks for fixing the problem promptly. 

Link to comment

Same issue on my galaxy s7, since the last update. I tried to delet the app and install it again but it didn’t do nothing and I think that every android user has the same problem with the app lately so I just hope that there will be another update to fix this 

Link to comment

Yes, it works for me too! I opened Google Play Store and sure enough Evernote had an update. Their description of course is completely vague and bogus, not even addressing this issue. I NEVER HEARD BACK FROM EVERNOTE TECH SUPPORT AND IT'S BEEN OVER 5 DAYS!  Certainly doesn't make me feel good if it was a serious issue, knowing I'm just gonna keep waiting with no response from them. Horrible support!

Link to comment

 You may need to include the annotations.jar file into your project, but note that there are two annotations.jar files in your Android SDK:

android-sdk/tools/support/annotations.jar - Which includes the following annotations:

  • SuppressLint
  • TargetApi

android-sdk/extras/android/support/annotations/annotations.jar - Which includes many other annotations:

  • AnimRes
  • AnimatorRes
  • AnyRes
  • ArrayRes
  • AttrRes
  • BoolRes
  • ColorRes
  • DimenRes
  • DrawableRes
  • FractionRes
  • IdRes
  • IntDef
  • IntegerRes
  • InterpolatorRes
  • LayoutRes
  • MenuRes
  • NonNull
  • Nullable
  • PluralsRes
  • RawRes
  • StringDef
  • StringRes
  • StyleRes
  • StyleableRes
  • XmlRes
Link to comment

Yeah, the new version has appeared in Play store for me, too, and the bug is fixed. Hooray!

Thank you, to everyone who persisted with Evernote tech support.

A footnote: I'm a new user of Evernote, and I've really been enjoying it; indeed, I'm starting to find it indispensable. And at this point, with any product, I start to think that I want to support it, as well as use it, and I'm willing to take out a subscription, pay for more features, whatever. But the refusal of Evernote to communicate, as described by some users here, makes me think again. Your tech support/customer service shouldn't leave customers wondering what on earth is happening. (I also notice that the first review in Play store, right now, is someone who has just swapped from iOS to Android, downloaded 8.5.1 and is disappointed that the annotate feature isn't present. This guy has no idea that it was a bug - he thinks it's something that isn't present in Android. So Evernote might want to think about a better communication strategy all-round.)

Link to comment

Well, I finally received a response from Evernote after 6 days! 6! At least they got back to me and fixed the issue but this is horrible customer service, horrible!

Below is the email...

"Geoff T. (Evernote Help and Learning)

Nov 16, 13:03 PST

Hi there Nick,

Thanks for reaching out to us at Evernote Support. My name is Geoff and I'll be assisting you.

I apologize for this delayed response, as we have been working through a larger than normal ticket volume. Please know that this is not typically the experience you should expect and we hope to return to our standard wait times as soon as possible.

I see that the Evernote for Android application is no longer allowing you to annotate images.

I wanted to be sure to let you know that our development team is aware of this issue and has fixed it with version 8.6 of the app.

Could you please check whether you are able to update to this version?

If not, you should be able to annotate once more by updating to the beta version of the application.

To join the beta program:

  1. Make sure you have Evernote already installed on your device
  2. Open the Play Store app
  3. Search for Evernote, then tap the Evernote icon to open the app details page
  4. Scroll down to the beta tester section
  5. If it's available, tap I'm in, read the disclaimer, then acknowledge by tapping Join
  6. Wait for the sign-up process to complete (Note: This can take up to 30 minutes)
  7. Once the sign-up is complete, go back to the Play Store and install the beta version of Evernote

Please don't hesitate to let me know if you have any additional issues or questions and I will be sure to look into them for you.


Geoff T.
Customer Support Representative
Tues-Sat, 6:30am-3:00pm, CST

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...