Jump to content

Text Replacement Problem in 8.4.1

Recommended Posts

Once I upgraded to Evernote for Android 8.4.1 I started to have the following problem in a text note.

When editing a word in a note by first selecting it in a line:

xxx yyy zzz

and then if I attempt to replace it by typing a word starting with a capital letter, when I hit the Shift (up arrow) and nothing else, it gets mangled into

xYyy zzz  

where red indicates the selection highlighting.

Worse, if instead of hitting a single Shift, I hit a double shift, the results are:

x Zzz

If I do the same process but NOT hit the Shift, it works fine, e.g. yyy is replaced with whatever I type,

xxx a zzz

with NO selection highlighting turned on.

My Environment:

Phone: Motorola X 2nd Gen

OS: Android 5.1

Please feel free to contact me if I can provide other information. Ed Kiefer


  • Like 1
Link to comment

I've never changed out my keyboard. According to Settings>Language & input > Keyboards & input methods

Current Keyboard == Multilingual typing - Gboard

I did have Texpand  on (doesn't work with Evernote any more) but the behavior remained when I turned it off, so that isn't a factor.

Is there any other information that I can collect for the analysis?

Thank you!

Link to comment
  • Level 5*

Hi. There's no analysis going on here - I'm just another user trying to help out.  If you check on the play store,  there are any number of other keyboards you can install - SwiftKey is a 'slideable' keyboard - just move your finger from one letter to another and it works out what word you're typing,  but it can be used like any other app with taps rather than slides.  Other keyboards are available.  :)

Link to comment

Got it. I'm still hunting around for the Holy Grail - a text expansion application that works on all of my platforms - Android (Evernote especially), Windows, Linux.

I found the new misbehavior as I was trying to kludge together some generic text lines for keeping track of my energy ins and outs that I keep in Evernote. I used to have a boatload of TexPand macros that worked magnificently on Evernote until a change to the input methods occurred a couple of years ago.

Thank you for your help,

Ed Kiefer

  • Like 1
Link to comment
  • 2 months later...

I'm seeing the same bug as EdKiefer. If I select a word then tap the shift key to replace it with a capitalized word, Evernote jumbles the text exactly as he described.
I tried the same thing in a Google Keep note, and it does not do this. So presumably it's a bug in Evernote, rather than a bug in my phone or the keyboard I'm using.

phone: Google Pixel 2XL

Android 9, build number PQ1A.18205.002

Evernote 8.7.0

Gboard keyboard

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...