Jump to content
Due to limited holiday staffing, chat will be unavailable from Thursday, July 2 at 5:30 PM (CDT) to Monday, July 13 at 8 AM (CDT). This will allow us to reply to your email requests as quickly as possible. Thank you for understanding. ×
msg5

Android Chrome Share to Evernote Not Working - No Text, No [longer] Screenshot Image Attachment

Recommended Posts

Device:  Asus Google Nexus 7 (2013) / Samsung Galaxy S7
Android Version:  6.0.1
Evernote for Android Version:  8.4 / 8.4.1
Browsers:  Chrome 69.0.3497.100 / Brave 1.0.59

I'm having a problem now clipping/sharing web pages from Chrome and Brave (Chromium based) browsers.

Very early on, the Evernote Web Clipper for Android used to clip a URL or the page.  In later versions, used with Chrome on Android, I couldn't get page content, but it would clip the URL and then a screenshot.  Sometimes, I wanted this, sometimes not.

Recently, even prior to these latest configurations I'm running, noted above, page Shares from Chrome or Brave browsers stopped including screenshots.  Instead, I started getting the URL (only sometimes) along with a weird attachment with an unusable 6-character randomized extension.  It turns out that this attachment was actually an image file, but it gets clipped/shared with a random 6 character extension instead of .jpg or .png (I think it was originally .jpg, but I can't remember for certain)

Firefox on Android still clips the URL at the least; no screenshot (not sure it ever did)
Clip Article with Text is hit or miss, depending on the page and content.  Most of the time, it never completes.

Ideally, I'd prefer to see some options for Android Clipping/Sharing so I know exactly what I'm getting:

  • URL (ideal)
  • Screenshot (would be nice if we could make it fast, and choose the resolution; I don't need full screen/HD resolution.  I just resize it down to 400px - 600px wide later if I even keep it)
  • Article with Text (that works.  Right now this is hit or miss for me, and usually only seems to work in Firefox; never works in Chrome based browsers.  Never completes, just shows Clipping in the note when I view it on a computer)

I'm fine with just the URL most of the time, since I usually do all of my production work and real Evernoting on a computer.  In fact, I prefer this URL-only option, because it should be much faster to clip.  The screenshots are handy sometimes as a reminder of what I've clipped for obscure sites, but man, it takes a long time to clip, save, upload, download, and whatever path to resolution that it before I can get it saved and it lets me back out to browsing.

Here's an example of the issue I'm having now in Chrome and Chrome-based browsers, like Brave, on Android.  This note was created from a Share to Evernote on the Nexus tablet.  Same thing happens with the Galaxy S7.  You may notice in this example that there is no URL in the note.  That seems to be a new issue.  The image attachment thing's been happening for several weeks for me.  The URL is available through the Note Info option in the Evernote client on a computer, but that's an additional step.  Just seems like something's off, and I'm not sure what or where.

Anyone else seeing this?

======================================================================

AS SEEN WHEN CLIPPED IN ANDROID
No URL, no Screenshot
Note weird extension on the attachment

907302024_01-AsClippedinAndroid.png.83a1edcc54208d901dca23cf6bf9004e.png

 

AS SEEN IN EVERNOTE CLIENT FOR MAC

1813900832_02-AndroidClipinEvernoteMac.png.8866eac0907cf08fa996097e03949f71.png

 

RENAMING THE ATTACHMENT TO AN IMAGE FORMAT AS A TEST
Right-click the attachment, choose Rename

1540975472_03-EvernoteRenameAttachment.png.2624ed64a4977327341910cb8523eeee.png

 

AGAIN, SEE THE RANDOMIZED FILE EXTENSION HERE?
THIS IS UNIQUE TO THE IMAGE.  OBVIOUSLY NOT A USABLE EXTENSION

720009843_04-EvernoteRenameAttachmentOrigExt.png.81e6a89bf5e3b8fbeb589c3a5f500227.png

 

MANUALLY CHANGING THE EXTENSION TO .PNG OR .JPG

481158547_05-EvernoteRenameAttachmentSetPNG.png.55b56eb5eaa264242c3a258cb59370f6.png

 

CONFIRM THE CHANGE

182497684_06-EvernoteRenameAttachmentConfirmRename.png.45d1cf7bd6ccbdbf7281853eb17a7b97.png

 

NOTE THAT THE ATTACHMENT ICON CHANGES; ATTACHMENT IS NOW USABLE AS AN IMAGE; CAN QUICK-VIEW, OR OPEN AND EDIT
The image attachment is now viewable, but is still not shown as an embedded image like it usually is on shared pages/URLs from Android Browsers.
Unable to set option to view as attachment or inline as is possible with PDF files.
This is relatively useless and would be more efficient if there were an option to not clip an image at all if it won't present as an inline image.  Again, as noted above, if this is to be the behavior, it would be great to be able to turn it off altogether, or be able to reduce the resolution of the clip before it uploads, which should save time.  This takes too long, even when it used to work.  Most of the time, all I'm trying to do is save the URL anyway, since the clipper in Android doesn't work as well as it does on a computer for saving articles or pages.

I know there are other ways to do this, but the Share option from the Android browser was convenient.

1227681203_07-EvernoteRenameAttachmentViewable.png.058b4357a381c2845631e0524ea5fe73.png

 

  • Like 1

Share this post


Link to post

Hi.. Having exactly the same problem here too. The OP explains perfectly the issue, amazed there is no one else experiencing the same. 

Thanks for highlighting msg5, brilliantly explained post!

  • Like 1

Share this post


Link to post

Hey Max thanks for chiming in confirming there are others!
I haven't been on in a while.  I was wondering whether it was just me experiencing this problem.

Revisiting this now, and have just opened a ticket with Evernote Support.  Hope to get this sorted out easily.

This problem persists for me now, even with browser versions current as of this post, as well newer versions of Evernote for Android.

Share this post


Link to post

Hey Max - just heard back from Evernote, and we're going through the initial troubleshooting.

I'm wondering whether this may be security-application related, or some other setting that's preventing pulling a screenshot.
Are you using any security application or third party screen capture utilities, by chance?

Here are the ones that come to mind that I have installed across two affected devices.  Any of these look familiar to you?

  • All-In-One Toolbox
  • Avast Mobile Security
  • Annotate
  • Easy Copy
  • Nova Launcher
  • Universal Copy
  • Screen Master
Edited by msg5
Added additional applications to the list

Share this post


Link to post

Experimenting with going back to the OE Samsung launcher (without removing Nova) did not make a difference.  I did restart in between tests.

(Edited above list of apps to include a few more)
Disabling the other applications listed above using Package Disabler Pro (with device restart after disabling) did not fix the issue, either.  Disabling with Package Disabler Pro makes these applications inaccessible.  They disappear from the Apps list, and cannot be called up for "share via" purposes, either.

Which devices are you guys using?
I'm having this problem across two different Android devices, a Galaxy S7 and Google Nexus 2013 tablet.

Also disabled the Data Saver option in Chrome, just to see.  No difference.
Again, this issue does persist across three different browsers.

If there is not an issue with the Clipper itself, I feel like there's some permission hangup or something messing up the screen capture operation.  Again, it does capture and attach a file that can be viewed as an image after renaming the extension, but whatever reason, it's adding the funky extension.

1490527386_evernotewebclipperandroid_400.png.f5bdfec0eb9a92110ab0410a4b33febe.png 

Share this post


Link to post

I have been having this problem for several months.  Evernote used to clip faultlessly but recently clips only the title and the app shows "clipping..." 

Given the number of unanswered complaints about this issue I doubt that I will renew my subscription.  Android clipping is a critically important function and I can't believe they are not addressing it. 

Btw It works better on the linux desktop but I spend more time on Android.

Share this post


Link to post

Pretty annoying really. I'd really like Evernote to solve this issue. As just a link isn't always helpful for memory like mine and just a image or screenshot does it all.

Also, clipping a whole article/page does normally work well either if the page has loads of comments at the bottom. Makes the whole process slow and pointless.

Screenshot_20190331-234313.png

  • Like 1

Share this post


Link to post

I've just come across this thread and I'm very grateful to msg5 for describing the problem in such comprehensive detail. I'm having the same problem on my GalaxyA8 phone and  Galaxy  Tab A tablet.  it is very frustrating and time-wasting.and the lack of response so far is disappointing. For me, the ease of use of Evernote Clipper is key to its appeal.  I'm not at the stage of looking around for an Evernote alternative yet  but it's not far away.   

  • Like 1

Share this post


Link to post

I've been experiencing this for months, I was hoping Evernote would eventually issue an update to address this but no dice.

Saving a url to Evernote on Android has become incredibly frustrating, not only it's super slow and has issues attaching the screenshot properly, but sometimes the buggy screenshot engulfs the link altogether leaving you with a blank note. 

Please, look into this.

Share this post


Link to post

I've been experiencing this issue too, any news from the Evernote support about it?

Share this post


Link to post

Frustratingly still the same for me too. Come on Evernote, you're better than this!

Share this post


Link to post

These are primarily user-to-user forums; Evernote staff may look in, but they generally don't respond directly to posts here. Clipping/Sharing from Web pages to Evernote on Android can be affected by a couple of things, including the HTML coding of the Web page and the strength and consistency of the Internet connection. Sometimes, IOW, it takes awhile, and sometimes the result is kind of cruddy.

Since everyone in this thread is a Premium or Plus subscriber, I think, you'd get best results by raising a support request, so Evernote's tech staff could work through the issues with you (which may be different for different users): https://help.evernote.com/hc/requests/new.

Share this post


Link to post

Guru, they did, if you go few posts above you will see.

But EN ignores all this, they have more important things to do, namely nothing. Nothing gets fixed, it is beyond frustration on EN part and the gurus here, who still defend the company.

Share this post


Link to post

Sorry, troll, I missed that. I meant to address just the most recent posters.

Troll, please point out where I "defended the company" here. I stated facts. Did you, lieber Troll?

(For those who are puzzled or offended by this absurd exchange, please do a quick search of AndreasM's posts. If you find one that was even remotely helpful to anyone, please let me know.)

  • Haha 2

Share this post


Link to post

Not worth the effort.

This troll is even copying his own posts - it seems he not only without any useful ideas, he is out of ideas at all.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...