Jump to content

v6.15.3.7881: Code blocks formatting is gone when pasting code


Recommended Posts

Before updating Evernote to latest version (6.15.3.7881), I used to paste formated code from Eclipse to Evernote's code blocks and it would be pasted with the same formating.

Since updating to new version, the formated code gets pasted into code blocks with no formating ☹️.

P.S. the "Paste and Match Style" option doesn't change anything.

Here's how that looks (look attachment pic)

Is there any way to fix this? If not, where can I download the previous version of Evernote from?

EvernoteNewVersion.png

Link to post
1 hour ago, gazumped said:

Hi.  Do you know which version that was?  This is the release thread for a recent version - 

There was a subsequent 6.14 GA which crashed a lot for some users...

 

Thanks a lot! It works fine in this version. Hope they fix it in the new versions.

  • Like 1
Link to post
  • 4 months later...

Hello, did anybody ever figure out how to keep the formatting?  I am copy/pasting from MS SQL Server and it previously kept my formatting and color configuration, but now when I paste (even when I paste and match style), my color configuration disappears (it all becomes black text) and keeping the color configuration for key words is very important to me and probably is for a lot of programmers. I am using Evernote version 6.17.6.8292 (see attached for Evernote > About).

I have a note with some SQL Server common syntaxes that I once in a while forget and need to look up.  I have attached the screen shot so you can see the issue that I am running into.  The code blocks where you see blue text in it are from a previous version of Evernote.  The code block, labeled "Table Variable" is the text that I am trying to paste into a code block and am loosing the text formatting (it should be the exact same text formatting as the other code blocks).  I have tried pasting multiple ways:

  • Pasted into the code block.
  • Pasted into the code block using "Paste and Match Style."
  • Pasted directly into the note and then highlighted the text and clicked the code block button to add the code block after pasting.
  • Pasted directly into the note using "Paste and Match Style" and then highlighted the text and clicked the code block button to add the code block after pasting.

None of the above resulted in a code block where the text formatting was kept in tact.

 

*** Can anybody please help me with this problem? ***

 

image.thumb.png.fdf2dbd550a04071f22733eff3d8722c.png

 

image.png.4aa8733db8e6b4dad4678e3828c311df.png

Link to post
  • Level 5*
8 hours ago, mturch said:

Hello, did anybody ever figure out how to keep the formatting?

Doesn't seem to work in the latest 6.18.1 beta either, at least pasted from Visual Studio. Looks like VS puts one instance of the copied text onto the clipboard in Rich Text Format (RTF), but Evernote ignores that and takes the Unicode text instance instead.

Link to post
  • 2 months later...
Em 13/02/2019 at 05:42, s95ammar disse:

I just reinstalled version 6.13 and have been woking with it since this feature was gone. It works fine there.

Hi,

I have the same problem also, why doesn't Evernote answer this question ?

Link to post
On 01.10.2018 at 11:13, s95ammar said:

Before updating Evernote to latest version (6.15.3.7881), I used to paste formated code from Eclipse to Evernote's code blocks and it would be pasted with the same formating.

Since updating to new version, the formated code gets pasted into code blocks with no formating ☹️.

OMG You Posted October 1, 2018  and still not fixed...

bb Evernote

Link to post
  • Level 5*
On 5/9/2019 at 10:32 AM, ptomas.it@gmail.com said:

Hi,

I have the same problem also, why doesn't Evernote answer this question ?

Hi.  This is a -mainly- user-supported forum,  not a route to Evernote Support.  If you're a subscriber and want a direct response,  please reach out to Support and raise a ticket.  If you're a Basic user,  try @EvernoteHelps

The current situation seems to be that Evernote moved away from the editor version that showed code blocks with formatting after v6.13 (link above).  They're known to be developing a new editor that might address this issue,  amongst many others.  On the other hand it might not.  Current position - if you need formatting,  use another app to lay out your code and embed the document file (or a link to it) into a note / revert to v6.13.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...