Jump to content

Disable Automatic Emoji?


Recommended Posts

Evernote 6.13.14 for Windows

I was just updating some tech notes, and went to make a note about a drive letter and the EN editor replaced my "D:" with a small black rectangle.

image.png.066a75df7bb93f2358f890387ac70e66.png

I presume this was supposed to be an automatic text formatting element, and I can't think of anything else this might be except for a frowny emoji?

I've tried searching the forums and can't find much on this, except for people asking for emoji support.  I've also tried disabling the Automatically format text elements option, but that didn't help with this.

Is there a way to turn this off that I'm missing?

image.png.b469d9b75d71eafb5701bac8f4de1dca.png

 

 

  • Like 8
Link to post
  • Level 5*

Hmmn.  Using "D:" here without quotes will get you this unhappy face -  ? - and this isn't Evernote code,  it's an independent commercial forum.  There seems to be some kind of international standard applying.  Cap D however is the only letter of the alphabet affected - and it's Saturday I tried 'em all ?.  It did lead to my finding out how to add emojis to my text with the Windows on-screen Touch keyboard,  so I no longer need to mess around with :codes:

Couldn't find any lists of emoji keyboard shortcuts - all the links I tried were about how to get to your virtual keyboard.

As regards your actual question,  I can only suggest you type inside a code block - the auto formatting seems not to work there...  ???

Sorry ?

Link to post
  • Level 5

Hmm. I find that for me it's :D, not D:, that gets turned into a box, undoubtedly substituting for some emoji my system can't display. I followed the auto-formatting instructions, and did Tools > Options > Note > Note editing and deselected Automatically format text elements, as @msg5's screenshot also shows. And this turns everything off except the emojis. Sheesh. The only other strategy currently available is the other one listed in the instructions: "To revert auto-formatting back to the original text input: Go to Edit > Undo from the menu bar, or use keyboard shortcut Ctrl + Z." Is there an emoji for :stupid:? If not, why not?

Link to post
  • 3 weeks later...

Hehe, yeah, Dave, the : D would be the accompanying smiley opposite for frowny D :

G - I do make regular use of the Code Block option but just didn't fit the use here in this particular note.  I use the Code Block option for sets of commands, or instructions, etc.  I'm still on 6.13, and have noticed that I can't indent with Code Block anymore like I used to be able to.  Also seen some strange behavior there where where in some versions or some methods of use, the code block would start at the left margin, and only the text would indent.  And then other times, I'd be able to indent the Code Block windows itself.  I'd settle for either at this point.

Link to post
  • 2 months later...
  • 2 weeks later...

I agree, I need to write < 3 without space & without it turning into stupid ❤️ !!!  This must be removed or at least an option to disable!  EN is first & foremost for note-taking not a chat app!

  • Like 2
  • Haha 1
Link to post
  • 3 months later...
On 1/25/2019 at 1:30 PM, jefito said:

This is sounding more like a feature request. Should I move it over to the appropriate forum?

Sorry for reviving a dead thread, but I just checked and I couldn't find it anywhere in the feature requests forum. So yes, if you were waiting for an answer to this, yes please do. 

Link to post
  • 2 weeks later...
  • 4 weeks later...

Another vote for disabling automatic emojis here!  I'm using it in a professional, technical environment.  I frequently want to type (for example) D: , and I will NEVER want to type a sad face emoji.  Infuriating, I can't believe it behaves like a chat application for 12 year olds.

  • Like 3
Link to post
  • 1 month later...

Just want to add my voice and say that the automatic emoji conversion (with no opt-out!!?) is deeply frustrating. I would like to close a parenthesis and then use a colon, but  ) : (without the space in between) transforms into a frowny face. This is on Windows Desktop, by the way.

Here's what I think about this forced feature:   :(:(:(

  • Like 1
Link to post
  • 2 months later...

Try the following: add a space inside your emoji, then a space after,  then remove the space from inside the emoji.  This effectively disables it. 

Alternately, the following AutoHotkey script can do it automatically:

#d::
Send D :{space}{left 2}{bs 1}{end}
return

Run it by pressing the Windows key followed the letter d (can change d on the first line to anything you wish).

Link to post
  • 5 months later...
On 10/30/2019 at 11:35 PM, Don Dz said:

add a space inside your emoji, then a space after,  then remove the space from inside the emoji.  This effectively disables it.

Yep, that also worked for me, thanks.  This minor issue just came up for the 1st time for me as well, and it was an unwelcome distraction.

My 1st solution, and another way to tackle this, was to: 1st copy/paste my text,  seen here inside quotes '😎'  which translates😎 to MS Notepad, then copy/paste back to EN.

I even struggled to stop this Auto Emoji behaviour here on this forum webpage!

I was creating 'non-sequential' numbered list and well the 😎 proved a hard nut to crack

Link to post
  • 2 months later...
  • 1 month later...
  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...