Jump to content

Serious and ridiculous, pasting <pre> text block sometimes loses pre formatting!

Jimm Chen

Recommended Posts

Two days ago, I was force to upgrade from Evernote 6.5.4 to (on Windows 7). I had been sticking with 6.5.4 because I love its "proportional table width" feature(see my link).

Now with 6.13, I found a problem that seems impossible to work around as a programmer user: When I copy a block of <pre> content from some webpages(for example) and paste it into an evclip(Evernote clip), the text formatting from <pre> block is all lost. We know that we use <pre> to protect spaces and linebreaks from being tampered, so we expect the code text to remain valid after copy/paste. But with 6.13, it is ruined.

See my screen shot below:

[ Google Chrome browser ]


[ Evernote 6.13 ]


Evernote 6.5.4 does NOT have such problem. 

I'm also curious whether any Evernote staff/developer has been aware of existence of this problem, and is there plan to fix it? 

And I have to say, even back in Evernote 6.5.4, copying/pasting a <pre> block from a webpage STILL HAS some flaws. The most prominent one is: Sometimes, some line-breaks get lost so multiple lines get merged into a single line; it just occurs spontaneously with no apparent pattern. I have to line break them manually, a bit annoying but still bearable. For example, it appeared many many times when I copied large chunks of <pre> code from Django Tutorial

[2018-08-14] Well, I realize this space-swallowing behavior does not happen for all <pre> blocks. For some webpages the spaces are preserved as desired, for example, this and this.However, there is still problems with line-break dropping. I felt despairing for 6.13 yesterday because one of my frequently visited internal website happened to run into this problem.

[2018-09-17] This is serious, no kidding. Almost every code block copied from docs.python.org (for example) causes space swallowing. And I checked the exported .enex, those space characters are all lost. I mean, it is data lost, not just a display issue.

Don't you Evernote developers use Python in your daily work?

I've tried the latest Evernote_6.14.5.7671.exe, still the same.

Original webpage in Chrome:


And this is what we see in Evernote 6.14:





==== There is a redundant image I want to delete from this forum post(I uploaded it by mistake, the tiny one you see below), but I can't figure out how to do it. ===

snap13581 Evernote 6.13 paste PRE bad.png

Edited by Jimm Chen
Update: Some webpages are free from this bug
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...