Jump to content

Evernote deleting attachments!


Recommended Posts

Hi there, 

we're experiencing a major and very scary issue with Evernote regarding attachments in shared notebooks. Attachments suddenly go missing from the notes. 

Scenario: 

- 3 Users (all Premium Accounts)

- User A shares several notebooks (read+write) to users C + B. 

- All users on MacOS High Sierra 10.13.6 and latest Evernote version (as of today 7.3.1 (456985 Direkt)) 

 

Use Case: 

We use Evernote to store and share scanned receipts and documents with each other. Mainly PDFs and JPEGs. There are many notebooks to categorise receipts 

 

Issue: 

Attachments inside notes go missing. They simply disappear from the note. 

A note that first looked like this: https://cl.ly/1W373u0Y2P36

Suddenly goes empty: https://cl.ly/3q3m1R1W130V

 

When checking the note in the web client it looks like this: https://cl.ly/2f0R1Z193l09

You can see that there was supposed an attachments but it is not accessible anymore (Webclient just saying UNKNOWN where previously was a PDF). 

 

You can see attached a screenshot how the attachment looks like in the web client. Evernote thinks the attachment is there but when clicking on it we just come to an error page saying: 

Quote

Oops, we encountered an error. 

Page not found
The location you provided is not valid. (/shard/s3/nl/226911/4a48ea89-80ce-458a-abb6-42f1bed2b808/true)

 

 

Scarily this issues happened to ALL notes within one notebook (113 attachments gone).

It also happens sporadically to individual notes in other notebooks. 

 

We have tested some things and it seems that when Users B or C makes changes to notes or move around notes within notebooks that the syncing to the Evernote cloud suddenly results in data loss. It never happens when User A (owner/creator of the notebooks) makes modifications. 

Strangely the notes where the attachments went missing don't show any recent "change". The creation and last updated dates are way in the past. So the attachment goes missing without the system even realising any change. There is also nothing shown in the note history!

 

I can confirm that all notes incl. attachments had been previously successfully synced to Evernote as they were accessible in the web interface by User A.

 

How can prevent this from happening? 

How can we get our data back? 

Is anyone else experiencing similar issues? 

 

Thanks for your help!

 

 

 

 

 

 

Web View Attachment Link Error.png

Web View Attachment Missing.png

Edited by berryloui
Added more info
Link to comment
  • Level 5*
On 8/10/2018 at 3:32 PM, berryloui said:

we're experiencing a major and very scary issue with Evernote regarding attachments in shared notebooks. Attachments suddenly go missing from the notes

We're a user discussion forum here.
I recommend you contact Evernote Support at https://www.evernote.com/SupportLogin.action

>>How can we get our data back? 

In the meantime, you can use Note History backup to recover your attachments,

Link to comment
  • Level 5*

I think there'd be more screaming if this was happening to others...  with various people contributing to these notes,  I wonder if one person's blank note has synced and overwritten someone else's saved files.  But that should put the content in Note History which you're not seeing...  Any chance to test this out just with two users and keep everyone else offline?

Link to comment

Thanks for the suggestion. We're testing this out tomorrow. Luckily the Evernote team has escalated this and we're doing a remote session tomorrow and they're now looking into this. Will also be testing directly with 2 users to see if we can replicate it. 

  • Like 2
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...