Jump to content

Recommended Posts

This one has me stumped, I hope someone can help. I can create a screen snap in Skitch of a database screen, name it, select "jpg" as the file type, and then drag it to my hard drive. I move to the next record in the database and try to repeat the exact same steps, but this time within seconds of making the second screen snap in Skitch, the first jpg disappears from my hard drive. I can actually see it vanish, it just leaves. This is a procedure that I have done weekly for almost two years, creating about twenty-five screen snaps per week. I've tried PDF instead of jpg, and I also tried dragging to a different folder, the result is the same. The only work around was to "Export" the file rather than drag it, but that is more time consuming and I would like to get the drag option back.

Any ideas?

Mac 10.13.3
Skitch 2.8.1

  • Like 1
Link to post

The same thing started happening to me this last week. I drag my images to my desktop, and they disappear just as soon as I move on to the next snap. If anyone comes up with a solution or a bug fix, that would be awesome.

MacOS 10.13.3

Skitch 2.8.1

Link to post

+1 I'm having the same issue... as a temporary hack I made a copy of the image file before it disappeared and the copy stuck around... Skitch seems to be getting less reliable as the years go on...

 

same user specs as above:

Mac 10.13.3
Version 2.8.1 (264719)

Link to post
  • Level 5*

Hi.  Not a Mac user but until one comes along...  Have you tried any other screen grab applications?  Don't know why Skitch would misbehave in this way,  but it would be interesting to know whether the issue is related purely to Skitch,  or whether it's something else...

Link to post

There is a Mac system screenshot utility and another called "Grab", they both work without any problems. Skitch has a much nicer interface though, and when doing twenty-five snaps at a sitting every week, I much prefer Skitch for it's speed and ease of use. I have to say that it is very strange to complete one file, start the second and just watch the first one disappear. 

Link to post
On 3/17/2018 at 6:09 PM, Shwaydogg said:

+1 I'm having the same issue... as a temporary hack I made a copy of the image file before it disappeared and the copy stuck around... Skitch seems to be getting less reliable as the years go on...

 

same user specs as above:

Mac 10.13.3
Version 2.8.1 (264719)

This is interesting, I'm curious to know if there was a change in the Mac OS within the past two weeks or so? I've followed the exact same snap and drag routine for almost two years without issue, the problem didn't start until somewhere between two and three weeks ago.

Link to post

So there are three of us that are showing the same issue, all with the same OS, Mac 10.13.3, perhaps therein lies the problem. I would be curious to have someone running a different version of the Mac system chime in as to whether they are able to duplicate the problem.

Link to post

Okay I'm still working on this and believe that I have found the culprit. In checking the recent updates, I see that Skitch was updated on March 10, just about the time that this problem appeared. And it looks like the key reason for the update has something to do with dragging and dropping images. So it appears that in the process of fixing one problem another was created. I've included a screenshot from my update screen. 

How does one report this bug?

App_Store.jpg

  • Like 1
Link to post
  • Level 5*
1 hour ago, Charles218 said:

How does one report this bug?

You kinda have - the developers do get around to reading these pages sooner or later.  Best way to get their attention faster is either to post in the release thread for an app (which I don't think there is in this case) where the devs will look out for comment and problems,  or -failing that- report it on https://www.evernote.com/SupportLogin.action if you're a subscriber,  Twitter - https://twitter.com/evernotehelps if not.

Please let us know how you get on.  Good teching by the way for finding an answer!

 

Link to post

It appears that the only support option that I have is here on the forum. I am not a Business or Premium user, and when I go to the support page it says to create a ticket to report a bug, but there is not option to do so. I do not use Twitter so that locks me out as far as I can see. It would be helpful if one of the others here who reported the same issue might be able to submit a ticket about this problem.

Link to post

Problem solved, well at least temporarily. The three or four of us that reported having this problem are all using Skitch 2.8.1 which automatically updated on my Mac on March 10. I simply downgraded to 2.8.0 and the problem disappeared. If you go this route, remember to go to Skitch Preferences and turn off auto update or you will eventually be right back where you started. Here is the download link for 2.8.0: https://evernote.s3.amazonaws.com/skitch/mac/release/Skitch-2.8.0.zip

  • Like 1
Link to post
  • 3 weeks later...

I have several users in my office that use the free version of Skitch. One of them on 2.8.1 just started seeing this issue after updating to macOS 10.13.4. Oddly, I tried version 2.8.1 on my own machine running macOS 10.13.4, and I didn't have the issue. I've recommended that she downgrade to 2.8.0.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...