Jump to content
  • 0

Android Widget Size / Evernote Action Bar Size Too Tall



I just updated the Evernote app on my Android smartphone at some point the past week or so, and the Widget/Evernote Action Bar is now 4x2.
Personally, I prefer a tighter display on my devices.
I'm really not a fan of a the additional padding around the widget/action bar.
I'm finding it a tremendous waste of space, but more importantly, it's jacked up the layout of my other widgets and icons.

I've attached a screenshot of my adjusted version.  Running a different launcher so I was able to add an extra gridline to at least keep the previous content.

Can we get a 4x1 option like before?
I don't mind a 4x2 as an option, but I prefer the 4x1.  I'm trying to find a backup on one of my devices of an earlier version of the Evernote app to try to restore.

I see no need for the extra space/padding.  It's bloated and wasteful imho.
Lots of developers offer different size widget options for their apps - can Evernote do this, too, please?  Offer a widget size like previously available?

Evernote Widget-400.png 

Evernote Widget-400_indicated.png

Link to comment

8 replies to this idea

Recommended Posts

  • 0
  • Level 5

I definitely take your point. In my setup the 4x2 is not as much of a problem, but how to arrange home screens, shortcuts, and widgets is very individual to each Android owner.

Hang on, though. On my phone there are in fact three widgets: the 4x2 list with action bar on top, the 4x1 action bar alone, and the 1x1 actions button. Do you only have the 4x2? Or are you saying that the 4x1 is functionally 2 high? For me, it seems normal height.

Link to comment
  • 0

Hey Dave,

Yeah, I do only have the 4x2.  There are two other widgets, but they're for Evernote Actions (1x1) and Evernote List (4x2)
The way I discovered it was that the existing 4x1 came up blank on a device restart.

I don't remember updating the app, but it may have done it after a cache/data clear I carried out last week.

I'm updating to 7.16 right now to see if that brings me the option...

Link to comment
  • 0

Can you try pulling your available 4x1 widget over to a screen and see whether it's actually functional?
I had the 4x1 on screen there for a while, though not showing up in widget choices, but it was showing blank, and I think it said unsupported or was just unresponsive when I tried to use it.

Link to comment
  • 0

Okay, yeah, still the same deal here.  No 4x1 widget option, even after a remove and reinstall with a utility clearing app leftovers.

Just the three widget options, with the "action bar" one being a 4x2.

Link to comment
  • 0

Dave, thanks for checking back in.  I see, yes, you have the 4x1!

Through some troubleshooting/experimentation, I was able to figure it out over the weekend. It was related to the Android Launcher I was using, an older one called Catapult, a port of Trebuchet from Cyanogenmod.  The app hasn't been updated since 2015.  Never really had any trouble with Catapult, but I'd been meaning to move to Nova Launcher for additional tweakability.

  1. I started by completely removing the Evernote app from my device using All-In-One Toolbox's application manager, removing leftovers, etc.
  2. Next, I pulled over a slightly older version of Evernote for Android that I had backed up on another device, 7.12, thinking that the issue was a change in a newer version of the app.  The problem remained.
  3. Scratched my beard
  4. Wondered whether...
  5. ... Switched to the Galaxy System Launcher.  Lo and behold, the 4x1 Widget was again an option!
  6. Installed Nova Launcher; confirmed 4x1 Widget was available.  It was.
  7. Problem appeared to be something going on with the Catapult Launcher.  I don't regularly update my apps because I don't always like the changes.  It's a ***** shoot sometimes.  I must have been running a version of the Evernote app in which there was no conflict with Catapult, and/or some carryover something or other that allowed the widget to continue functioning as a 4x1.  In the past week, I'd carried out a wipe of the app data and cache in the Evernote app, just as a reset/database consolidation on the device, and that's when the widget went dark on the home screen.  I had to re-add, and then the 4x2 issue began.
  8. Running fine now on the current version of Nova Launcher.

I'm still running Evernote 7.12, and will try the most current update again, though I don't foresee any problems moving forward since the issue seems to have been with the Catapult launcher.

Okay, so a few screenshots for reference and because everyone likes pictures

  • 01 Catapult Evernote Widget Selection; note only 4x2 available
  • 02 Catapult Evernote 4x2 Widget on Desktop; no option to resize shorter; note padding (disregard Nova Launcher app.  had just installed it, but was still in Catapult)
  • 03 Nova Launcher Evernote Widget Selection; note 4x1
  • 04 Nova Launcher Homescreen; note 4x1 Evernote Widget


Thanks for hanging through the troubleshooting process, Dave, and for confirming the 4x1 Widget availability.

01 catapult widgets 400_mrk.png

02 catapult desktop 400_mrk.png

03 nova widgets 400_mrk.png

04 nova-desktop 400-edt.png

Link to comment
  • 0
  • Level 5

Beautiful, glad it's worked out! @msgvb, you are a man after my own heart (and beard). Your experience is exactly why I've never rooted a phone or used an alternative launcher--because I know I would end up galloping down just this kind of rabbit trail. Thank you for confirming me in my brutal self-denial. -_-

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...