Jump to content
Due to limited holiday staffing, chat will be unavailable from Thursday, July 2 at 5:30 PM (CDT) to Monday, July 13 at 8 AM (CDT). This will allow us to reply to your email requests as quickly as possible. Thank you for understanding. ×
  • 0
Chantal Leonard

Evernote for Windows 6.9 Beta 2

Idea

[Edit 1/25: We pushed an update as we were seeing an intermittent crash for some business users so you'll see a prompt to be upgraded to 6.9.4. Link below has been updated.] 

Hi folks - 

Today we're announcing Windows 6.9 Beta 2 - download it here. It includes more improvements to sharing and organization for teams and businesses. You can learn more about the Evernote Business Public Beta here

In addition, we've made a number of fixes to improve stability and quality. Some key fixes include: 

  • Recording audio is not saved when switching notes
  • Zoom In /Out using Ctrl+Mouse wheel is not working in 6.8.4 
  • Fix 4 frequent crashes including two when loading and using the note, 1 when showing encrypted text  
  • EvernotePlayer is always running in the background
  • An intermittent issue where the view looks garbled when starting Evernote when offline
  • An intermittent issue where text note's thumbnails are black when using the Thumbnail view for the note list. 
  • Issues where some of our educational messages were clipped. 
  • Performance improvements for the notebook picker - especially when you have many notes + notebooks. 

We've also been hard at work on some improvements around drag + drop which we'll be releasing in Beta 3 in the next couple of weeks. As always looking forwards to hearing from the community - please let us know if you spot any issues or have feedback. 

Thanks,

Chantal and the rest of the Windows Team

---------------------------------------------------

Screenshot of 6.9 - some UI tweaks made to the sidebar

image.thumb.png.6f961720bf320c0dcf14ae42d20f7066.png 

---------------------------------------------------

Release Notes

Release Notes for Windows version 6.9

Note: Versions 6.9 is supported in OS versions Windows 7 and up.

New

Spaces for Evernote Business users. Establish a shared organization for your teams' content — store your notes and notebooks in Spaces so they're all in one spot.

Improved & Fixed:

  • Aligned 'New Note' button look + feel to other Evernote apps
  • Fixed an issue where links in PDFs don't open in a browser
  • Fixed an issue where ctrl+mousewheel doesn't zoom in/out
  • Fixed an issue where recording audio is sometimes not saved when switching notes
  • Several crash and stability fixes

Share this post


Link to post

40 replies to this idea

Recommended Posts

  • 3

Anyone noticing this is really slow to respond when typing notes? My UI doesn't say "not responding" it just isn't responding for 5-15 seconds after I type in a note title before I can actually start typing in the body.

Share this post


Link to post
  • 3
10 minutes ago, chirmer said:

I'm so frustrated. These betas are a slap in the face to power users. I don't care, at all, about subtle fixes to a button. But I do care about drag-dropping PDFs and images, and I do care about a stable product.

Please, you guys. I've been beta testing for years and years, and never have I been so frustrated. You are ruining this product with your misdirected focus. 

Fix.

The.

PDFs.

And.

Bugs.

Amen to that. Super frustrating. I'm still at version 6.5.4 for the same reason. A payed customer.

  • Like 1

Share this post


Link to post
  • 2

Hi,

 

The bug with the insertion of horizontal lines isn't fixed yet (since Evernote 6.8).

They still don't appear correctly (or best said, they don't appear at all).

Hope it will get fixed soon

PS : English is not my mother language).

Thanks, have a great day,

  • Like 2

Share this post


Link to post
  • 1

Thank you. However:

Please provide instructions how to get rid of this nerve-wracking FLE-screen (First LaunchExperience?) in my note list. As a 9-year-user with > 18K notes I am not really a first time user with a first time experience. And: No, I am not interested and have no nerves to walk through these five steps, to create notes and notebooks etc. Been there, seen that.

I already gave this information in the beta thread - there should be no FLE in the windows client of long time users. 

So far, I have my FLE groundhog day every day. Every morning - FLE. Since several weeks. And now with the final client as well. 

Thx, EvB

  • Like 1

Share this post


Link to post
  • 1

I am following the comments here about the Windows product development. I understand work is in progress to make the Windows product better and to support changes to the Evernote Business Edition.

Was the drag and drop PDF feature fixed in this release?

Is there a stable version coming in the near future will all existing bugs listed and corrected?

I think it is important to have a stable product and limit the beta cycle to something that is carefully thought out.

A good round of bug fixes is badly needed right now.

  • Like 1

Share this post


Link to post
  • 0

Very annoying ratings-pop up keeps popping up all the time even though I've rated the app.. 

Share this post


Link to post
  • 0

The only way this should be able to happen is if the file <path-to-database>/<databasename>.exb.context file is not being properly updated. I've seen other reports that sound like that here in the forums, but we've never been able to reproduce it in-house. Hint: Do not delete the .context file. And make sure your virus scanner doesn't either.

Share this post


Link to post
  • 0

Small point, but should the title of this be 6.9.3

Share this post


Link to post
  • 0
5 minutes ago, CalS said:

Small point, but should the title of this be 6.9.3

No, 6.9.3 is beta2. Really. (the version number does not imply the beta-cycle)

Share this post


Link to post
  • 0

Well that makes things as clear as mud.....     :rolleyes:

  • Like 1

Share this post


Link to post
  • 0
34 minutes ago, CalS said:

Well that makes things as clear as mud.....     :rolleyes:

So, some guesswork:

They have a four component version number: major.minor.subversion.subsubversion, which you can see in the About box.  They use the major.minor piece for the official public (non-beta) releases.  The subversions could refer to internal milestones within a public release, and when Evernote is deemed ready for the next beta, whatever the current subversion is, is used; but they could have multiple milestones between beta releases if a version is not up to snuff. Not sure what the subsubversion is, might be time/date based, or based on some absolute build number: look on FileHippo's old Evernote versions page (https://filehippo.com/download_evernote/history/) and you can see that the subsubversions seem to be the last four digits of some monotonically increasing sequence which rolls over every so often.

The upshot is that the name of the beta release may not match up with the subversion number.

 

  • Like 1

Share this post


Link to post
  • 0
49 minutes ago, jefito said:

The upshot is that the name of the beta release may not match up with the subversion number.

 

Yup. Sometimes we have to patch a beta. Rather than calling it a new beta, we just bump the version number and announce it was patched.

  • Like 1

Share this post


Link to post
  • 0
14 hours ago, Arnaud68 said:

Hi,

 

The bug with the insertion of horizontal lines isn't fixed yet (since Evernote 6.8).

They still don't appear correctly (or best said, they don't appear at all).

Hope it will get fixed soon

PS : English is not my mother language).

Thanks, have a great day,

I'm on 6.8.7 and have gone back to using dashes --------------------------------------------------- to create horizontal lines. Very retro. Hoping this is fixed soon.

Share this post


Link to post
  • 0

Is "simplify formatting" broken again or has it changed? What's the direction of this? I'm getting confused.  

Also, in previous betas (or releases) since again a new editor was introduced: There are now formattings that seem to be <Heading> or <Section>, which are there and are not removed during "simplify formatting", but the corresponding format is not accessible in the editor.

Share this post


Link to post
  • 0

Finally!! I was checking almost every single day for any new update. I'm very much annoyed already using the 6.8 version due to the broken formatting when we copy and paste & match style from other platforms. There is this"*" appearing in every line instead of bullets which is actually supposed to appear! It is very time consuming and literally doubling the work and making us tired sitting before the computer and remove each "*" from each line and do the bulletin again. Previous version did not have this issue. So when I Googled, I found this thread which exists since 2013 to till today. So I bring you to the notice that many people finding this bug as very difficult and already many had moved to Onenote. I'm also a huge fan of Evernote like the person who created this thread. I'm hoping Evernote team had fixed that bug in 6.9 Beta 2, otherwise do take this into immediate consideration and fix this bug.

 

 

Share this post


Link to post
  • 0
20 hours ago, jefito said:

The upshot is that the name of the beta release may not match up with the subversion number.

Yeah, I get it, I truly do.  Just interesting to have a second release of the same beta is all.

Share this post


Link to post
  • 0
1 hour ago, CalS said:

Yeah, I get it, I truly do.  Just interesting to have a second release of the same beta is all.

There's a 3rd being promoted as I type... (I ran into a crippling issue that no one else did. Under certain circumstances - which my database had - the program crashed so hard no crash logs were captured.)

  • Sad 1

Share this post


Link to post
  • 0
4 minutes ago, dconnet said:

There's a 3rd being promoted as I type... (I ran into a crippling issue that no one else did. Under certain circumstances - which my database had - the program crashed so hard no crash logs were captured.)

Circumstances to avoid I am sure.  As long as we stay in the same beta thread I suppose.

Share this post


Link to post
  • 0


Oke, this is maybe oke; not.

Some UI tweaks made to the sidebar - which tweaks? I don't see anything except "New Note" button (it looks oke).

Drag & drop doesn't work for months , it's like hypelink in pictures/photos which doesn''t work for 6 months. 

"We've also been hard at work on some improvements around drag + drop which we'll be releasing in Beta 3 in the next couple of weeks. As always looking forwards to hearing from the community - please let us know if you spot any issues or have feedback."

Couple of weeks?' Funny!

This CEO and Team are worst. I don't wan't to pay 60 EUR for incomplete software that looks like Windows. Looking for alternative/s.

Chantal Leonard

 

Share this post


Link to post
  • 0
On 1/25/2018 at 6:23 AM, lhb said:

Is "simplify formatting" broken again or has it changed? What's the direction of this? I'm getting confused.  

 

Upgraded to 6.9.4.6614 (306614) Prerelease (CE Build ce-1.39.3895), and "simplify formatting" still doesn't work for me. Interestingly, "remove formatting" now does something similar as "remove formatting" before, but not as much: Some formatting that typically didn't remain with "simplify formatting" remains....

Share this post


Link to post
  • 0
13 hours ago, Broms said:


Oke, this is maybe oke; not.

Some UI tweaks made to the sidebar - which tweaks? I don't see anything except "New Note" button (it looks oke).

Drag & drop doesn't work for months , it's like hypelink in pictures/photos which doesn''t work for 6 months. 

"We've also been hard at work on some improvements around drag + drop which we'll be releasing in Beta 3 in the next couple of weeks. As always looking forwards to hearing from the community - please let us know if you spot any issues or have feedback."

Couple of weeks?' Funny!

This CEO and Team are worst. I don't wan't to pay 60 EUR for incomplete software that looks like Windows. Looking for alternative/s.

Chantal Leonard

 

I am able to attach a URL (hyperlink) to an image and if I click on the image a webpage opens - it sounds like I am missing a detail that is causing my experience to be different than yours with 6.9 Beta 2 (windows 10) - is this for new notes or older notes that already have links and are the notes create in Evernote or are they webclips? 

Share this post


Link to post
  • 0
5 hours ago, Ethan Mings said:

I am following the comments here about the Windows product development. I understand work is in progress to make the Windows product better and to support changes to the Evernote Business Edition.

Was the drag and drop PDF feature fixed in this release?

Is there a stable version coming in the near future will all existing bugs listed and corrected?

I think it is important to have a stable product and limit the beta cycle to something that is carefully thought out.

A good round of bug fixes is badly needed right now.

I'm so frustrated. These betas are a slap in the face to power users. I don't care, at all, about subtle fixes to a button. But I do care about drag-dropping PDFs and images, and I do care about a stable product.

Please, you guys. I've been beta testing for years and years, and never have I been so frustrated. You are ruining this product with your misdirected focus. 

Fix.

The.

PDFs.

And.

Bugs.

  • Like 2

Share this post


Link to post
  • 0

Issue.  Doing my weekly reminder review and noticed that the Reminder icon in the note header had been replaced by the Share icon.  Installed 6.9.4 this afternoon so I'm assuming that is the culprit?  Kind of hard to fat finger removing one icon and replacing with another in the note header area...

Share this post


Link to post
  • 0
13 hours ago, Jason Miller said:

I am able to attach a URL (hyperlink) to an image and if I click on the image a webpage opens - it sounds like I am missing a detail that is causing my experience to be different than yours with 6.9 Beta 2 (windows 10) - is this for new notes or older notes that already have links and are the notes create in Evernote or are they webclips? 

This!  http://bit.ly/2DG0kRb

Share this post


Link to post
  • 0

Hello, Thank you for releasing new versions and fixing bugs. 

Could we get why my installation freezes from time to time? It has been hanging for long time for unknown reasons. Not sure it is connected to this specific version. Please see description at 

Share this post


Link to post
  • 0

 Still getting a number of notes that refuse to show me the body. The scenario:

  • Sync on demand enabled
  • click on a note
  • gets downloaded (the hollow dot goes away)
  • Nothing shows in the body
  • navigate away/back nothing shows
  • export note as ENEX - there is data there
  • there is data in the web site and on my phone
  • Closing/opening Evernote doesn't fix it.
  • Help|Fix current note doesn't fix it.
  • Changing the tags or other metadata in the header does sync, but still won't encourage EN to show the body on the Windows client.
  • Changing the body on the web often will cause the EN Windows client to show the body, but that messes with the note content and messes up the edited date. Just adding and deleting a space can fix this.

 

This is using 6.9.4.6614 (306614).

It seems if, for whatever reason, it doesn't display the note when it syncs it on demand, I never will. I have to go online to the web or use another client. If a dev wants me to send the ENEX to look at to see if there is something in there that is odd, I can, but I won't post it here. There is a huge difference in the XML of the two enex files (before and after adding/deleting the space on the website).

Share this post


Link to post
  • 0
On 1/27/2018 at 7:36 AM, beenhee said:

Hello, Thank you for releasing new versions and fixing bugs. 

Could we get why my installation freezes from time to time? It has been hanging for long time for unknown reasons. Not sure it is connected to this specific version. Please see description at 

Beenhee, I reverted to 6.8.7.638 (release) and that issue is there as well (Windows 10). I've got a ticket in for it - but so far nothing; they just want me to re-create my database from scratch. I get "Lock" in my logs all the time but no one will tell me what that means.  I've even given them specifics: when you do a search and select a note from the results and start editing it you can type about one character every few seconds. It doesn't only happen then, but it definitely happens then. 

At first they thought it might be due to a note that is longer than 10,000 words, but the thing is you can't search for that and there is no column for it either. I displayed my notes by size, but that doesn't help much because I have so many note with pdfs and those are what show up as large.  They want me to rebuild to eliminate the possibility of a corrupt note, and I guess I will have to even though it takes well over 8-10 hours, and despit the fact that I just rebuilt about 2-3 months ago.  It wouldn't be such a big deal except for the fact that every single time I report a bug, the initial advice by the front end csr people is to rebuild, even before they send off your issue to the tech dept.  I tend to refuse because a lot of the time it is a very specific thing I am reporting and if customers have to spend 10 hours rebuilding their database every time they report a bug, well, there is something deeply wrong somewhere. But I suppose that is a separate issue - it's just me ranting about rebuilds.

Share this post


Link to post
  • 0
28 minutes ago, lisec said:

I displayed my notes by size, but that doesn't help much because I have so many note with pdfs and those are what show up as large.

You can do a -resource:application/pdf search and then only be looking at non PDF notes.  FWIW.

Share this post


Link to post
  • 0
1 hour ago, CalS said:

You can do a -resource:application/pdf search and then only be looking at non PDF notes.  FWIW.

Right, I forgot about that. Thanks CalS. 

  • Like 1

Share this post


Link to post
  • 0
25 minutes ago, lisec said:

Right, I forgot about that. Thanks CalS. 

You are welcome.

Share this post


Link to post
  • 0

Bug Report.

Maybe I missed it getting reported somewhere in this 6.9 beta process, but it appears that links to local files are broken.  I have quite a few notes wherein I put a link to a spreadsheet that is in my local file system, typically in my DropBox folders (I like the versioning provided therein).  These links don't work anymore.  I get the little hand, but nothing happens when I click.

Anyone else seeing the same issue?  Or if previously reported, oops.

Share this post


Link to post
  • 0

Anyone having problems sharing a note to someone in the work chat list in this build?  My note shares now show up as separate entries in 'work chat' but recipient isn't getting anything.

Share this post


Link to post
  • 0

Can I install Betas into another folder and not have it affect my production version? [Without resorting to a second account or virtual machine]

Share this post


Link to post
  • 0
On 1/24/2018 at 4:40 AM, Arnaud68 said:

Hi,

 

The bug with the insertion of horizontal lines isn't fixed yet (since Evernote 6.8).

They still don't appear correctly (or best said, they don't appear at all).

Hope it will get fixed soon

PS : English is not my mother language).

Thanks, have a great day,

Apparently this happens in Windows 10 when the display settings are set to 125% (as opposed to say 100% or 150%), although I haven't tested that as I reverted to a previous version.

[I guess my original report was responded to, but I didn't see the response: 

]

Share this post


Link to post
  • 0

Having some sharing note issues - might be related to the "work chat" issue I posted on a couple of messages prior to this one.

 

My example:

 

1) find a note that is currently "work chat shared". 

2) Decide I want to remove sharing of this note - as shown here:workchat3.thumb.png.d8dc037b7326edb7db18646516a41df8.png

 

3) Next, I'm click on the "can view" so I can select remove access:

workchat2.thumb.png.e52e2d2c99dcd455933c096aed1b9ed4.png

 

4) The confirmation window pops up and wants to remove MY access - not the person it is shared to.

workchat1.thumb.png.398553b236851dd6c70a4199dcf7abad.png

 

At this point, I hit cancel... I don't want to see what happens if it really does remove my access from the note. If it does work the way it should - something in this last screen needs changed so it is showing the person it is shared to as getting access removed -- NOT the originator of the note.  

I've replicated the issue with other shared notes too.

 

 

 

 

Share this post


Link to post
  • 0
2 hours ago, CraigZ said:

Can I install Betas into another folder and not have it affect my production version? [Without resorting to a second account or virtual machine]

No. As far as I know, there is no way to get a 2nd copy of Evernote installed on the same PC, short of a virtual machine. The app is installed for all users and shares common registry entries for users. Only the data is separate in profiles.

  • Thanks 1

Share this post


Link to post
  • 0
On 1/31/2018 at 8:47 PM, lisec said:

Beenhee, I reverted to 6.8.7.638 (release) and that issue is there as well (Windows 10). I've got a ticket in for it - but so far nothing; they just want me to re-create my database from scratch...

Thanks for the comment. Probably i should also to recreate my db. Hope they fix it in the next versions (today I've updated to 6.9.5.6679

Share this post


Link to post
  • 0
On 2/1/2018 at 2:48 PM, ej8899 said:

The confirmation window pops up and wants to remove MY access - not the person it is shared to.

Noted. Bug created. Looks like the wrong string parameters are being passed when the message is formatted.

  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...