Jump to content

Copy and Paste file path into an Open File Dialog issue


Recommended Posts

I'm used to use Evernote to save the list of file I'm working on to create a deploy script after the job is done.

Like this:

image.png.2c157ddf61506bacf91ce960898e2e73.png

Since last update of the desktop app (i´m using the latest now: 6.7.5.5825) when I copy the path and paste into an "Open File Dialog", it does not recognize it.

It´s like there is a non printable character at the content of the clipboard value.

"O nome do arquivo não é válido" is "File name is invalid" in portuguese.

image.png.988199c2a5da101d6dec78f707ab61c6.png

There is anyone else with the same issue?

I already tries to clean the format, but didn't work.

 

 

 

 

Link to post
  • Level 5*

Hi.  How did you try to clean the format?  Did you paste first into a text-only editor like Notepad and then copy/ paste again into the dialogue?  Does it help if you 'remove formatting' in the note before copying?

Link to post
  • Level 5*
4 hours ago, mcardia said:

I'm used to use Evernote to save the list of file I'm working on to create a deploy script after the job is done.

59e62f9e72034_ScreenShot2017-10-17at09_26_54.png.a825788449c3ee24e42976fa01dbf6b3.pngCan you display the actual link being opened
The example is from my Mac

Link to post
4 horas atrás, gazumped disse:

Hi.  How did you try to clean the format?  Did you paste first into a text-only editor like Notepad and then copy/ paste again into the dialogue?  Does it help if you 'remove formatting' in the note before copying?

Yes, i tried.

Paste in notepad and copy again works. But it´s not a solution.

Link to post
3 horas atrás, DTLow disse:

59e62f9e72034_ScreenShot2017-10-17at09_26_54.png.a825788449c3ee24e42976fa01dbf6b3.pngCan you display the actual link being opened
The example is from my Mac

It´s not a link. It´s only text.

Previous version for windows desktop used to convert file paths into links. But this feature was removed sometime (months) ago.

Link to post
  • Level 5

@mcardia, since you are working in Portuguese, I wonder whether the issue might be similar to the one that @saoki raised and solved here: https://discussion.evernote.com/topic/109622-encoding-troubles-while-importing-text-files/?do=findComment&comment=482353. It has to do with how copied text is encoded, although if the text is being copied from within Evernote, the other discussion may not be relevant.

 

Link to post
  • Level 5*
5 hours ago, mcardia said:

Paste in notepad and copy again works. But it´s not a solution.

Interesting that pasting to Notepad and copy pasting from there does work.  Seems to suggest that encoding isn't the issue,  but I don't know enough about this...

You might want to try Evernote support - if you're a paying customer you can reach out to Support directly on https://help.evernote.com/hc/requests/new or anyone can reach them on Twitter https://twitter.com/evernotehelps

Link to post
14 horas atrás, Dave-in-Decatur disse:

@mcardia, since you are working in Portuguese, I wonder whether the issue might be similar to the one that @saoki raised and solved here: https://discussion.evernote.com/topic/109622-encoding-troubles-while-importing-text-files/?do=findComment&comment=482353. It has to do with how copied text is encoded, although if the text is being copied from within Evernote, the other discussion may not be relevant.

 

Thank you for the tip. But is not the same. Important to say that in my path there is no special character or letters with accents like á ç ã. Not even spaces. My development tree is all lowercase, no spaces, and clean as possible. like instead of use "produção" (production) we use "producao" to avoid charset issues.

  • Like 1
Link to post
  • Level 5

OK, sounds like you've done all you can to prevent problems. Since this is only happening in the most recent update of the Windows desktop program (6.7.5.5825), it may well be something that Evernote has introduced somehow in their efforts to improve the editor. Are you able to examine the text that Evernote is placing on the clipboard to see what invalid characters it contains? That must be what's happening, since cleansing it through Notepad succeeds. Are you able to test with very short, simple paths (such as "c:\temp"), and increase the complexity until it fails? Or does it fail with even the simplest paths?

This definitely seems like a bug that should be reported directly to Evernote (this is only a user-to-user forum).

Link to post
1 hora atrás, Dave-in-Decatur disse:

OK, sounds like you've done all you can to prevent problems. Since this is only happening in the most recent update of the Windows desktop program (6.7.5.5825), it may well be something that Evernote has introduced somehow in their efforts to improve the editor. Are you able to examine the text that Evernote is placing on the clipboard to see what invalid characters it contains? That must be what's happening, since cleansing it through Notepad succeeds. Are you able to test with very short, simple paths (such as "c:\temp"), and increase the complexity until it fails? Or does it fail with even the simplest paths?

This definitely seems like a bug that should be reported directly to Evernote (this is only a user-to-user forum).

I got the chars that is causing de problema is the "newline and carriage return" chars. Even if I select the text char by char, when i copy the text to the clipboard, Evernote is adding they:

Evernote

image.png.86c0902f9ae320700f37cd117ef61062.png

Notepad++

image.png.be81256ed05c2790749136ab2cad22a2.png

I even tried to add 4 spaces at ending of the line, but still, when i copy (selecting only 2, to avoid the end of line), CR/LF is there.

image.png.142359d4cc694f8d7c2b9029dbc71706.png

image.png.9de0d4142faa327862f098c0e99a65e8.png

I think is a bug too.

But I´m not a paid user, so i can´t report. I tried twitter, let´s see...

Anyone here has a paid account and can report this?

Thanks everyone!

 

 

Link to post
  • Level 5

I've got an earlier version of Evernote (see my signature below), and I do not experience the problem. I just tested copying a couple of file paths from Evernote and pasting them into file open dialogs, and they worked properly. I hope Evernote will respond to you on Twitter. You've certainly isolated the problem, and the adding of CR+LF seems to be very unhelpful behavior. It's hard to imagine a situation in which it could be useful!

You mentioned that previous versions of the EN Windows desktop program converted file paths into links, but that the current version does not do so. Is it still possible to convert the paths to links manually, by selecting them and pressing Ctrl+K (and being sure that the link address has file:/// at the beginning)? Obviously that would be a lot of extra work in your situation, but it might at least give easy access to the linked files.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...