Jump to content

Copy / Paste issue with special characters


Recommended Posts

Hi All,

 

Every time I copy from Evernote to another app (like outlook on the Mac) I get issues with special characters. Below is an example

Evernote - this “happens"

Outlook - this “happens"

 

Anyone have a clue on why this is?

 

Cheers,

 

Liam

Link to post
  • Level 5*
5 hours ago, liambres said:

Every time I copy from Evernote to another app (like outlook on the Mac) I get issues with special characters. Below is an example

Evernote - this “happens"

Outlook - this “happens"

My suspicion is you have hidden characters in your Evernote note.  I'd export the note and look at the underlying html code

What font are you using.  This looks ok on my Mac using Helvetica font599c91764cf5c_ScreenShot2017-08-22at13_17_06.png.4379f6174b1ff38c0971fa55149fe977.png

Link to post

I've tested this in a number of fonts, including Helvetica. This appears to be a pure Mac issue as making a similar note on the iOS app works as expected. Even when copied to within the Mac. 

On export as an enex I get this - 

<en-note><div>“Test&quot;</div><div><br/></div><div>“Test”</div><div><br/></div><div><br/></div></en-note>

This is using Version 6.12 Beta 3 (455392 Direct)

Any ideas?

Link to post
  • Level 5*
17 hours ago, liambres said:

Every time I copy from Evernote to another app (like outlook on the Mac) I get issues with special characters. Below is an example

Evernote - this “happens"

 

18 minutes ago, liambres said:

On export as an enex I get this - 

<en-note><div>“Test&quot;</div><div><br/></div><div>“Test”</div><div><br/></div><div><br/></div></en-note>

I was expecting to see   this “happens"

Where are you copying from?

Link to post
  • 2 weeks later...
  • 4 months later...

I have this issue too on Mac.
I can not yet reproduce when it does/does not happen.

hex(and( not(BYTES + and(ADDR; 0x00FF) + (ADDR >>8) + and(DBIN0; 0x00FF) + (DBIN0 >>8) + and(DBIN1; 0x00FF) + (DBIN1 >>8) + and(DBIN2; 0x00FF) + (DBIN2 >>8) + and(DBIN3; 0x00FF) + (DBIN3 >>8) )+1; 0xFF ))
 
hex(and( not( and(0x0000; 0x00FF) + (0x0000 >>8) + and(0x1A40; 0x00FF) + (0x1A40 >>8) + and(0x0040; 0x00FF) + (0x0040 >>8) + and(0x0000; 0x00FF) + (0x0000 >>8) )+1 ; 0xFF ))
 
(this is copied as normal text (note the many >> characters)
But when I copy only one of the 2 rows (happens with both) the >> are converted to &gt;
 
I cannot find anything that breaks the correct formatting.
 
Link to post
  • 2 years later...

Not sure if this is helpful for Mac users, but I found this issue and played with the options settubgs to fix it. Hope this is helpful.

[When using "Find & Replace", characters where getting substituted]
On Windows 10, using Control + H, I'd paste $(date "+%Y-%m-%d_%H-%M-%S") into the search field and it would substitute a double quote character " with &quot ;
 
My fix was to go into options (Tools --> Options --> Note) and Uncheck "Automatically format text elements"
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...