Jump to content

Tags synchronization issue for shared notebooks

Recommended Posts

I noticed a long discussion about the fact that only the notebook owner can create tags for shared notebooks. The issue I'm describing here has nothing to see with this.

I have noticed that if I share a notebook, which contains certain tags, with another user, everything gets nicely synchronised. But, if I as owner add new tags to the notebook, after having it shared, those new tags do not synchronise to the shared users. The only way for the shared users to get the new tags, is to delete the shared notebook and to re-add it from the work chat, only then all tags get again synchronised, till the owner decides to add a couple of more new tags. I'm sure that you understand, when making a notebook and sharing it, that you as owner cannot foresee all the tags I will need in the future.

Link to comment
  • Level 5*
47 minutes ago, dominiquetanghe said:

The only way for the shared users to get the new tags, is to delete the shared notebook and to re-add it from the work chat, only then all tags get again synchronised, till the owner decides to add a couple of more new tags.

II just tested this;
- As owner, I added a new tag to a note in the shared notebook and sync’d 
- As a share, after syncing I see the updated note, the new tag, and am able to use it in the shared notebook

I did not have to delete/add the shared notebook

Link to comment

After your reply I tested it again between 2 Android phones. The behavior is weird. A notebook shared with 1 tag. Then I add couple of more tags,  really strange,  some get synchronised and some absolutely don't.

Apart from this, and that is where I actually noticed this first,  is on the Windows app for PC. After being shared not a single not gets synchronised. 

Link to comment
  • Level 5*

Is this a new issue
We started out discussing shared notebooks
Now it's about syncing and multiple devices

The master version of our data is maintained on the Evernote servers
Are you able to confirm the syncing issue by checking the notes using the web platform (www.evernote.com)

Link to comment

I do not see why this would be a new issue. The issue is,  at least in my tests, after sharing a note book, tags do not get synchronised correctly. Certainly not between PC's. Tags created on a PC after registering the notebook do not get synchronised. Tags created on an Android phone,  do get synchronised sometimes. After your post I did several tests and some tags come through,  others not. It is very frustrating as I use Evernote to share projects with colleagues. Thank you for your help. 

Link to comment

I did several test on this by sharing notebooks from one account to another. It is a very strange behavior. All tags, added at the moment of sharing or added later by the owner do display correctly in the Evernote Web version. Everything shows correctly. However when checking on Android devices as well as on PC the tags are not correctly synchronised, some show up up other not. I cannot not identify a specific behavior, but if you do some tests by adding tags from the owners account on an Android phone and then some tag from the share account's phone. All of it will show up correctly in the webversion, but not anymore in the Android nor Windows App. It is very frustrating if you want to use Evernote within colleagues and need them to check via phone and PC. I can certainly not be the only one facing this issue.

Link to comment


All the devices are running the last version of Evernote.

OPPO F3 with the Evernote App, signed into account DT.

Samsung J7 with Evernote App, signed into account SLS.

I'm using and Asus Windows PC with Evernote app installed (signed into account DT) and in Edge I'm signed into DT in the Evernote web portal and in Chrome into SLS.

Created notebook TEST1 on Samsung J7 (account SLS) with 1 note and 1 tag (tagtest1).

Tag appears in web portal of SLS.

On Samsung J7 I share the notebook TEST1 with user DT.

Open it via work chat on OPPO account DT: Notebook and note is there, but no tag. See screenshot: OPPO-DT-TEST1. Note that tag view tags is enabled, but even when opening the note the tag is not there.

In the web portal of DT the tag is there correctly. See screenshot: Webportal-DT-TEST1.

In the Windows portal of DT the tag is also there. See screenshot: Windows-DT-TEST1.

And obviously in the web portal of SLS all is correct as well. SLS is the owner of this TEST1 notebook.

Now SLS adds the tag tagtest2 from his Samsung J7 to the same note. The newly added tag is visible in: SLS webportal, of course also on SLS phone the Samsung J7.

It is also visible on DT webportal, gets also synchronised in the Windows portal of DT, but not on the OPPO phone of DT.

Now DT removes 1 tag in the Windows portal. This gets updated to both web portals of DT and SLS. And it gets synchronised to the Samsung J7 of SLS. In DT's OPPO still no tags are showing up.


Now I create a notebook in DT's OPPO and share it with SLS, notebook TEST2. And create 1 note in it with 1 tag. Shared it to SLS, on the Samsung J7 from SLS the tag is not appearing (webportals are OK, have the tag showing) and also DT's Windows portal shows the tag.

DT owner of the notebook now adds a tag in the Windows portal. The new tag gets synchronised to DT's OPPO, but not to SLS's Samsung J7.

DT owner add yet another tag in his OPPO, gets synchronised to both webportals and to DT's Window portal, but not to SLS Samsung J7.


I will now sign out DT from the Windows portal and sign in SLS (can't do this simultaneously as I have only 1 PC).

A new tag created in DT OPPO synchronises to the Windows portal of SLS, but not to the Samsung J7 phone of SLS.

In Windows account from SLS I created a new note in NOTE2 (owned by DT) and tag it with one of the existing tags. In SLS's Samsung J7 the note shows up, but without tag. In DT's OPPO the note shows up with the tag.

Now I have created another note in TEST1 (owner SLS) in the Samsung J7. It gets synchronised to SLS's Windows prtal, but not to DT's OPPO.


I also remember coming across case where it would not synchronise correctly from 1 Windows portal to another, with all changes done in the Windows portal, the note is there, but no tag.


It is very difficult to get some systematics in the behaviour, as it seems very random, but I'm sure there is a system behind the bug...

Thank you for your help, as when sharing amongst collegues it is very difficult if it does not synchronise correctly between different devices.






Link to comment
  • Level 5*

Hi.  This issue may seem random because it depends on the tmescale over which syncing takes place.  As @DTLow mentioned,  all devices sync with the server,  which is the central and prime copy of the database.  So if you make a change on one device,  it will sync the new tag to the server.  Now the next device has to sync its changes up,  and any new data down,  before it becomes 'aware' of the change.  Depending on whether the device has just logged into Evernote,  or has been running for a while and syncing every 15 minutes or so,  this could be up to 30 minutes after the original change was made.  On a mobile device you get the whole note downloaded when you open it to view.  If that copy remains on screen,  you won't see any changes made elsewhere in the meantime in your copy of the app,  because Evernote doesn't sync again until you exit the note.  What you may well then get is a 'conflicting changes' notebook because Evernote can't decide which remote change is the corrected latest version to save as the final copy.

Stock advice for anyone with a shared database missing tags is to log out of Evernote and then back in,  which forces a full sync and usually draws down any new changes.  You may find that your issue is resolved if you manually sync each phone before and after any changes to make sure that you have the latest version of a note to work on.

Link to comment
  • Level 5*

Hmmn.  OK - if you're already syncing before and after,  that can't be the issue.  Do you make any changes to the body of a note when adding a new tag?  I can remember a discussion about whether the updated date of a note should change when a new tag is added.  I think the current default is not to change that date.  (I just tested on a note of mine anyway,  and adding/ removing a tag didn't change that date.)

Maybe the note doesn't properly sync 'just' because you add a tag - maybe the note body has to have an added "." or something to change the updated date and force a full sync... ?

If that's not the trick,  I'd suggest you reach out to Support directly if you're a paying customer on https://help.evernote.com/hc/requests/new or tweet them if not via https://twitter.com/evernotehelps to see if they have any other suggestions.

Link to comment

Hi, no also this does not solve the problem. Tried to add some text in the body of the notes I had created earlier. That caused the newly added to synchronise, but not the tags. Even tried the whole process all over again, sharing a new notebook with a new note containing text in the tittle and the body and a tag. Exactly same problem. I can hardly believe that I'm alone on this one.

Link to comment
  • Level 5*
41 minutes ago, dominiquetanghe said:

logged a ticket by email

Not on the website?  Did you get a ticket number?  If you did,  please post the number here and we can flag the post for an Admin to chase up.  If you didn't get a ticket number,  you're not in the system...

Link to comment
  • Level 5*
On 2017-07-08 at 오후 0시 5분, dominiquetanghe said:

I will do some more testing on this and will also see and check the web version.

I added devices in my testing; Mac and iPad

So far, tag changes displayed ok

Link to comment

DTLow, did you test the synchronising within the same account to different devices? Or Synchronising of shared notebooks between different accounts? The first thing never has been an issue. Within the same account everything synchronises well between all devices. The problem is the synchronisation of tag for shared notebooks within different accounts. I have kept these TEST notebooks to see what happens, but still it remains the same, tags have not come. I do not know whether the same problem is there on MAC and IOS as I'm only using Android and Windows.

Link to comment
  • Level 5*
8 hours ago, dominiquetanghe said:

Posted my ticket to Twitter as well.  No reply so far. ?

If you posted your support request yesterday,  you should get some response in a day or two - it doesn't start out as a live conversation (though if you're a premium user there's a live chat opton on the support page).  Email response time tends to vary with how busy the department has been lately.

Link to comment
  • Evernote Staff*

Thanks for the reports @dominiquetanghe. We're aware of this issue and working on a fix that's scheduled to be in a future release. I do not currently have an ETA. I'll update here when I do. 

As you mentioned, the current workaround is for the joined user to remove and add the shared notebook back to their account. Thanks again for reporting this. 

Link to comment
  • 1 month later...

@Austin G

It is disappointing not to get any updated on this after 1 month.

The workaround I suggested is only valid in Windows if new tags are added after the notebook was shared and in case they do not synchronise correctly.

Between Android devices there is no fix or work around. I tested this further and at times tags synchronise but mostly they do not synchronise at all between users of shared notebooks (on Android devices). I think, so far as what I saw on Windows there is not really an issue.

I noticed that although the tags synchronise in the notes in the web portal, they are not listed in the tags list in the web portal. Maybe would this cause the problem?

Link to comment
  • 4 weeks later...
  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...