Jump to content
  • 1
Luiiiis

Problem with copying formatted code block

Idea

Hi all,

I recently updated my Evernote to the latest version, the old note with formatted code block just becomes to light text and background after the update. Also, it just gave me the plain text when I tried to copy some formatted code block to Evernote, but it's working fine on the web version. Is it a bug or I need to change the setting in the preferences in the new version? I attached two screen shot, one is the note on the mac version and you can see the code block's text is very light with no background color, another one is what it supposed to look like and it's normal on the web version.

The note on mac version.png

The note on web version.png

Share this post


Link to post

6 replies to this idea

Recommended Posts

  • 0

I agree that this is a problem in the new Evernote version for Mac: I remember that there was an issue with copying and pasting formatted text in earlier versions of Evernote 6.x for Mac. This problem was fixed at one point, but has now gotten un-fixed.

Share this post


Link to post
  • 0

I have a similar problem and contacted support about it just now...

Copying and pasting syntax highlighted code from various sources used to work. Now, when I do the same on the Mac (Version 6.11), it just copies with the default text, no highlighting.

Not only that, but I have now looked at my old notes, which had syntax highlighted code snippets, and they all look like this now:

59012f1fb98a1_Development__Evernote.png.c77ba3b18ea68384dd7edb0bdf11b31e.png

This should be a solid black box of highlighted code, using a monospaced font. The other notes are even worse.

I managed to add some highlighted code to Evernote Web, which worked as expected. However, when it syncs with the Mac version, it does the same thing as the screenshot above.

I'm a long time paid customer and this is the first time I've been quite annoyed, to say the least! If they fix this, I'm hoping the fix will work on the old notes too. Will wait and see what they com back with...

Share this post


Link to post
  • 0

Hi.  The latest Beta has some formatting fixes -

..which will make it to general release soon.  If it doesn't look like this will help,  this is a (mainly) user-supported forum.  It will help fix issues like this if you contact Support directly if you're a paying customer or tweet them if not..  https://help.evernote.com/hc/requests/new or https://twitter.com/evernotehelps 

Share this post


Link to post
  • 0
7 hours ago, renancamargo said:

@Luiiiis

How do I create block of code formatted with black background?

I am a programmer and wanted to add code fragments formatted in Evernote

 

http://markup.su/highlighter/

I'm using this website to generate the code block. The language auto detect is not working properly, but it provides you different options for the styles.

Share this post


Link to post
  • 0
23 hours ago, Luiiiis said:

http://markup.su/highlighter/

I'm using this website to generate the code block. The language auto detect is not working properly, but it provides you different options for the styles.

 
 

That Markup site is great. Been using it for a while. Even picks up my CMake files!

Another option is Visual Studio Code. They added this functionality a couple of versions back. Simply cut and paste the code from there.

 

Back to the issue at hand...

As @gazumped mentioned, the latest beta does indeed fix the issue. I was in contact with support who directed me to that, but one thing to bear in mind is that if you have made any changes to the affected notes, you'll need to grab an earlier version from your history to restore the formatting again. Luckily, for me, I only had to do this for two of my notes. The others just went back to normal automatically (phew!)

If it's any use, here's the email I got from Support:

Quote

 

Based on your description, our development team believes this issue is fixed in the most recent beta version of Evernote for Mac.

If you would prefer not to use a beta version, this should be fixed in the next update to the Mac desktop app. I don't have a firm timeline for when this will be released.

Please know that any affected note that was edited on 6.11 with not be automatically fixed on the update. You will need to restore the note from note history after updating to the beta. If you didn't edit the note in its altered state, it will automatically appear as expected after the update.

 

 
 

Hope this helps!

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...