Jump to content
  • 1

Firefox Addon Corrupt



Trying to install the Webclipper addon on Waterfox version 52.0.1 (64-bit)

I always get


The add-on downloaded from this site could not be installed because it appears to be corrupt


I tried with





Looking at the plugin contents, I don't see install.rdf, chrome.manifest, ...

How is this expected to install?


2017-04-11 14_28_39-.png

Link to comment

7 replies to this idea

Recommended Posts

  • 0
  • Level 5*

Hi - I'm currently using Firefox 52.0.2 64 bit and Clipper 6.10.2 without issues,  though I think the installation updated from a previous version (of both Firefox and Clipper).  Not clear what Waterfox is in relation to Firefox,  but maybe the difference is significant...

Link to comment
  • 0

Thanks @gazumped and sorry for the delayed response.

I switched to FF x64 and was able to install the Evernote addon

Sadly though, like many other users, I'm unable to use the addon in FF

It has the red dot which is supposed to Sign-In to Web Clipper when I click on it.

It comes up with a blank page, and nothing more.

If I sign-on to https://www.evernote.com/Home.action Manually.

The blank page does not even come on, nada.


Link to comment
  • 0
  • Level 5*

Hi again..  The red dot means you're not signed in to Evernote,  but the issue may be to do with the privacy settings on your browser,  or conflicts with other extensions.  Finding the cause may take a little time,  switching things off and checking whether the login goes ahead.

Link to comment
  • 0

Thanks again @gazumped.

I've given up on Evernote in Firefox, no wonder the plugin ratings is so low.

I spent a lot of time trying to isolate this.

Started with a fresh new Firefox profile and added the plugin, of course it works, I added few of my core plugins and setup as I usually do.

It broke with Tabs Mix Plus.

Went over every single setting of Tabs Mix Plus until I narrowed it down to "Enable to Single Window Mode", this needs to be disabled, for whatever reasons, otherwise the plugin opens an empty tab.

I figure ok, I can live with that, changed the setting on my main profile, and it was still broken.

Narrowed it down to having to delete evernote* cookies

Great, now I got a sign-in dialog, and entered my credentials.

Red dot did not disappear :(

Not only that, now if you click on it, you get a popup that disappears immediately, have to delete the cookies to get back to sign in popup, and of course you need to restart the browser in between.

After a lot more time wasted, it turns out if you have Third Party Cookies disabled, it will never work even on a virgin profile with only Evernote clipper installed.

You add couple of more addons and things break again.

Seriously who runs FF with no plugins and everything set to default? Do Evernote folk perform any tests or do they rely on customers finding bugs for them?

Thanks for listening to my rant.

Link to comment
  • 0
  • Level 5*

Yeah...  I may have shaken the glitch tree myself.  Because of problems with another app I disabled all my add-ins and deleted history and cookies to try and get back to basics.  Problem not solved,  but went back to normal browsing and re-enabled all the add-ins,  including Clipper...  and suddenly I'm now getting all the new user messages for Clipper and saving PDFs - and I had to log in to Clipper three times so far...

I'll see your rant and raise you... :)

  • Like 1
Link to comment
  • 0

I had to sign into evenote proper - I don't even get an option to sign in on the clipper.  Now it's just a white drop-down page and I can pretty much just cut and paste onto it - no other options.  It had worked great for years and now this.  I am soooo disappointed.  I recommended this to people when it was working...now I wish I hadn't.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...