Jump to content

Recommended Posts

Hi, after the upgrade a few days ago, I now cannot save attachments to my hard drive by right clicking a note in the list in the middle column (I have mine set up as links, note list, note preview).  It goes through the motions like it is going to save it but when you go to the folder and check, it's not there.  So, now it's like if I want to download the attachment to say rename it or something, I have to open it first and save it from Adobe.

Anyone else have that problem?  Should I re install?

Link to post
  • Level 5*

It's working fine for me. You might try a reinstall, yes.

 

Edit: Do you have On demand syn enabled (Tools / Options / Synchronization / Enable On Demand Sync)? There may be a problem there: 

 

Link to post

Uninstalled and reinstalled. No luck. I was trying to save about 90 ~1 MB attachments at once, so I tried smaller subsets, but the feature doesn't work even when I only select a single note. No message of any kind, error or otherwise. The dialogue closes and the folder remains empty.

Link to post

Well, maybe most people don't save stuff like you and I do Stephen, but this is DEFINITELY BROKEN.  I've spent way too much time trying to install reinstall resync etc..... Jefito, since you're a guru shepard for evernote, would you please look into this simple function that stopped working?

Link to post
  • Level 5*
2 hours ago, kennychua said:

Well, maybe most people don't save stuff like you and I do Stephen, but this is DEFINITELY BROKEN.  I've spent way too much time trying to install reinstall resync etc..... Jefito, since you're a guru shepard for evernote, would you please look into this simple function that stopped working?

"Guru" in this context means "I answered more questions than most, so I prob'ly know quite a bit about Evernote,  but I'm not an employee and any help I offer is in my own spare time".  IMHO if you have this problem,  you should report it to Evernote Support - We're a (mainly) user-supported forum,  not a direct feedback to the company, although developers will read these pages for feedback at some time.   It will help fix issues like this if you contact Support if you're a paying customer or tweet them if not..  https://www.evernote.com/SupportLogin.action or https://twitter.com/evernotehelps - the more reports they receive,  the more likely things are to get fixed... 

  • Like 1
Link to post
  • Level 5*
3 hours ago, kennychua said:

Jefito, since you're a guru shepard for evernote, would you please look into this simple function that stopped working?

I posted a link to gazumped's post where he reported something similar, which is why I asked the question that I did (to see whether you have the same situation as he does), but you didn't answer. As it is, he's already reported it in a forum thread where an Evernote developer has been present, so most likely opening a ticket would be redundant in this case, though not harmful either.

Link to post
1 hour ago, jefito said:

I posted a link to gazumped's post where he reported something similar, which is why I asked the question that I did (to see whether you have the same situation as he does), but you didn't answer. As it is, he's already reported it in a forum thread where an Evernote developer has been present, so most likely opening a ticket would be redundant in this case, though not harmful either.

Again, my apologies.  I thought that thread was about database size and SSD hard drives (I didn't have time to read all of it and how it led to csv files not saving.... was just careless in reading).  Anyway, I hope they fix this problem soon.

  • Like 1
Link to post
  • Level 5*
On 4/1/2017 at 11:18 PM, kennychua said:

Again, my apologies.

No problem. Sounds like you fell afoul of the same situation. 

On 4/1/2017 at 11:18 PM, kennychua said:

Anyway, I hope they fix this problem soon.

Yep, me too.

Link to post

In case anyone is interested, Evernote Support wrote back to me and said that they are aware of the issue and closed the ticket and asked me keep a watch out for the next upgrade.  They don't have a timeline for this.

Thanks.

  • Like 2
Link to post
  • Evernote Support Staff

Thank you for all of the reports. As @kennychua mentioned, a fix is scheduled for the next release. Current workarounds depend on the file type.

  • Images: Copy and Paste from the note to your desired location
  • PDFs: Print to PDF (Download Nitro PDF if you're on WIN 7 or 8 and need a print to PDF option) 
  • Office, Audio, Video and other files: Either right-click the file and select "Save As" or drag and drop it to the desktop
  • Like 4
Link to post

Please resolve this asap as this is such an inconvenience. I have exhausted a bunch of time trying to troubleshoot and honestly I am not very happy with the current issue. I know that there is a "fix" that is scheduled for the next release but when is that...seems like an open - ended answer.

  • Like 1
Link to post

In case it's helpful, I had resigned myself to waiting on the next release when I noticed the files I'd requested saved to my Downloads folder, meaning at least one of my attempts was successful. I had told them to save to a custom folder on the desktop, so it's still a bug, but it might be a temporary workaround for those who need it.

  • Like 1
Link to post

Really need a fix for this ASAP. In my case the problem is that I take multiple photos on a note - if I try to copy and paste individually the file name is the same each time so Windows asks me to overwrite which means I have to save a photo, then change that filename before I can save the next one. Impractical with multiple photos and very annoying

Link to post
  • Level 5*

Hi.  Have you tried right-click and Save As?  Slightly shorter...

I killed your other post on this topic by the way - duplicate threads just confuse things around here...

Link to post
  • Level 5*
1 hour ago, Ainsley004 said:

Really need a fix for this ASAP

 

On 4/4/2017 at 6:42 PM, Austin G said:

I don't have a current ETA on the fix. I'll post here as soon as I have an update.

 

You'll need to wait for the fix, like everyone else. Evernote knows about the problem, and they're working on it.

Link to post
2 hours ago, jefito said:

You'll need to wait for the fix, like everyone else. Evernote knows about the problem, and they're working on it.

Of course. I wasn't posting to suggest someone was going to sort this out specifically for me, but having been directed here by EN Support it seems reasonable to try and outline WHY this is important to me. Also that it's frustrating that something that I pay for and that has worked previously, suddenly stops working because of an update. 

Thanks

 

Link to post
9 minutes ago, Ainsley004 said:

gazumped - yes, that helps, thanks (and for closing the other thread - I was directed here by EN support so thought nit best to post here)

actually I've just realised that SAVE AS doesn't solve the problem - the file names are still the same so this just over-writes the last picture saved. Oh Well

Link to post
  • Evernote Support Staff

 @Ainsley004 Ideally we'd like all users to be on the latest build, but if this bug is killing your flow you can uninstall 6.5.4, and install the previous version (6.4.2) using these steps:

1. If Evernote is running, select **File > Exit** from the menu bar to exit the Evernote app
2. Click the 'Start' button to open your Start menu
3. Go to **Control Panel > Uninstall a program**
4. Select Evernote, then click **Uninstall**
5. Restart your computer
6. Exit Internet Explorer and Outlook (if installed & open)
7. Download and install (as an administrator) Evernote for Windows from http://cdn1.evernote.com/win6/public/Evernote_6.4.2.3788.exe
8. Open Evernote and log in to your Evernote account

 

  • Like 2
Link to post
1 hour ago, Austin G said:

 @Ainsley004 Ideally we'd like all users to be on the latest build, but if this bug is killing your flow you can uninstall 6.5.4, and install the previous version (6.4.2) using these steps:

1. If Evernote is running, select **File > Exit** from the menu bar to exit the Evernote app
2. Click the 'Start' button to open your Start menu
3. Go to **Control Panel > Uninstall a program**
4. Select Evernote, then click **Uninstall**
5. Restart your computer
6. Exit Internet Explorer and Outlook (if installed & open)
7. Download and install (as an administrator) Evernote for Windows from http://cdn1.evernote.com/win6/public/Evernote_6.4.2.3788.exe
8. Open Evernote and log in to your Evernote account

 

That's really cool - thanks. I resume I'll get prompts to re-install 6.5.4? How will I know when that is updated with the fix?

Link to post
  • Evernote Support Staff

Yes. You'll continue to be prompted to update when you launch EN - sry. The fix is currently scheduled to be included in the 6.6 release.  When 6.6 is available that prompt will update to list that version as the latest available. Additionally, I'll post here when it's available. 

 

 

Link to post

I am so glad someone posted a link to the old version.

I feel that the "lack of priority" for this issue is due to Evernote assuming that the majority of Evernote users don't use Evernote like we do.  Though we are a small group who'd use Evernote to store bulk scanned files, I want to download the attachments so I can rename them to something better than a serial number.  I guess most people don't work that way and hence "We'll get to it in the next release".  However, I am still also a paying customer.

Link to post
  • Level 5*
46 minutes ago, kennychua said:

I feel that the "lack of priority"

What lack of priority? You reported a bug 2 weeks ago (thanks for that), they've reproduced it and will roll out a fix in the next release. It will probably hit beta before then, I'd imagine. And general releases come out pretty often, though they don't appear have a regularly scheduled cycle; it's not like you need to wait a year before the next one, though.

47 minutes ago, kennychua said:

I guess most people don't work that way and hence "We'll get to it in the next release"

"Get to it"? Where did anyone from Evernote say this? You don't just hack in a quick fix and drop the next build out onto some 10's of millions of devices out there...

  • Like 1
Link to post
  • 3 weeks later...

Same problem here when trying to save the attachments to a specific directory but I found the files hiding in "C:\Users\[YourUserName]\AppData\Local\Apps\Evernote\Evernote" for some reason and was able to manually copy them over to the appropriate location.

  • Like 1
Link to post
On 4/13/2017 at 0:03 AM, jefito said:

What lack of priority? You reported a bug 2 weeks ago (thanks for that), they've reproduced it and will roll out a fix in the next release. It will probably hit beta before then, I'd imagine. And general releases come out pretty often, though they don't appear have a regularly scheduled cycle; it's not like you need to wait a year before the next one, though.

"Get to it"? Where did anyone from Evernote say this? You don't just hack in a quick fix and drop the next build out onto some 10's of millions of devices out there...

Here we are more than 6 weeks later and they still haven't fixed it.

I'm leaving Evernote because I've had enough of its bugs. Forget about machine learning or whatever you're all doing and fix the core functionality. That's what your users want.

Link to post
  • 2 weeks later...

I am an Evernote paying customer. 

I have been following this thread with keen interest as I also use the save attachments feature. The main reason I use Evernote is photographing my receipts and then saving the attachments so I can fill expense reports. Since the save attachments feature has stopped working, I am having to do this with alternative software. Please can you give a timeline for the update so resolve this?

Thanks,

Paul

  • Like 1
Link to post
  • Evernote Support Staff

This is now fixed in the 6.6 beta 1. You can find more info about that version, and a download link here

If you prefer to stick to general releases, you can roll back to 6.4.2 using the steps here. This issue only affects 6.5.4. Thanks for your patience. Please let us know if this issue continues with 6.6.1+.

 

  • Like 2
Link to post
  • 2 months later...

Hi folks,

As an alternative to this you could always email yourselves the note and then use your email program (i.e. Outlook) to export all attachments to your desktop.

For me this is the fastest workaround since I don't do this kind of thing often.

Thanks,
Lee

  • Like 1
Link to post
  • 2 weeks later...

I continue to be frustrated by the attachment issue.  I could save 100s of pdf attachments from my notes in evernote a separate directory on my hard drive.  The ability was lost on an update.  I was able to install an earlier version of evernote to deal with the issue while it was being remedied.  I then had issues with the earlier version since it would only selectively save some of the note attachments (not all that were batched).  A post suggested that the issue had been fixed but it still only saves some of the highlighted attachments.  I don't want to save each of them individually.  It will take forever.  What gives?  Updates should move the product forwards; not backwards  

Link to post
  • Evernote Support Staff
On 8/7/2017 at 11:52 AM, BDH63 said:

 A post suggested that the issue had been fixed but it still only saves some of the highlighted attachments.

As @gazumped mentioned, this should now be fixed with the current GA, 6.6. You can select Help > Check for Updates if you haven't been prompted to update yet. Please let us know if you have any issues saving attachments on 6.6. 

Link to post
  • 4 months later...
On 8/9/2017 at 8:41 PM, Austin G said:

As @gazumped mentioned, this should now be fixed with the current GA, 6.6. You can select Help > Check for Updates if you haven't been prompted to update yet. Please let us know if you have any issues saving attachments on 6.6. 

Hi. I've upgraded to version 6.8.7 and most of the attachments that used to be stored in the "attachment" folder disappeared.Only a few files remain (from different types).

Every time I open an attachment from a specific note a file with ".backup" extension is created in the "attachment" folder

How do I restore all the files attached to my notes to the "attachment" folder?

Does anyone have the same problem?

Link to post
  • Level 5*
On 20/12/2017 at 5:44 PM, Margarida said:

How do I restore all the files attached to my notes to the "attachment" folder?

Hi.  Your attachment folder is a temporary home for attachments that are being edited or printed outside Evernote.  The parent document is part of the Windows database EXB file and not visible as a separate entity.  It's not necessary to move a copy of each attachment into the folder,  and you should not be using that file directly - you may generate changes there that are not copied back into the original note attachment.  You could (and probably should) delete all files in that folder from time to time to save disk space and avoid duplications.

  • Like 1
Link to post
11 hours ago, gazumped said:

Hi.  Your attachment folder is a temporary home for attachments that are being edited or printed outside Evernote.  The parent document is part of the Windows database EXB file and not visible as a separate entity.  It's not necessary to move a copy of each attachment into the folder,  and you should not be using that file directly - you may generate changes there that are not copied back into the original note attachment.  You could (and probably should) delete all files in that folder from time to time to save disk space and avoid duplications.

Thanks so much for your help.

In previous versions of Evernote the attachment folder contained all of the attached files, so I found it weird when in the latest version that didn't hapened.

 

Link to post
  • Level 5*
3 hours ago, Margarida said:

Thanks so much for your help.

In previous versions of Evernote the attachment folder contained all of the attached files, so I found it weird when in the latest version that didn't hapened.

 

Hi again - previous versions of Evernote since I started using it (a while ago) have all followed the same pattern of including all attachments with the main database file.  If you were nervously checking each note and opening attachments,  I guess that might have put copies of the files into the folder,  but normally it has always operated mostly empty.  It's nothing to worry about anyway..  Happy holidays! :)

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...