Jump to content

Sync fails with security warning

Recommended Posts

Every now and then the following extremely annoying and data-losing thing happens to me:

  • Evernote attempts to sync.
  • A "Security Alert" dialog is displayed, saying: "This page requires a secure connection which includes server authentication. The Certificate Issuer for this site is untrusted or unknown. Do you wish to proceed?".
  • If I select "View Certificate", it transpires that the certificate it's complaining about says it's issued to and by "self-signedKey". I have the option of installing this in Windows's "Trusted Root Certification Authorities Store", which sounds like an incredibly bad idea.
  • Alternatively, I can select "No" (to the "Do you wish to proceed?" question), in which case sync fails. Or I can select "Yes", in which case the dialog goes away but it appears that sync has still not been successful. (There is an exclamation-mark-in-red-circle thing on the sync button in the UI.)

On previous occasions, I think this has gone away when I've exited Evernote and restarted it; I may perhaps have had to reboot the computer too. Obviously, doing this throws away any un-synced changes I have made in the Evernote client.

A little searching indicates that this has been happening to some Evernote users for several years. At least one person had a similar problem and was able to fix it by visiting the Evernote web client using a browser -- presumably this caused the necessary certificates to be installed, or something. I have tried this and it didn't help at all: the web client works fine, but after opening it in both my usual browser and Internet Explorer, the native desktop app still has the syncing problem.

So I have these questions:

  • In this situation, is there anything I can do that will not lose data? (You may assume that I cannot remember exactly what I have changed since the last time sync was successful. But maybe there's a way to get Evernote to display all not-yet-synced changes, or something?)
  • In this situation, is there an approved way to get Evernote syncing again?
  • Is there anything I or my computer might be doing to provoke this, and if so what could I change to make it less likely to happen?
  • Is this problem understood by the Evernote team? If so, is there any prospect that it will be fixed in the future?

(I am using version of the Evernote desktop client, on Windows 7.)

Link to comment

Looking through my activity log, the start of the trouble on this occasion seems to have gone like this:

  • 13:11:52 [50476] Client synchronization started
  • ... it then gets as far as "0% Loaded updateCount: 3782"; in previous successful syncs this has been immediately followed by "0% Usage Metrics: sessionCount=0" but on this occasion the next thing in the log is more than half an hour later:
  • 13:48:09 [36148] Comms Engine: getMessages
  • 13:48:09 [36148] Communication Engine client handler failed to retrieve cached events from local data store
  • ... and then the next thing, considerably later again, is ...
  • 15:18:34 [50944] 0% Can't send HTTP request, error: INTERNET_INVALID_CA
  • 15:18:34 [50476] Client synchronization finished, status: error
  • (This is clearly the same client sync, because it says "elapsed time: 2h 6m 42s". Also, the process ID or thread ID or whatever it is on the INTERNET_INVALID_CA line is the same as the one shown in the status messages immediately after "Client synchronization started".)

It looks as if there may have been some sort of internet outage somewhere around this time, because the next entries in the log are these

  • 15:19:50 [36148] Failed to retrieve messages from the Communication Engine Client
  • 15:19:50 [36148] * Received unexpected http content type: text/html

and the log contains the actual content it received -- which appears to be a login page from my ADSL modem! So, I checked with the ADSL modem and it appears that there was a brief internet outage somewhere around 13:12 -- i.e., at the time when sync started. But that's when the outage ended, and it can't have been very lengthy because (1) I would have other evidence of it and (2) the previous, successful, sync in the activity log is just 15 minutes before. So why is there nothing in the log until later? Well, I think 15:18 is when I sat down at the machine in question, saw the warning dialogs, and actually took any action.

Also possibly worthy of note: the issuer of the self-signed certificate is "Sagemcom", a name which also appears in a copyright notice on that ADSL modem login page.

So, it looks as if the sequence of events is as follows.

  • Up until, let's say, 13:10 all is well.
  • There is then a short network outage.
  • During this time, a sync begins at 13:11.
  • At this point my connection to the internet is broken, and somehow Evernote gets provided with a useless security cert from my ADSL modem. This confuses the Evernote client or some bit of networking machinery it depends on, and it pops up a warning dialog.
  • Until that dialog gets closed by the user, the thread that's trying to do the sync is blocked (and in particular it doesn't put any complaining messages in the log).
  • At 15:18, I come along and click the "No" button on the warning dialog, at which point sync can actually go ahead and fail, yielding a log message.
  • (I don't know what happened at 13:48.)

Anyway, after this the Evernote client (or some other thing it depends on) is plainly very confused because every subsequent attempt to sync fails. At this point, my internet connection is fine again and has been for hours; but somehow Evernote (or whatever other thing it's using) has become lastingly confused and there seems to be no way to say "no, you've got the wrong certificate, try the connection again from scratch".

It seems like maybe it would help if getting an INTERNET_INVALID_CA error provoked some sort of try-again-from-scratch response from Evernote.

Link to comment

On this occasion it turns out that exiting the Evernote client and running it again suffices to make the problem go away. Information in the activity log made it clear that in fact there were no local changes since the last successful sync.

It would be very useful to have some way to tell, when there have been local changes since the last successful sync, what they are.

Link to comment
  • Level 5*

Hi.  To set your mind at rest first - you're not losing any data.  The Evernote for Windows app is installed on your computer and includes a copy of the central database including all your notes.  If you make changes to any of those notes,  or add new ones,  they're stored in your computer first,  and then synced to Evernote's servers when a connection can be made.  If any single sync fails,  the notes that are due to be synced will be saved until the next opportunity arises.  So if you get a certificate problem,  just end the process.  Evernote will try again in due course.

As to the reasons for the security issue - no real clue.  It's possible that if you have a weak or intermittent internet connection,  or if the computer (or anyone else at your location) is trying to do something else that uses up connection speed,  the bad connection will cause a fault.

To check your sync settings,  go to Evernote > Tools > Options > Sync.

If the issue arises,  restart your system and just run Evernote - no other apps - and manually sync (F9)

Have a look at a List View of your notes,  and check for a column headed 'Sync' - a dot in that column means the note needs syncing.  (Right click the header menu of you don't see a Sync column - there are various options to select.)

If you click the 'info' button on any single note (" i ") a drop-down will show you the sync status of that note.

The only consideration here is:  if you edit your notes on another device,  you could wind up with two versions of that note if you have unsynced content on your computer and make changes to the current saved copy via another connection.

Evernote has 200M users,  and if this were a server problem you;d see a torrent of abuse by now about the issue.  As you are (AFAIK) the only person with this issue currently,  I would assume that it is something local to you,  rather than an Evernote issue.

Hope some of that helps...

Link to comment


It looks like you're right: if sync fails and I quit the Evernote client, I don't lose my local changes. I'm sure I remember getting an "Are you sure you want to quit without syncing? You will lose your changes" message on a previous occasion, but whether or not I'm imagining that it doesn't seem to happen now. That's a relief :-). And thanks for the advice on ways to identify things that need syncing.

As for the cause: if you have a look at my followup comment you will see that I have a conjecture about what happened. The underlying problem was indeed a local one -- but I think the Evernote client could have handled it a lot better.

Link to comment
  • Level 5*

Hmmn.  Yes,  a random internet outage would certainly count as a large spanner in the works.  It could be that it occurred after Evernote started to sync and got comfortable with the process,  and was just exchanging a periodic handshake to confirm the server was still receiving,  it got something out of left field that the developers hadn't forseen and built a response for - but there are so many possible edge cases for transmission problems from asteroid strike on down that it's possibly understandable why they didn't allow for them all...

Developers do read these posts,  so its possible you'll get a follow up question if they have any - but by documenting the issue you've alerted them to the fact that this is something they need to factor into sync checks and balances...  Hope the rest of your week is excitement-free...


Link to comment
  • 2 months later...

For the record, Gareth McCaughan is not the only person with this issue currently.
Recently, I've experienced exactly the same problem and, it appears to be, for exactly the same reason. In my case, the issuer of the certificate is "Huawei", the manufacturer of my fibre modem/router.
To be able to recover and allow Evernote to sync without this problem, I needed to exit from the Evernote desktop client and reboot the computer.
Also worth noting:
- Evernote is the only application that has this problem (including an application I've developed myself that syncs with OneNote).
- I'm running the desktop client build (304720) Public, under Windows 10.
- I agree with Gareth McCaughan that the Evernote client could have handled this issue a lot better, by, as he suggests, having the error provoke some sort of try-again-from-scratch response from Evernote.
- @gazumped Thanks for your interest and your useful comments.

Link to comment
  • 3 weeks later...

Yesterday (2017-04-25), my Evernote client (Windows 10, began popping up Security Alert windows about an expired www.comcast.net certificate.

This happens every time it tries to sync. It appears that the only way I'll be able to sync now is if I start trusting this self-signed certificate which describes itself as valid from 2014-09-17 to 2015-09-07. Why should I?

So Sync is now broken on Windows 10.

This is a critical bug.


Link to comment
  • Level 5*
1 hour ago, Tone Engel said:

So Sync is now broken on Windows 10

Sync is still working for me, on two Win 10 desktops. Wondering why the certificate in question is a Comcast certificate...

Link to comment
6 hours ago, Tone Engel said:

So Sync is now broken on Windows 10.

This is a critical bug.

@Tone Engel You can't make a sweeping statement like that on the basis of your own single experience! Sync still works perfectly for me on the same Evernote build on Windows 10.

Link to comment
6 hours ago, Tone Engel said:

an expired www.comcast.net certificate

Sounds like Comcast is doing something weird - you need to talk to your ISP. We (obviously) don't sign using a comcast certificate.

Link to comment

Thanks for responding so quickly that other's were not seeing this problem.

Problem disappeared after a reboot. Possibly originally caused by rebooting a router between Comcast and the computer without rebooting the computer. Only a guess though. Haven't seen this kind of a problem before and it was oddly specific - Only triggered by Evernote Sync function (not Dropbox, Google Drive, iCloud, etc...)

Link to comment

I have also been experiencing the same error on my Windows 10 machine for a few weeks. In my case, the offending certificate is at localhost.localdomain.

For me, restarting Evernote is not a solution, as the problem always returns on startup. I got a little relief for a couple weeks from upgrading Evernote to the latest version, but then the cert error returned.

The Windows Evernote app is definitely less tolerant of imperfect certificates for HTTPS with newer releases. I wish that Evernote would provide some more insight on the issue.

I do not have this issue on any of my other devices that run Evernote (Mac, Android, iOS), and I am able to browse in HTTPS with multiple browsers without issue.

Here's an excerpt from Evernote's log with the specific errors:


09:44:41 [265308] 0% Can't send HTTP request, error: INTERNET_INVALID_CA
09:44:41 [264356] Client synchronization finished, status: failed
09:44:41 [264356] * error: Could not connect to Evernote server
09:44:41 [264356] * elapsed time: 2m 39s
09:44:45 [265792] 100% Can't send HTTP request, error: INTERNET_INVALID_CA
09:44:45 [265800] 100% Can't send HTTP request, error: INTERNET_INVALID_CA




Link to comment
  • Level 5*
3 hours ago, modulist said:

I wish that Evernote would provide some more insight on the issue.

Hi.  We're (mainly) users here in the Forum,  not Evernote staff;  so certificate issues are definitely above our pay grade - although that's a very odd address (to me, anyway) you're getting an error from.  Are you connecting from a work network or from a domestic one?

To get some direct feedback from Evernote you could reach out to Support direct if you're a paying customer on https://help.evernote.com/hc/requests/new or tweet them if not via https://twitter.com/evernotehelps

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...