Jump to content

Did Evernote Outlining (Lists) Just Get Buggy?

Recommended Posts

I've been using Evernote for years to make outlines. Early on, it was kind of clunky. Strange things would happen when I tried to delete, cut, and paste.

In the last couple of years it seemed to get smoother, but now I'm getting weird behavior again. For example, if I'm working with a numbered outline (ordered list) with several levels of indentation and I cut a line, I will frequently (but not always) see a new line with a new number created at the first level of indentation just above where I cut. And sometimes when I cut multiple lines, the numbers of the lines I cut will not disappear. The text will be cut, but not the lines or the numbers. Weird.

My question is, did Evernote do something with the code that is causing this to happen? As I said, I don't recall having this problem all the way through 2015 and most of 2016. But just recently it feels like it's getting buggy again.

Link to comment

Thanks for the replies. I'm using Evernote for OSX, 6.10 454269 from the App Store.

Here's an example of an unexpected behavior on cut. Cutting the highlighted text below:

Screen Shot 2017-01-05 at 2.39.43 PM.png

Gives this result (but only once, mind you -- when I try to reproduce it after an undo, it works the way you would expect, deleting the text of the first heading and the entire second heading, leaving only the number of the first heading)

Screen Shot 2017-01-05 at 2.41.48 PM.png

And doing a forward delete from the cursor position below:

Screen Shot 2017-01-05 at 2.50.06 PM.png

Gives this result (instead of deleting the capital S to the right of the cursor, Evernote promotes the subheading, which is the same as it what does for a backspace delete):

Screen Shot 2017-01-05 at 2.41.12 PM.png

I've seen even stranger things than this, and if I can reproduce them I'll post them to this thread.

I agree that Workflowy is a much better outliner, but I'm trying to avoid having my content spread across too many different apps. So, I make do with Evernote and I keep hoping they'll improve the outlining functionality.


  • Like 1
Link to comment

Here is more strange outlining behavior. After adding a line at the first level of indentation in the middle of an outline, I attempted to indent the line below it:

1. The original outline:

Screen Shot 2017-01-09 at 12.38.10 PM.png

2. I added a line above line 22 above; the original line became line 23 as expected:

Screen Shot 2017-01-09 at 12.38.28 PM.png

3. But here's what happened when I tried to indent line 23 (using the tab key) -- the line indented as expected but then I also got a new blank line underneath it. Weird!:

Screen Shot 2017-01-09 at 12.37.32 PM.png

4. If I go back and undo it and repeat the steps above, it turns out right:

Screen Shot 2017-01-09 at 12.38.58 PM.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...