Jump to content
  • 0

6.9.2 - Important bug with hotkeys



  • Level 5

This bug was first noted in 6.9.453991 (posted about it here) but it still hasn't been fixed as of today's update - 6.9.2 (454158).  Is someone going to look at this bug??

I am reposting the details below for convenience:

I found a problem with this new keyboard shortcut system!  If you try to clear them in Preferences by pressing the "X" next to each action, it actually sets the shortcut to the letter "A" with no modifiers.


This causes a problem since now whenever the "a" key is pressed, it triggers the functions (create new note, etc).  Luckily I had another Mac that I hadn't tinkered with yet and was able to dig into the .plist to find the correct setting to mean "disable shortcut" and I ran these commands with Terminal:

defaults write com.evernote.evernote "ShortcutRecorder fullscreenshot" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder newnote" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder newnotewindow" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder pasteboard" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder screenshot" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder search" -dict keyCode -1 modifierFlags 0 modifiers 0

After running those, here's how the shortcut window looks:


The only cosmetic problem with this is that there is a subtle hint text now in the QuickNote window that displays a null character. This entire line should really be hidden if the shortcut is disabled:


Please fix this! (I am running v6.9.2-454158-Direct btw)

(sorry for the huge screenshots, that's how the forum displays them from my retina screengrabs...)

  • Like 1
Link to comment

7 replies to this idea

Recommended Posts

  • 0

This is much like the problem I've been having. When I clear the keyboard shortcuts, Evernote strangely assigns the keys "a", "b", "c" and so on to its own keyboard shortcuts. The assignments in the Evernote preferences pane look blank, but they are not.

I've worked around this by assigning very complex and never-used key assignments to the Evernote functions, such as Control+Command+Shift+F12 and so on. However, this is not a fix—it's a workaround. As of now, Evernote is "taking over" keystrokes such as "a", "b" and so on without warning, so this needs to be properly addressed by the developers.

I just sent a bug report to Evernote as well. Here's a screenshot of the problem.


Evernote keystroke assignment issue.png

Edited by endless_chap
Added image for explanatory purposes
Link to comment
  • 0
  • Level 5*

Hi.  Confusingly my mysterious post above was to a thread that included a post from Evernote Employee @BSR that said something to the effect of:

"Our developers are aware of this issue and are working on a fix. I do not have an ETA for when this will be released.  In the meantime, a workaround is selecting Evernote > Preferences > Keyboard Shortcuts from the menu bar and using modifier keys such as CTRL, OPT, or CMD + Letter to restore a shortcut.  Please let me know how this works out for you or if you have any questions!"

The link now seems to be broken,  so I'm not sure what's going on. :huh: 


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...