Jump to content

Welcome! You're currently a Guest.

If you'd like to join in the Discussion, or access additional features in our forums, please sign in with your Evernote Account here. Have an Evernote Account but forgot your password? Reset it! Don't have an account yet? Create One! You'll need to set your Display Name before your first post.

Photo
Safari

Safari Web Clipper beta

chrome clipper

  • Please log in to reply
29 replies to this topic

#1 jbignert

jbignert

  • Title: Browncoat
  • Group: Evernote Employee
  • 1,489 posts

Posted 10 July 2012 - 03:59 PM

Hi all,
We have a new version of the Safari Web Clipper that packs a lot of nice improvements. It has feature parity with Chrome Web Clipper and is completely rewritten. It should work on Safai 5.1 and aboce including Safari 6 beta.

If you report a bug please mention your OS version, Safari version, and the URL where the issue has been observed and an detailed steps necessary to reproduce it.

UPDATE - This version is now released. Thanks for all the people who tested it before release.

#2 Metrodon

Metrodon

  • PipPipPipPipPip
  • Title: Bankrobber
  • Group: Members
  • 4,789 posts

Posted 10 July 2012 - 04:09 PM

I assume we should delete the previous clipper before installing?

#3 tkaraszewski

tkaraszewski

  • Title: Member
  • Group: Evernote Employee
  • 47 posts

Posted 10 July 2012 - 04:38 PM

Yes, you should probably delete the old one before installing the new one (in theory, you can install both of them at the same time, but we haven't tried it).

#4 macfixer

macfixer

  • PipPipPipPip
  • Title: Shepherd
  • Group: Members
  • 168 posts

Posted 10 July 2012 - 04:56 PM

Hmmm, that didn't work too well...
[attachment=2692:clipper.jpg]

 

kyle (macfixer) demilo
i fix stuff :-)
http://MadeOn.LI


#5 tkaraszewski

tkaraszewski

  • Title: Member
  • Group: Evernote Employee
  • 47 posts

Posted 10 July 2012 - 05:03 PM

Hmmm, that didn't work too well...
[attachment=2692:clipper.jpg]


Did you try reloading the page? Neither Safari nor Chrome reliably loads required scripts into pages that were already open when an extension was installed, so reloading the page(s) after installation is the workaround for this. Any new page you open after the clipper is installed should be fine.

#6 macfixer

macfixer

  • PipPipPipPip
  • Title: Shepherd
  • Group: Members
  • 168 posts

Posted 10 July 2012 - 05:06 PM

The second time it worked!
[attachment=2693:clipping-1.jpg]

 

kyle (macfixer) demilo
i fix stuff :-)
http://MadeOn.LI


#7 Palladion

Palladion

  • Pip
  • Title: Member
  • Group: Members
  • 30 posts

Posted 10 July 2012 - 06:58 PM

This looks great. Thanks especially since the old old clipper was really unstable with rendering certain pages (e.g. amazon, etc.). Now I don't need to go to Chrome for just bookmarking.

#8 macfixer

macfixer

  • PipPipPipPip
  • Title: Shepherd
  • Group: Members
  • 168 posts

Posted 10 July 2012 - 07:27 PM

Evernote, I'm really happy for you and I'm gonna let you finish, but Chrome has the best Clearly plugin of all time! OF ALL TIME!

seriously, does this mean we're not getting Clearly on Safari?

 

kyle (macfixer) demilo
i fix stuff :-)
http://MadeOn.LI


#9 ilium007

ilium007

  • Pip
  • Title: Member
  • Group: Members
  • 14 posts

Posted 14 July 2012 - 02:41 AM

Why do I get the OSX 'dink' sound everytime I use up/down/left/right to position the Article window ? I still do not think this beta plugin is as good as the Chrome plugin. In Chrome the article selection seems to be a lot more accurate. This is the only think that keeps me from coming back to Safari from Chrome.

By the way, I am running on Mountain Lion and apart from this it seems to be working ok.

#10 tkaraszewski

tkaraszewski

  • Title: Member
  • Group: Evernote Employee
  • 47 posts

Posted 16 July 2012 - 11:36 PM

The "dink" sound has been fixed and shouldn't happen in the final version.

#11 drfrot

drfrot

  • Pip
  • Title: Member
  • Group: Members
  • 19 posts

Posted 24 July 2012 - 08:38 AM

How do I stop the "Get Web Clipper for Safari" page from loading every single time I launch Safari? I've uninstalled the previous clipper and downloaded the new one, but it just keeps coming back as a new tab! On on my machines! It's driving me mad!! (I have Lion's Restore feature deactivated, btw)

#12 jbignert

jbignert

  • Title: Browncoat
  • Group: Evernote Employee
  • 1,489 posts

Posted 24 July 2012 - 01:07 PM

@drfrot
Are you using the beta version from the top of this thread? If so I recommend uninstalling it from Safari and then visit www.evernote.com/webclipper to re-install the production version.
If the problem persists then please let us know and give us your OS version, Safari version.

#13 drfrot

drfrot

  • Pip
  • Title: Member
  • Group: Members
  • 19 posts

Posted 25 July 2012 - 06:37 PM

Thanks. No, I've only ever had the web clipper that I'm assuming updates through the Safari Extensions pane (yup - I've got the "Update automatically" box checked.

When this persistent page kept launching itself, I have uninstalled the Evernote clipper entirely and reinstalled using the link. But still it persists! On both my machines. Both are running:

Mac 10.7.4
Safari 5.1.7
Evernote 3.2.0

Something to do with caches? I do sync my ~/Library/Safari folder between Macs, using symbolic links with Dropbox, if that's any help.

G

#14 jbignert

jbignert

  • Title: Browncoat
  • Group: Evernote Employee
  • 1,489 posts

Posted 25 July 2012 - 06:45 PM

@drfrot
Ok thanks for the details, appreciate it. I don't have any recommendations at this point but we will look into this and see what is going on and will provide a fix as soon as we can.

#15 jkd032

jkd032

  • Pip
  • Title: Member
  • Group: Members
  • 3 posts

Posted 26 July 2012 - 05:49 AM


@jbignert


I also have the same issue as drfrot and opened a ticket on 7/24. Ticket#: 16051-126773. THANK YOU for addressing this issues as drfrot stated it is driving me nuts. Not that I needed any help.


I opened the ticket in the hopes no one else would stumble across the issue. I can go back to the previous Evernote Web Clipper 1.0.2 that I had installed and the problem does not exist. When I "Update" or do a "Clean" install of Web Clipper 5.6 the "Get Web Clipper for Safari" web page will re-open in another tab persistently.


Posted below is the info from the ticket describing the problem in detail. Thank You Again! I hope it is not too much text for the Post. This is my first post ever! Thanks!



First Thank You for one of the Best Applications I have ever used in my 26 years of computing.


This is in regards to the New Safari Web Clipper version 5.6 for the Mac.

Also I am running the current version of Lion (10.7.4) and the current version of Safari (5.1.7) as of 7/24/12.


After upgrading to Web Clipper 5.6 (I really like some of the New Features) from version 1.0.2 the Evernote Web Page will Automatically Open in a New "Additional" Tab next to my Default Apple Homepage/Tab when I quit Safari. Please Note: I am extremely systematic and anal on my processes. So No I Did Not already have the Evernote Web page or any other Tab or Web Page open when I quit Safari therefore upon Re-Opening Safari all windows/tabs from the Last Session would then re-open.


I always "Close" all Tabs except my default Apple Tab. I will then Clear my History and then Empty my Cache, I will then go to "Preferences" from within Safari and select the "Privacy" tab and "Remove All Web Site Data" and then I will then "Reset Safari". After all that has been done I will then "Quit" Safari.


But then when I re-open/relaunch Safari my default Tab/Web Page will open and then a second or two later the Evernote Web Page will open in another Tab. I hate to say this but quiet frankly it Pisses me off since I did not initiate this process.


Also Note: I Removed/Uninstalled version 5.6 and then Installed the Older 1.0.2 Extension and the Issue Did Not Occur. I have now tested this several times as I firmly believe that "One Time Does Not Constitute A Test."


I Tested this again by uninstalling the 1.0.2 and re-installing the 5.6 version and the Issue/Problem would re-appear.


Thank You so Much for Your Time and for a Great Application!!!

Regards,

JD


#16 tkaraszewski

tkaraszewski

  • Title: Member
  • Group: Evernote Employee
  • 47 posts

Posted 27 July 2012 - 08:13 PM

The Safari Clipper is intended to display that welcome page exactly once, and once it does, it stores a setting saying that it has been shown so that it won't appear again. If your regular ritual is to delete all your saved data every time you close your browser, then you are probably deleting this setting and so the Clipper will think that it hasn't displayed the welcome page and show it again next time it starts.

#17 g-a

g-a

  • Pip
  • Title: Member
  • Group: Members
  • 19 posts

Posted 28 July 2012 - 01:23 AM

Hi all,
We have a new version of the Safari Web Clipper that packs a lot of nice improvements. It has feature parity with Chrome Web Clipper and is completely rewritten. It should work on Safai 5.1 and aboce including Safari 6 beta.

If you report a bug please mention your OS version, Safari version, and the URL where the issue has been observed and an detailed steps necessary to reproduce it.

UPDATE - This version is now released. Thanks for all the people who tested it before release.


Hello!

I uninstalled the Safari extension yesterday, for it was blocking Google Ads.

Now I try to reinstall it via Evernote web page, but nothing happens.

OS X 10.8
Safari 6

#18 jkd032

jkd032

  • Pip
  • Title: Member
  • Group: Members
  • 3 posts

Posted 30 July 2012 - 02:24 AM

The Safari Clipper is intended to display that welcome page exactly once, and once it does, it stores a setting saying that it has been shown so that it won't appear again. If your regular ritual is to delete all your saved data every time you close your browser, then you are probably deleting this setting and so the Clipper will think that it hasn't displayed the welcome page and show it again next time it starts.



#19 jkd032

jkd032

  • Pip
  • Title: Member
  • Group: Members
  • 3 posts

Posted 30 July 2012 - 03:54 AM


@tkaraszewski

Thank you for the reply.


Yes I already figured, which to me was obvious that there was a trigger/flag that made the web clipper page open in another tab. But after this trigger/flag has been tripped the "End User UNDER NO Circumstance" should be able to reset this flag and be able to regenerate the re-opening of this page/tab.


It is true as you stated if I do not Empty the Cache, Clear the History and Reset Safari the web page will not re-open. But do you really think that an enduser is never going to do these general maintenance tasks ever. I can make this occur anytime I want with the current 5.6 Web Clipper for Safari. ANYTIME!


My work around was to go back to the Previous Web Clipper I was using v1.0.2, in which if I do the steps indicated does not trigger/open any additional tab/web page. Which is how it should work and did work.


I only "posted" and "opened" a ticket so this could be Reviewed and "TESTED" so as Others would not "ACCIDENTALLY STUMBLE" across this issue as Evernote User "drfrot" has. It is a certain set of steps (at least for me) to re-trigger the flag. But I or anyone else should not be able to re-trigger this action. I vaguely and I say vaguely remember that this happened to a previous version of the web clipper.


Send the information to your "Dev Team" for testing. I put all the necessary information in the ticket for testing. If an enduser/customer can create this and re-create this then it is NOT AN ANOMALY.


@tkaraszewski or any of the Exceptional Evernote staff. PLEASE, PLEASE, PLEASE Do Not Take Any of This Negatively because it is not meant to be in anyway! If I came off this way I do apologize. As an IT Support Tech myself I think stuff like this is FUN. I love testing and re-testing stuff. IT people do at times need to be ***** but I think its a blast. I only wish I knew and could have been part of the beta. I have worked in Technical EndUser/HelpDesk support for 20 years and it is with out a doubt one of the "Hardest" jobs but can also be one of the "Most Rewarding."


As I have said before the Evernote Team and Software is some of best I have ever seen in my 26 years of computing! I have not had as much fun since my early Mac days using the original MacPaint, MacWrite, MacDraw from Apple (later from Claris) and PageMaker from Aldus.


Thank You!!!

JD


#20 dlozow2002

dlozow2002

  • Pip
  • Title: Member
  • Group: Members
  • 2 posts

Posted 30 July 2012 - 04:49 PM

can not install webclipper on multiple macs...safari 5.7 running on 10.6.8





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Clip to Evernote