Jump to content

Welcome! You're currently a Guest.

If you'd like to join in the Discussion, or access additional features in our forums, please sign in with your Evernote Account here. Have an Evernote Account but forgot your password? Reset it! Don't have an account yet? Create One! You'll need to set your Display Name before your first post.

Photo
Mac

Solved Mac crashes and missing notes sync problem

sync problem mac evernote

  • Please log in to reply
1 reply to this topic

#1 supermonchi

supermonchi

  • Pip
  • Title: Member
  • Group: Members
  • 1 posts

Posted 18 December 2011 - 05:13 PM

My Evernote on Mac had been working beautifully until one day it must have had a conflict or something and just crashed the entire app. I couldn't even open the application on my Mac. It loaded but it wouldn't load any of my notes and all I got is a spinning icon which eventually led to an annoying "Application Not Responding" and the only thing I could do was Force Quit the application.

Thankfully all my notes were still intact on the web server, so I wasn't too worried about losing data, because I know it worked on the web client and also on my Android app, so I knew it was just a problem with my Mac.

I didn't do anything further since I wanted to upgrade my OS X 10.5.8 Leopard to the latest OS X 10.7 Lion anyway, so I thought might as well wait until the upgrade is done. I did that, and updated the software, hoping that it would just work itself out. Unfortunately it didn't, Evernote still kept crashing on my Mac upon opening.

After reading around how to refresh/rebuild the local database and to force sync to the web server, the suggested solution was to go to ~/Library/Application Support and rename or move the Evernote folder e.g. to Desktop. I did that and this time Evernote didn't crash on open and it did attempt to sync to the web server, but strangely a lot of my notes were missing.

After further reading around, I tried someone's suggestion to empty the trash and rename or move the ~/Library/Application Support/Evernote folder again like above to force the web sync. This time it worked, I got all my notes on my Mac now and everything seems to be working fine again.

I'm glad I was able to solve this problem. I thought I'd share my experiences perhaps it could shed some light to others facing the same problem.

Cheers!

#2 susanmillar

susanmillar

  • Pip
  • Title: Member
  • Group: Members
  • 1 posts

Posted 05 December 2012 - 06:08 AM

Thank you, this just helped me fix my issue :).
BTW, in Mac OSX Lion, ~/Library is hidden, probably because of a general unfamiliarity with its content. To access, simply open Finder, press Command+Shift+G, type in ~/Library and enter.





Also tagged with one or more of these keywords: mac, sync problem mac, evernote

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Clip to Evernote